Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 442734 - ~dev-util/systemtap-2.0 please stabilize
Summary: ~dev-util/systemtap-2.0 please stabilize
Status: RESOLVED DUPLICATE of bug 500728
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Sven Wegener
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 379117
Blocks:
  Show dependency tree
 
Reported: 2012-11-11 14:50 UTC by Andreis Vinogradovs ( slepnoga )
Modified: 2014-02-08 23:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreis Vinogradovs ( slepnoga ) 2012-11-11 14:50:13 UTC
Please stabilize ~dev-util/systemtap-2.0.
Version less 2.0 have more bag and very old.
Comment 1 Jaak Ristioja 2013-01-07 09:07:55 UTC
Systemtap 2.0 fails with newer kernels (tried with 3.7.0), but their git log appears to show like they have fixed it. Maybe apply some patches first?

# stap -ve 'probe begin { log("hello world") exit () }'
Pass 1: parsed user script and 89 library script(s) using 94896virt/21964res/3024shr/19320data kb, in 110usr/10sys/115real ms.
Pass 2: analyzed script: 1 probe(s), 2 function(s), 0 embed(s), 0 global(s) using 95424virt/22712res/3280shr/19848data kb, in 0usr/0sys/4real ms.
Pass 3: translated to C into "/tmp/.private/root/stapZoIuNp/stap_44505e534dd5cdf9c3f4862be9dff5b7_999_src.c" using 95424virt/23012res/3552shr/19848data kb, in 0usr/0sys/0real ms.
In file included from /usr/share/systemtap/runtime/linux/task_finder.c:17:0,
                 from /usr/share/systemtap/runtime/linux/runtime.h:169,
                 from /usr/share/systemtap/runtime/runtime.h:17,
                 from /tmp/.private/root/stapZoIuNp/stap_44505e534dd5cdf9c3f4862be9dff5b7_999_src.c:20:
/usr/share/systemtap/runtime/linux/task_finder2.c: In function '__stp_get_mm_path':
/usr/share/systemtap/runtime/linux/task_finder2.c:441:24: error: 'VM_EXECUTABLE' undeclared (first use in this function)
/usr/share/systemtap/runtime/linux/task_finder2.c:441:24: note: each undeclared identifier is reported only once for each function it appears in
make[1]: *** [/tmp/.private/root/stapZoIuNp/stap_44505e534dd5cdf9c3f4862be9dff5b7_999_src.o] Error 1
make: *** [_module_/tmp/.private/root/stapZoIuNp] Error 2
WARNING: kbuild exited with status: 2
Pass 4: compiled C into "stap_44505e534dd5cdf9c3f4862be9dff5b7_999.ko" in 3120usr/680sys/3921real ms.
Pass 4: compilation failed.  Try again with another '--vp 0001' option.
Comment 2 OGINO Masanori 2014-02-04 05:28:25 UTC
dev-util/systemtap-2.4 with sys-kernel/gentoo-sources-3.10.25 succeeded the test #1 showed.

$ uname -r
3.10.25-gentoo
$ stap --version
Systemtap translator/driver (version 2.4/0.149, non-git sources)
Copyright (C) 2005-2013 Red Hat, Inc. and others
This is free software; see the source for copying conditions.
enabled features: AVAHI LIBSQLITE3 NSS BOOST_SHARED_PTR TR1_UNORDERED_MAP NLS LIBVIRT LIBXML2
$ sudo stap -ve 'probe begin { log("hello world") exit () }'
Pass 1: parsed user script and 96 library script(s) using 118288virt/28512res/3128shr/26048data kb, in 140usr/10sys/150real ms.
Pass 2: analyzed script: 1 probe(s), 2 function(s), 0 embed(s), 0 global(s) using 118816virt/29304res/3232shr/26576data kb, in 10usr/0sys/4real ms.
Pass 3: translated to C into "/tmp/stapQHP5EM/stap_bd90ab0fbff648970504748d26c440dd_956_src.c" using 118816virt/29876res/3748shr/26576data kb, in 0usr/0sys/0real ms.
Pass 4: compiled C into "stap_bd90ab0fbff648970504748d26c440dd_956.ko" in 5980usr/610sys/6748real ms.
Pass 5: starting run.
hello world
Pass 5: run completed in 0usr/10sys/298real ms.
Comment 3 Pacho Ramos gentoo-dev 2014-02-08 13:44:57 UTC
Maybe a newer version would be a better candidate
Comment 4 Andreas K. Hüttel gentoo-dev 2014-02-08 23:46:36 UTC

*** This bug has been marked as a duplicate of bug 500728 ***