Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 442220 - app-editors/focuswriter - segmentation fault in Xfce4
Summary: app-editors/focuswriter - segmentation fault in Xfce4
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-07 17:29 UTC by Jean-Pierre de la Croix (jdelacroix)
Modified: 2013-04-05 15:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
strace focuswriter (focuswriter.strace,152.85 KB, text/plain)
2012-11-07 17:29 UTC, Jean-Pierre de la Croix (jdelacroix)
Details
backtrace (backtrace.log,2.40 KB, text/plain)
2012-11-07 18:09 UTC, Jean-Pierre de la Croix (jdelacroix)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Pierre de la Croix (jdelacroix) 2012-11-07 17:29:25 UTC
Created attachment 328710 [details]
strace focuswriter

=app-editors/focuswriter-{1.3.5.2,1.4.0} throws a segmentation fault when launching in Xfce4 (4.10) on amd64.

focuswriter runs successfully (tested) on KDE4, GNOME3, fluxbox, and X without a DE/WM.

Portage 2.1.11.31 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r3, 3.4.9-gentoo-beast x86_64)
=================================================================
System uname: Linux-3.4.9-gentoo-beast-x86_64-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-gentoo-2.1
Timestamp of tree: Wed, 07 Nov 2012 06:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -g0"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news noclean parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl amd64 apache2 berkdb bzip2 cli consolekit cracklib crypt cups cxx dbus dri fortran gd gdbm gpm iconv imagemagick ipv6 jpeg mmx modules mudflap multilib ncurses nls nptl opengl openmp pam pcre png policykit pppd python qt3support qt4 readline session sqlite sqlite3 sse sse2 ssl tcpd tiff truetype unicode vhosts zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jeroen Roovers gentoo-dev 2012-11-07 17:52:55 UTC
Could you provide a gdb backtrace, please?
Comment 2 Jean-Pierre de la Croix (jdelacroix) 2012-11-07 18:09:47 UTC
Created attachment 328728 [details]
backtrace

Attached backtrace for =app-editors/focuswriter-1.4.0 running from xterm in Xfce 4.10.
Comment 3 Davide Pesavento gentoo-dev 2012-11-07 20:49:44 UTC
CC'ing xfce.
Comment 4 Davide Pesavento gentoo-dev 2012-12-27 08:55:07 UTC
Can you try with qt 4.8.4 please?
Comment 5 Michael Palimaka (kensington) gentoo-dev 2013-01-06 15:59:32 UTC
(In reply to comment #4)
> Can you try with qt 4.8.4 please?

Upstream has released 1.4.1 which is a bugfix release. Could you please test this version. I am assuming you are running qt 4.8.4 since that is now stable.
Comment 6 Ben de Groot (RETIRED) gentoo-dev 2013-04-05 11:14:33 UTC
Since the bug reporter hasn't reacted to test requests in 3 months, and nobody seems to confirm this is still an issue, I am closing this as "NEEDINFO". Feel free to reopen when confirmed this is still an issue with latest stable (or latest ~testing).
Comment 7 Samuli Suominen gentoo-dev 2013-04-05 15:05:38 UTC
focuswriter-1.4.1 was the last one I tested, it was fine few weeks ago and it's still fine here
i'm using qt-4.8.4