Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 44216 - Gaim's "Show Empty Groups" option doesn't work
Summary: Gaim's "Show Empty Groups" option doesn't work
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gaim Bugs Crew
Depends on:
Reported: 2004-03-09 21:36 UTC by Paul Hoepfner-Homme
Modified: 2004-03-15 11:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Paul Hoepfner-Homme 2004-03-09 21:36:49 UTC
(I'm reporting this Gaim bug in the Gentoo Bugzilla, since that's what I was instructed to do when I last emerged Gaim.)

For as long as I've ever used Gaim on my Gentoo system, the "Show Empty Groups" option in the Buddies menu has never worked. Empty groups in my contact list are always displayed, whether "Show Empty Groups" is checked or not. This is very annoying because MSN always creates the default "Individuals" group which I do not use, and so I would not like it to clutter my contact list. But Gaim won't hide it, even though there are 0 contacts in that group. This is been Gaim's behaviour for every version I've used it, all the way up to version 0.75.

Reproducible: Always
Steps to Reproduce:
1. Install Gaim.
2. Add an MSN account and connect to it.
3. Delete all contacts from your Indiviuals group on your contact list.
4. Make sure Buddies > Show Empty Groups is unchecked.

Actual Results:  
The "Individuals" group stays visible in the contact list. 

Expected Results:  
The "Individuals" group should be hidden. 

paul@ball paul $ emerge info 
Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.3_pre20040117-r0, 
System uname: 2.4.22-gentoo-r5 i686 Intel(R) Pentium(R) III Mobile CPU      
Gentoo Base System version 
Autoconf: sys-devel/autoconf-2.58 
Automake: sys-devel/automake-1.7.8 
CFLAGS="-mcpu=pentium3 -O3 -pipe" 
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d" 
CXXFLAGS="-O2 -mcpu=i686 -pipe" 
FEATURES="autoaddcvs ccache sandbox" 
USE="X aalib alsa apache2 apm arts avi berkdb cdr crypt cups dga dvd encode 
fbcon foomaticdb gd gdbm gif gphoto2 gpm gtk gtk2 imlib java jikes jpeg kde 
libg++ libwww lirc mad mikmod motif mpeg mysql ncurses nls oggvorbis opengl 
oss pam pdflib perl png pnp python qt quicktime readline samba sdl slang spell 
sse ssl tcltk tcpd tetex truetype usb video_cards_radeon x86 xinerama xml2 
xmms xv zlib"
Comment 1 Don Seiler (RETIRED) gentoo-dev 2004-03-10 11:43:29 UTC
Just for clarity, exactly which package of gaim are you using?  gaim-0.75-r10?
Comment 2 Paul Hoepfner-Homme 2004-03-10 17:43:17 UTC
Comment 3 Don Seiler (RETIRED) gentoo-dev 2004-03-11 09:37:09 UTC
For starters I would emerge gaim with USE="debug" and run it as 'gaim -d', then see if the debug output says anything when you try to toggle the empty groups setting.
Comment 4 Paul Hoepfner-Homme 2004-03-11 09:43:35 UTC
I guess I could try this... but why don't you (or the gaim developers) try this? I've just reported what doesn't work; I figure it's the job of the developers to investigate why and to come up with a fix.

Also, why am I supposed to report this in Gentoo's bug database rather than gaim's? It hardly seems like a Gentoo-specific bug to me.
Comment 5 Don Seiler (RETIRED) gentoo-dev 2004-03-11 09:50:42 UTC
I would love to try it if I could duplicate it, but my empty groups hide just fine.  When we can't duplicate bugs, we have to rely on the bug reporters or users who can duplicate it to perform experiments for us.

I want you to report it here first so we can confirm if it is a gentoo-specific bug or not.  One never knows what problems crop up.  Feel free to search gaim's bug tracker to see if it is a known upstream bug.  If not I want to make sure it is their problem before passing it to them.  They don't like getting distro-related bugs.
Comment 6 Paul Hoepfner-Homme 2004-03-11 09:58:50 UTC
Okay, I didn't realize that you couldn't duplicate it. Sorry!

I've found this same bug in the Gaim bug database here: However, the report just got another "works for me" reply.

I tried fiddling around with the options some more, and I just found out that the "Show Empty Groups" option *does* work if "Show Offline Buddies" is unchecked. But I always have "Show Offline Buddies" checked. Can you see if you have the same behaviour?
Comment 7 Don Seiler (RETIRED) gentoo-dev 2004-03-11 10:08:04 UTC
If I check "show offline buddies", then the groups that have buddies will show up, even if no buddies are online.  However truly empty groups (like ~ and Individual) are still hidden.

While that particular bug isn't very helpful to the developers, it would seem to describe yours.  I'd still ask you to get some output from gaim-d or Help->Debug Window and capture the output when you check/uncheck show empty groups.
Comment 8 Paul Hoepfner-Homme 2004-03-11 10:28:59 UTC
This is all that's output when I check/uncheck "Show Empty Groups":

prefs: /gaim/gtk/blist/show_empty_groups changed, scheduling save.
Comment 9 Don Seiler (RETIRED) gentoo-dev 2004-03-15 11:11:04 UTC
Looks like they have acknowledged that behavior on the bug you referenced.  I'd suggest monitoring that bug from here on out.