Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 441876 - games-emulation/gens patch for amd64
Summary: games-emulation/gens patch for amd64
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords: KEYWORDREQ, PATCH
: 624358 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-05 13:48 UTC by haarp
Modified: 2018-04-29 09:50 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gens amd64 and menu entry patch (gens64.patch,1.27 KB, text/plain)
2012-11-05 13:48 UTC, haarp
Details
ebuild (file_441876.txt,1.12 KB, text/plain)
2016-06-26 00:52 UTC, cronolio
Details
gens build (gensbuild.log.tar.gz,37.06 KB, application/gzip-compressed-tar)
2016-06-26 00:59 UTC, cronolio
Details
gens-2.15.5-r1.ebuild (gens-2.15.5-r1.ebuild,1.12 KB, text/plain)
2016-09-11 00:11 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description haarp 2012-11-05 13:48:46 UTC
Created attachment 328454 [details]
gens amd64 and menu entry patch

I have successfully modified the gens ebuild to build a 32-bit binary on amd64. It is based on portage gens with changed taken from the v-fox overlay.

Also see bug 354411.

I also added a menu entry, make_desktop_entry at the bottom (which should be applied even if my 64 bit changes are rejected)
Comment 1 Agostino Sarubbo gentoo-dev 2012-11-18 13:20:18 UTC
@games, how sounds this for you?
Comment 2 Agostino Sarubbo gentoo-dev 2012-11-26 11:09:37 UTC
(In reply to comment #1)
> @games, how sounds this for you?

No response, cc back us if you need a double-check
Comment 3 haarp 2013-05-19 06:28:26 UTC
amd64 compilation recently broke again. configure complains about
'conftest.c(12): catastrophic error: cannot open source file "gtk/gtk.h"'

I have no idea why or how to fix it, though...
Comment 4 Michał Ziąbkowski 2015-01-25 17:19:58 UTC
What worked for me was commenting out the line with multilib_toolchain_setup and appending -m32 to CFLAGS. A bit ugly, but it makes the error go away.
Comment 5 haarp 2015-01-26 14:14:54 UTC
(In reply to Michał Ziąbkowski from comment #4)
> What worked for me was commenting out the line with multilib_toolchain_setup
> and appending -m32 to CFLAGS. A bit ugly, but it makes the error go away.

That's roughly what multilib_toolchain_setup is doing, too. I tried your way, but unfortunately it bails out aswell:

checking for GTK+ - version >= 2.4.0... 
*** 'pkg-config --modversion gtk+-2.0' returned 2.24.25, but GTK+ (2.24.23)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GTK+. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: *** GTK+ version 2.4.0 not found!
Comment 6 cronolio 2016-06-26 00:52:56 UTC
Created attachment 438820 [details]
ebuild
Comment 7 cronolio 2016-06-26 00:59:24 UTC
Created attachment 438822 [details]
gens build
Comment 8 Alex 2016-09-11 00:11:41 UTC
Created attachment 445426 [details]
gens-2.15.5-r1.ebuild

Here is cronolio's ebuild updated with pax-markings to make it work on my hardened system.

Works pretty fine for me.
Comment 9 haarp 2016-09-11 09:45:46 UTC
At this point I would actually suggest to deprecate gens in favor of gens-gs, which works fine on amd64. There are some overlays which carry it.
Comment 10 Raymond Jennings 2016-09-11 12:26:49 UTC
I dunno...I'm not really in favor of deprecating stuff just because it appears in an overlay.
Comment 11 Pacho Ramos gentoo-dev 2018-04-29 09:49:35 UTC
[master ad515498b9d9] games-emulation/gens: Drop games.eclass, add amd64 support (#441876)
 4 files changed, 54 insertions(+), 6 deletions(-)
 create mode 100644 games-emulation/gens/gens-2.15.5-r1.ebuild
Comment 12 Pacho Ramos gentoo-dev 2018-04-29 09:50:13 UTC
*** Bug 624358 has been marked as a duplicate of this bug. ***