Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 441624 - media-sound/pulseaudio-2.1-r1: KDE freezes when using pulseaudio.
Summary: media-sound/pulseaudio-2.1-r1: KDE freezes when using pulseaudio.
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Arun Raghavan (RETIRED)
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-03 20:53 UTC by Kelly Doran
Modified: 2013-05-22 04:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kelly Doran 2012-11-03 20:53:18 UTC
When starting up KDE from a cold boot, the system freezes for about 10-20 seconds... it is very annoying.  I went through the logs and saw that pulseaudio was starting multiple times and locking up on the second load.

There are two files that media-sound/pulseaudio-2.1-r1 installs into /etc/xdg/autostart, pulseaudio.desktop and pulseaudio-kde.desktop.  Both of these get executed at almost the same time and cause the lockup.  pulseaudio-kde.desktop has a line: "OnlyShowIn=KDE;", so it will only load when KDE loads.  pulseaudio.desktop has no limitations for what DE loads it.  This issue can be fixed by adding "NotShowIn=KDE;" into pulseaudio.desktop, which I think would be the best way to solve this since the other desktop file is designed specifically for KDE.  I have modified this file on my computer and it fixes the freeze, I recommend adding a patch for this or fixing this upstream.

Reproducible: Always

Steps to Reproduce:
1. Use pulse audio and kde.
2. Log into a kde session from a cold boot.
3. Watch the computer freeze up for about 10sec.
Actual Results:  
The system freezes when logging into KDE.

Expected Results:  
The system should NOT freeze when logging into KDE.
Comment 1 Wang Jiajun 2013-03-08 05:53:27 UTC
Yeah, it is an upstream bug.
Someone has already reported that.

https://bugs.freedesktop.org/show_bug.cgi?id=58758
Comment 2 Johannes Huber gentoo-dev 2013-04-22 08:55:09 UTC
Quote from upstream bug:
> Unsure about start-pulseaudio-x11, but confirming that adding  "NotShowIn=KDE;" > to the end of the pulseaudio.desktop fixed the delay in Archlinux + KDE 4.10 
> for me on multiple systems.

@Arun: please patch the pulseaudio.desktop file to make kde pulseaudio user smile again
Comment 3 Arun Raghavan (RETIRED) gentoo-dev 2013-04-22 09:15:16 UTC
Got this marked as a 4.0 blocker, so expect to have it fixed in the next release.
Comment 4 Arun Raghavan (RETIRED) gentoo-dev 2013-04-27 04:10:45 UTC
Posted this comment upstream as well, but more logs would help debug more quickly:

"""
Could someone set "log-level = debug" and "log-time = yes" in /etc/pulse/daemon.conf, reproduce this error, and post the logs here please?
"""
Comment 5 Arun Raghavan (RETIRED) gentoo-dev 2013-05-22 04:04:35 UTC
Can anyone verify whether this delay goes away when you add User=root to /usr/share/dbus-1/system-services/org.freedesktop.Avahi.service (or, start up avahi-daemon with /etc/init.d/avahi-daemon start)