Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 440508 - media-sound/pulseaudio-1.1-r1: some elog messages should only be shown for the first install.
Summary: media-sound/pulseaudio-1.1-r1: some elog messages should only be shown for th...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: first-time-messages
  Show dependency tree
 
Reported: 2012-10-31 10:59 UTC by poletti.marco
Modified: 2014-02-16 21:18 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description poletti.marco 2012-10-31 10:59:21 UTC
Disclaimer: this bug has been filed in a semi-automated manner.

When emerging the package media-sound/pulseaudio-1.1-r1, the following elog messages are displayed:

 * 
 * The Bluetooth proximity module is not enabled in the default
 * configuration file. If you do enable it, you'll have to have
 * your Bluetooth controller enabled and inserted at bootup or
 * PulseAudio will refuse to start.

Such messages should only be displayed when the package is a new install.
These situations can be checked in the ebuild as follows:

if ! has_version 'media-sound/pulseaudio'; then

See the tracker bug 440214 for more details.
Comment 1 Arun Raghavan (RETIRED) gentoo-dev 2012-12-07 20:08:23 UTC
Does this actually work in pkg_postinst?
Comment 2 Pacho Ramos gentoo-dev 2014-02-16 21:18:28 UTC
Done in 4.99.4