Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 440442 - sys-boot/grub-0.97-r12: some elog messages should only be shown for the first install.
Summary: sys-boot/grub-0.97-r12: some elog messages should only be shown for the first...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: first-time-messages
  Show dependency tree
 
Reported: 2012-10-31 10:58 UTC by poletti.marco
Modified: 2016-10-04 21:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description poletti.marco 2012-10-31 10:58:48 UTC
Disclaimer: this bug has been filed in a semi-automated manner.

When emerging the package sys-boot/grub-0.97-r12, the following elog messages are displayed:

 * 
 * To avoid automounting and auto(un)installing with /boot,
 * just export the DONT_MOUNT_BOOT variable.
 * 

Such messages should only be displayed when the package is a new install.
These situations can be checked in the ebuild as follows:

if ! has_version 'sys-boot/grub'; then

See the tracker bug 440214 for more details.
Comment 1 Ian Stakenvicius gentoo-dev 2016-10-04 21:05:38 UTC
Messaging could be made less verbose but since the grub:0 package exists now only to help maintain systems that haven't or can't easily migrate to another bootloader, these changes aren't going to be integrated.