Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 440432 - app-admin/eselect-wxwidgets-1.4: some elog messages should only be shown for the first install.
Summary: app-admin/eselect-wxwidgets-1.4: some elog messages should only be shown for ...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: first-time-messages
  Show dependency tree
 
Reported: 2012-10-31 10:58 UTC by poletti.marco
Modified: 2012-11-11 13:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description poletti.marco 2012-10-31 10:58:41 UTC
Disclaimer: this bug has been filed in a semi-automated manner.

When emerging the package app-admin/eselect-wxwidgets-1.4, the following elog messages are displayed:

 * By default the system wxWidgets profile is set to "none".
 * 
 * It is unnecessary to change this unless you are doing development work
 * with wxGTK outside of portage.  The package manager ignores the profile
 * setting altogether.

Such messages should only be displayed when the package is a new install.
These situations can be checked in the ebuild as follows:

if ! has_version 'app-admin/eselect-wxwidgets'; then

See the tracker bug 440214 for more details.
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2012-11-01 02:03:05 UTC
This is intentional.  You will not believe the number of times I have had to explain to developers that the eselect wxwidgets setting doesn't affect their packages.  The more times people see this reminder the better.
Comment 2 Pacho Ramos gentoo-dev 2012-11-11 13:46:40 UTC
(In reply to comment #1)
> This is intentional.  You will not believe the number of times I have had to
> explain to developers that the eselect wxwidgets setting doesn't affect
> their packages.  The more times people see this reminder the better.

Wouldn't be better to show it then only if profile is NOT set to "none"? The problem is that I am unsure about how to check it with eselect because, in my case, it simply shows it as selected to the only provider one :S
# eselect wxwidgets show
Current wxWidgets profile:
  gtk2-unicode-release-2.8  
# eselect wxwidgets list
Available wxWidgets profiles:
  [1]   gtk2-unicode-release-2.8 *