Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 440416 - kde-base/kdm-4.8.5: some elog messages should only be shown right after the relevant use flag is enabled.
Summary: kde-base/kdm-4.8.5: some elog messages should only be shown right after the r...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: first-time-messages
  Show dependency tree
 
Reported: 2012-10-31 10:50 UTC by poletti.marco
Modified: 2012-10-31 13:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description poletti.marco 2012-10-31 10:50:26 UTC
Disclaimer: this bug has been filed in a semi-automated manner.

When emerging the package kde-base/kdm-4.8.5, the following elog messages are displayed:

 * You have compiled 'kdm' with consolekit support. If you want to use kdm,
 * make sure consolekit daemon is running and started at login time
 * 
 * rc-update add consolekit default && /etc/init.d/consolekit start

Such messages should only be displayed when the package is a new install, or when the relevant USE flag is not enabled in the current installed version.
These situations can be checked in the ebuild as follows:

if use consolekit && ! has_version 'kde-base/kdm[consolekit]'; then

See the tracker bug 440214 for more details.
Comment 1 Chris Reffett gentoo-dev Security 2012-10-31 13:35:27 UTC
Already is USE-dependent, thank you very much. Fix your script, and review these before posting them.
Comment 2 poletti.marco 2012-10-31 13:38:28 UTC
The "if use consolekit" part is already there, yes.
But the "if ! has_version 'kde-base/kdm[consolekit]" part is not.

It's up to you to decide if you want to show this message at every update when the use flag is enabled, but this is not a bug in my script.