Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 440262 - qt4-build.eclass does not respect AR
Summary: qt4-build.eclass does not respect AR
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords: InVCS
: 440264 (view as bug list)
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2012-10-30 13:11 UTC by Agostino Sarubbo
Modified: 2012-11-12 09:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2012-10-30 13:11:19 UTC
ar cqs libbootstrap.a .obj/release-static/qisciicodec.o .obj/release-static/qlatincodec.o .obj/release-static/qsimplecodec.o .obj/release-static/qtextcodec.o .obj/release-static/qtsciicodec.o .obj/release-static/qutfcodec.o .obj/release-static/qglobal.o .obj/release-static/qmalloc.o .obj/release-static/qnumeric.o .obj/release-static/qabstractfileengine.o .obj/release-static/qbuffer.o .obj/release-static/qdatastream.o .obj/release-static/qdir.o .obj/release-static/qdiriterator.o .obj/release-static/qfile.o .obj/release-static/qfileinfo.o .obj/release-static/qfilesystementry.o .obj/release-static/qfilesystemengine.o .obj/release-static/qfsfileengine.o .obj/release-static/qfsfileengine_iterator.o .obj/release-static/qiodevice.o .obj/release-static/qtemporaryfile.o .obj/release-static/qtextstream.o .obj/release-static/qurl.o .obj/release-static/qmetatype.o .obj/release-static/qvariant.o .obj/release-static/qsystemerror.o .obj/release-static/qbitarray.o .obj/release-static/qbytearray.o .obj/release-static/qbytearraymatcher.o .obj/release-static/qdatetime.o .obj/release-static/qhash.o .obj/release-static/qlist.o .obj/release-static/qlocale.o .obj/release-static/qlocale_tools.o .obj/release-static/qmap.o .obj/release-static/qregexp.o .obj/release-static/qstring.o .obj/release-static/qstringlist.o .obj/release-static/qvector.o .obj/release-static/qvsnprintf.o .obj/release-static/qxmlutils.o .obj/release-static/qxmlstream.o .obj/release-static/qdom.o .obj/release-static/qxml.o .obj/release-static/qfilesystemengine_unix.o .obj/release-static/qfilesystemiterator_unix.o .obj/release-static/qfsfileengine_unix.o .obj/release-static/qlocale_unix.o
Comment 1 Davide Pesavento gentoo-dev 2012-11-01 08:47:35 UTC
*** Bug 440264 has been marked as a duplicate of this bug. ***
Comment 2 Davide Pesavento gentoo-dev 2012-11-06 09:04:00 UTC
The problem is that QMAKE_AR is defined as "ar cqs" for the default linux mkspec, so we should replace that with "$(tc-getAR) cqs".
But on mac and solaris, QMAKE_AR is just "ar cq", and on mac ranlib is used to build the archive index.

So I don't know if we can assume that the 's' flag is always supported by $(tc-getAR)...
@prefix, can we assume that or not?
Comment 3 Davide Pesavento gentoo-dev 2012-11-06 09:07:47 UTC
CC'ing bsd as well.
Comment 4 Fabian Groffen gentoo-dev 2012-11-06 09:37:50 UTC
Darwin ar understands s (IIRC it even needs that one on x86/Darwin).  On Solaris we use GNU binutils, which understands s obviously.  So I'd say, using s is fine.
Comment 5 Davide Pesavento gentoo-dev 2012-11-06 10:09:15 UTC
(In reply to comment #4)
> Darwin ar understands s (IIRC it even needs that one on x86/Darwin).  On
> Solaris we use GNU binutils, which understands s obviously.  So I'd say,
> using s is fine.

Awesome, thanks!
Comment 7 Naohiro Aota gentoo-dev 2012-11-11 09:33:17 UTC
FreeBSD ar also understand s.
Comment 8 Davide Pesavento gentoo-dev 2012-11-12 09:32:31 UTC
Applied to gx86. Thank you all!