Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 440104 - media-libs/lensfun-0.2.6 installs corrupted pkgconfig file
Summary: media-libs/lensfun-0.2.6 installs corrupted pkgconfig file
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
: 442524 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-29 09:24 UTC by Juergen Rose
Modified: 2014-08-15 17:51 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/media-gfx/rawstudio-2.0/temp/build.log (build.log,95.81 KB, text/plain)
2012-10-29 09:26 UTC, Juergen Rose
Details
/var/tmp/portage/media-gfx/rawstudio-2.0/work/rawstudio-2.0/config.log (config.log,47.55 KB, text/plain)
2012-10-31 20:13 UTC, Juergen Rose
Details
/var/tmp/portage/media-libs/lensfun-0.2.6/temp/build.log from moose (build.log,61.69 KB, text/plain)
2012-11-02 20:57 UTC, Juergen Rose
Details
/var/tmp/portage/media-libs/lensfun-0.2.6/temp/environment (temp_environment,213.74 KB, text/plain)
2012-11-02 21:02 UTC, Juergen Rose
Details
uncompressed /var/tmp/portage/media-libs/lensfun-0.2.6/build-info/environment.bz2 (environment,213.06 KB, text/plain)
2012-11-02 21:02 UTC, Juergen Rose
Details
modified lensfun-0.2.5_p153-build.patch (lensfun-0.2.5_p153-build.patch,2.00 KB, text/plain)
2012-12-03 16:19 UTC, Juergen Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2012-10-29 09:24:56 UTC
'emerge rawstudio' fails with:
...
/bin/sh ../libtool --tag=CXX   --mode=link x86_64-pc-linux-gnu-g++  -march=native -O2 -pipe  -Wl,-O1 -Wl,--as-needed -o librawstudio-2.0.la -rpath /usr/lib64 rs-debug.lo rs-io-job.lo rs-io-job-checksum.lo rs-io-job-metadata.lo rs-io-job-prefetch.lo rs-io-job-tagging.lo rs-io.lo rs-plugin.lo rs-rawfile.lo rs-exif.lo rs-1d-function.lo rs-icc-profile.lo rs-color-space.lo rs-color-space-icc.lo rs-image.lo rs-image16.lo rs-lens.lo rs-lens-db.lo rs-lens-db-editor.lo rs-lens-fix.lo rs-metadata.lo rs-filetypes.lo rs-filter.lo rs-filter-param.lo rs-filter-request.lo rs-filter-response.lo rs-library.lo rs-output.lo rs-plugin-manager.lo rs-job-queue.lo rs-utils.lo rs-math.lo rs-color.lo rs-settings.lo rs-spline.lo rs-curve.lo rs-tiff.lo rs-tiff-ifd.lo rs-tiff-ifd-entry.lo rs-huesat-map.lo rs-dcp-file.lo rs-profile-factory.lo rs-profile-selector.lo rs-profile-camera.lo rs-color-space-selector.lo conf_interface.lo rs-gui-functions.lo rs-stock.lo -pthread -Llib64/ -lgthread-2.0 -lrt -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgconf-2 -llcms -ldbus-1 -lexiv2 -lfftw3f -llensfun -lglib-2.0 -lflickcurl -lxml2 -lcurl -lsqlite3 -lssl -lgphoto2 -lgphoto2_port -lm -lexif -lX11   -ljpeg -ltiff  
../libtool: line 6007: cd: lib64/: No such file or directory
libtool: link: cannot determine absolute directory name of `lib64/'



root@cheetahnew:/root(5)# emerge --info '=media-gfx/rawstudio-2.0'
Portage 2.1.11.31 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r3, 3.6.1-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.6.1-gentoo-x86_64-Intel-R-_Core-TM-_i3-2120_CPU_@_3.30GHz-with-gentoo-2.2
Timestamp of tree: Mon, 29 Oct 2012 03:00:01 +0000
ld GNU ld (GNU Binutils) 2.23
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.9-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.2
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.4
sys-devel/binutils:       2.23
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo science sunrise lisp x-portage x-cpan x-g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-10.3 cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr ru"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/science /var/lib/layman/sunrise /var/lib/layman/lisp /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cgi chm cli consolekit cracklib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse g3dvl gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gstreamer gtk gtk3 gudev guile harness hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 id3tag ide imagemagick imap inotify ipod ipv6 ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdepim kdrive kerberos keymap kpathsea kqemu kvm ladspa lame lapack latex lcms ldap lensfun libffi libkms libnotify libsamplerate live lm_sensors lua lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp overview pam pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q32 qemu qhull qt3support qt4 quicktime raw readline reiserfs reports rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets soup sox speex spell sql sqlite sse sse2 sse4_1 ssl ssse3 subtitles subversion sudo suexec svg svm swig szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus threads thunderbird tidy tiff tk tools truetype udev unicode usb userlocales utempter vaapi video virtualbox visio vorbis wav webdav webdav-serf webkit wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

media-gfx/rawstudio-2.0 was built with the following:
USE="(multilib)"



root@cheetahnew:/root(6)# emerge -pqv '=media-gfx/rawstudio-2.0'
[ebuild   R   ] media-gfx/rawstudio-2.0
Comment 1 Juergen Rose 2012-10-29 09:26:07 UTC
Created attachment 327670 [details]
/var/tmp/portage/media-gfx/rawstudio-2.0/temp/build.log
Comment 2 Rafał Mużyło 2012-10-29 17:02:38 UTC
Attach config.log too.
We need to see where does '-pthread -Llib64/ -lgthread-2.0 -lrt' come from.
Comment 3 Juergen Rose 2012-10-31 20:13:43 UTC
Created attachment 327886 [details]
/var/tmp/portage/media-gfx/rawstudio-2.0/work/rawstudio-2.0/config.log
Comment 4 Samuli Suominen gentoo-dev 2012-10-31 20:24:47 UTC
I just have to ask to narrow one thing first down.

Is this with sysrescuecd? It has had this same problem for years now, exports something to the environment that confuses libtool. We have the bug reported here in our bugzilla, many times, by sysrescuecd users... if I just could remember the Subjects for search :-/
Comment 5 Rafał Mużyło 2012-10-31 21:28:23 UTC
(In reply to comment #4)
> I just have to ask to narrow one thing first down.
> 
> Is this with sysrescuecd? It has had this same problem for years now,
> exports something to the environment that confuses libtool. We have the bug
> reported here in our bugzilla, many times, by sysrescuecd users... if I just
> could remember the Subjects for search :-/

This looks significantly different than those sysrescuecd failures - there raw paths were pases, not something like '-Llib64/'.

The check seems to be for 'gtk+-2.0 >= 2.8.0 libxml-2.0 >= 2.4 gconf-2.0 >= 2.0 lcms dbus-1 exiv2 fftw3f lensfun libcurl flickcurl sqlite3 libssl libgphoto2 x11'.
Quite a lot of it.

You'll need to check with 'pkg-config --libs' each of them to see which one adds the value.
Then you'll need to trace it back to the *.pc file.
Comment 6 Juergen Rose 2012-11-01 12:01:20 UTC
Beside the fact that I used systemrescuecd for installing of gentoo and that there are some partition labels with sysresccd:

root@cheetahnew:/root(58)# blkid /dev/sda6
/dev/sda6: UUID="b6404946-65df-3b86-ffe8-65e0917887d8" UUID_SUB="0c263ab8-a3d9-2d4e-9d6c-2dca71336b69" LABEL="sysresccd:2" TYPE="linux_raid_member" 
root@cheetahnew:/root(59)# blkid /dev/sdb6
/dev/sdb6: UUID="b6404946-65df-3b86-ffe8-65e0917887d8" UUID_SUB="01f740c2-d0d8-7392-d089-9536b99e2c01" LABEL="sysresccd:2" TYPE="linux_raid_member" 

the system is now a normal gentoo system, booted from the harddisk.


I also tried the pkg-config calls:

root@cheetahnew:/root(68)# pkg-config --libs gtk+
Package gtk+ was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+' found
root@cheetahnew:/root(69)# pkg-config --libs libxml
Package libxml was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxml.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxml' found
[1]+  Done                    gparted /dev/sda
root@cheetahnew:/root(70)# pkg-config --libs gconf
Package gconf was not found in the pkg-config search path.
Perhaps you should add the directory containing `gconf.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gconf' found
root@cheetahnew:/root(71)# pkg-config --libs lcms
-llcms  
root@cheetahnew:/root(72)# pkg-config --libs dbus-1
-ldbus-1  
root@cheetahnew:/root(73)# pkg-config --libs exiv2
-lexiv2  
root@cheetahnew:/root(74)# pkg-config --libs fftw3f
-lfftw3f -lm  
root@cheetahnew:/root(75)# pkg-config --libs lensfun
-Llib64/ -llensfun -lglib-2.0  
root@cheetahnew:/root(76)# pkg-config --libs libcurl
-lcurl  
root@cheetahnew:/root(77)# pkg-config --libs flickcurl
-lflickcurl -lxml2 -lcurl  
root@cheetahnew:/root(78)# pkg-config --libs sqlite3 
-lsqlite3  
root@cheetahnew:/root(79)# pkg-config --libs libssl
-lssl  
root@cheetahnew:/root(80)# pkg-config --libs libgphoto2
-lgphoto2 -lgphoto2_port -lm -lexif  
root@cheetahnew:/root(81)# pkg-config --libs x11
-lX11  


I.e., "-Llib64/" comes from lensfun. I removed and reemerged lensfun:

root@cheetahnew:/root(85)# emerge -C lensfun
...
root@cheetahnew:/root(89)# emerge -vuND world
...

but nothing changes with pkg-config:

root@cheetahnew:/root(94)# pkg-config --libs lensfun
-Llib64/ -llensfun -lglib-2.0
Comment 7 Rafał Mużyło 2012-11-01 15:58:04 UTC
@comment 6: 
First a note: those names were taken straight from the check so i.e 'pkg-config --libs gtk+-2.0', but not really important.

Now, just to make sure, attach that pkg-config file from lensfun, so we could check if it's really there or is that inherited.
If the file's at fault, the herd is still the same, but the description (and package affected) wil need to be corrected.
Comment 8 Juergen Rose 2012-11-01 18:20:29 UTC
Still some more answers form pkg-config:

root@cheetahnew:/root(40)# pkg-config --libs gtk+-2.0
-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0  
root@cheetahnew:/root(41)# pkg-config --libs libxml-2.0
-lxml2  
root@cheetahnew:/root(42)# pkg-config --libs gconf-2.0
-lgconf-2 -lglib-2.0  


and the contents of lensfun.pc:

root@cheetahnew:/root(44)# cat  /usr/lib64/pkgconfig/lensfun.pc
Name: lensfun
Description: A photographic lens database and access library
Version: 0.2.6.0
Requires: glib-2.0
Libs: -Llib64/ -llensfun
Cflags: -I/usr/include/ 
root@cheetahnew:/root(45)#


What can I do more?
Comment 9 Juergen Rose 2012-11-01 18:21:44 UTC
On my other systems I have:

rose@leopard:/home/rose(56)$ cat /usr/lib64/pkgconfig/lensfun.pc
Name: lensfun
Description: A photographic lens database and access library
Version: 0.2.6.0
Requires: glib-2.0
Libs: -L/usr/lib64/ -llensfun
Cflags: -I/usr/include/
Comment 10 Rafał Mużyło 2012-11-01 19:15:02 UTC
OK, so it is caused by lensfun, but now the question is how do those systems differ.

Compare cmake versions, portage tree timestamp, try reemerging the working version to see if it breaks...
Comment 11 Juergen Rose 2012-11-01 19:48:51 UTC
I reemerged lensfun with a working lensfun.pc and now there is lensfun.pc also broken:

root@moose:/root(1)# cat /usr/lib64/pkgconfig/lensfun.pc
Name: lensfun
Description: A photographic lens database and access library
Version: 0.2.6.0
Requires: glib-2.0
Libs: -L/usr/lib64/ -llensfun
Cflags: -I/usr/include/ 
root@moose:/root(2)# emerge -v1 lensfun

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/lensfun-0.2.6  USE="doc sse sse2" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-libs/lensfun-0.2.6
 * lensfun-0.2.6.tar.bz2 SHA256 size ;-) ...

...

root@moose:/root(3)# cat /usr/lib64/pkgconfig/lensfun.pc
Name: lensfun
Description: A photographic lens database and access library
Version: 0.2.6.0
Requires: glib-2.0
Libs: -Llib64/ -llensfun
Cflags: -I/usr/include/
Comment 12 Juergen Rose 2012-11-01 19:50:52 UTC
I.e., should I open a new lensfun bug?
Comment 13 Rafał Mużyło 2012-11-02 02:38:02 UTC
(In reply to comment #12)
> I.e., should I open a new lensfun bug?

What for ? This one is just fine.

Attach build log for broken lensfun build.
environment file from that build *might* be useful too.
Comment 14 Juergen Rose 2012-11-02 20:57:16 UTC
Created attachment 328142 [details]
/var/tmp/portage/media-libs/lensfun-0.2.6/temp/build.log from moose
Comment 15 Juergen Rose 2012-11-02 21:02:04 UTC
Created attachment 328144 [details]
/var/tmp/portage/media-libs/lensfun-0.2.6/temp/environment
Comment 16 Juergen Rose 2012-11-02 21:02:44 UTC
Created attachment 328146 [details]
uncompressed /var/tmp/portage/media-libs/lensfun-0.2.6/build-info/environment.bz2
Comment 17 Rafał Mużyło 2012-11-10 03:02:50 UTC
*** Bug 442524 has been marked as a duplicate of this bug. ***
Comment 18 urcindalo 2012-11-10 07:35:01 UTC
I'm the original poster of Bug 442524, marked as a duplicate of this one.

As I said in Bug 442524 I'm an amd64 stable user. I just have a few ~amd64 packages installed, mostly science or photography related. I need lensfun-0.2.6 because it is the first version to include descriptions for micro-4/3 camera systems.

So, if lensfun-0.2.6 current incarnation is the culprit (Gentoo or upstream), might this also explain why my Olympus micro-4/3 lens description can't be found by digikam or any other kiki-plugins dependent package?

What are the options then for us, micro-4/3 users? Is the lensfun 0.2.6 ebuild to be fixed eventually? I'm not asking for or demanding it, I'm just asking to make up my mind on what steps or workarounds to follow.

I can offer my help for whatever developers may need.

Thanks.
Comment 19 Rafał Mużyło 2012-11-10 13:53:38 UTC
@comment 18: first we need to determine whether it's a bug in the build system, the ebuild or something portage related.

Current suspects (alternatives):
- in the ebuild, '-DLIBDIR=$(get_libdir)' might need to be '-DLIBDIR=/$(get_libdir)'
- in lensfun-0.2.5_p153-pc.patch, '${CMAKE_INSTALL_LIBDIR}/' might need to be '"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/'

Looking at the current state of svn, probably the later.
Comment 20 Juergen Rose 2012-12-03 16:17:15 UTC
I tried at first to change the ebuild:

 root@cheetahnew:/usr/local/portage/media-libs/lensfun(21)# diff -U2 lensfun-0.2.6.ebuild_orig  lensfun-0.2.6.ebuild
--- lensfun-0.2.6.ebuild_orig   2012-09-21 18:31:20.000000000 +0200
+++ lensfun-0.2.6.ebuild        2012-12-03 16:53:08.738402420 +0100
@@ -40,5 +40,5 @@
        local mycmakeargs=(
                -DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
-               -DLIBDIR=$(get_libdir)
+               -DLIBDIR=/$(get_libdir)
                -DBUILD_AUXFUN=ON
                $(cmake-utils_use_build doc)

But the resulting lensfun.pc is the same as before:

root@cheetahnew:/root(17)# cat /usr/lib64/pkgconfig/lensfun.pc
Name: lensfun
Description: A photographic lens database and access library
Version: 0.2.6.0
Requires: glib-2.0
Libs: -Llib64/ -llensfun
Cflags: -I/usr/include/ 



Then I returned to the original ebuild but changed files/lensfun-0.2.5_p153-pc.patch:

root@cheetahnew:/usr/local/portage/media-libs/lensfun(33)# diff -U2  files/lensfun-0.2.5_p153-pc.patch_orig files/lensfun-0.2.5_p153-pc.patch
--- files/lensfun-0.2.5_p153-pc.patch_orig      2012-07-02 18:31:18.000000000 +0200
+++ files/lensfun-0.2.5_p153-pc.patch   2012-12-03 17:04:08.397369132 +0100
@@ -8,8 +8,8 @@
 +IF(UNIX AND NOT APPLE)
 +  SET(CONF_VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_MICRO}.${VERSION_BUGFIX}")
-+  SET(CONF_LIBDIR "${CMAKE_INSTALL_LIBDIR}/")
++  SET(CONF_LIBDIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/")
 +  SET(CONF_INCLUDEDIR "${CMAKE_INSTALL_PREFIX}/${INCLUDEDIR}/")
 +  SET(CONF_LENSFUN_STATIC "")
 +  CONFIGURE_FILE("lensfun.pc.in" "lensfun.pc" @ONLY)
-+  INSTALL(FILES "${CMAKE_CURRENT_BINARY_DIR}/lensfun.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
++  INSTALL(FILES "${CMAKE_CURRENT_BINARY_DIR}/lensfun.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/pkgconfig")
 +ENDIF(UNIX AND NOT APPLE)


and the resulting /usr/lib64/pkgconfig/lensfun.pc seems to be OK:

root@cheetahnew:/usr/local/portage/media-libs/lensfun(32)# cat /usr/lib64/pkgconfig/lensfun.pc
Name: lensfun
Description: A photographic lens database and access library
Version: 0.2.6.0
Requires: glib-2.0
Libs: -L/usr/lib64/ -llensfun
Cflags: -I/usr/include/ 



And the following 'emerge rawstudio' works too.
Comment 21 Juergen Rose 2012-12-03 16:19:25 UTC
Created attachment 331314 [details]
modified lensfun-0.2.5_p153-build.patch
Comment 22 urcindalo 2012-12-06 09:40:44 UTC
(In reply to comment #21)
> Created attachment 331314 [details]
> modified lensfun-0.2.5_p153-build.patch

I think the "modified" patch is the same old one, according to kdiff3 and my results compiling rawstudio with it. Maybe you attached the wrong one? :)

I had to manually edit /usr/lib64/pkgconfig/lensfun.pc to include the correct Libs path.
Comment 23 urcindalo 2012-12-07 09:45:19 UTC
Hmm, the pacth file to modify is lensfun-0.2.5_p153-pc.patch, not lensfun-0.2.5_p153-build.patch

You uploaded the wrong file after fixing the correct one. This also explains why I couldn't find your diff changes in the uploaded "modified" patch. Now that I have modified the lensfun-0.2.5_p153-pc.patch as per your suggestions, lensfun-0.2.6 installs the correct /usr/lib64/pkgconfig/lensfun.pc file.

Thanks very much.
Comment 24 Andreas Sturmlechner gentoo-dev 2013-05-20 11:55:10 UTC
So, is that fixed by the mentioned patch and/or upgrade to 0.2.7?
Comment 25 Markus Meier gentoo-dev 2014-06-15 11:55:34 UTC
I guess this is fixed in -0.2.7/8?
Comment 26 Nikoli 2014-08-15 17:51:45 UTC
$ cat /usr/lib64/pkgconfig/lensfun.pc
prefix=/usr
bindir=/usr/bin
libdir=/usr/lib64
includedir=/usr/include
datadir=/usr/share/lensfun
docdir=/usr//usr/share/doc/lensfun-0.2.8-r1/html

Name: lensfun
Description: A photographic lens database and access library
Version: 0.2.8.0
Requires.private: glib-2.0
Libs: -L${libdir} -llensfun
Cflags: -I${includedir} -I${includedir}/lensfun


I think docdir=/usr//usr/... is wrong.