Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 439894 - app-text/stardict - configure.ac:310: error: possibly undefined macro: AM_GCONF_SOURCE_2
Summary: app-text/stardict - configure.ac:310: error: possibly undefined macro: AM_GCO...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-27 15:51 UTC by unknown
Modified: 2014-05-09 14:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info.txt,4.20 KB, text/plain)
2012-10-27 18:47 UTC, unknown
Details
build log (stardict-build.log,66.85 KB, text/plain)
2012-10-27 18:48 UTC, unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description unknown 2012-10-27 15:51:55 UTC
gnome-base/gconf is a build dependency of the stardict-3.0.3-r2:

...
m4/libtool.m4:1022: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:5360: _LT_LANG_CXX_CONFIG is expanded from...
m4/libtool.m4:785: _LT_LANG is expanded from...
m4/libtool.m4:768: LT_LANG is expanded from...
configure.ac:24: the top level
configure.ac:310: error: possibly undefined macro: AM_GCONF_SOURCE_2
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
Comment 1 Samuli Suominen gentoo-dev 2012-10-27 16:15:29 UTC
The package doesn't use autotools.eclass and thus, eautoreconf so it shouldn't be rerunning aclocal, autoconf etc.

So indeed, if it was to be intended, gconf would be always a DEPEND but since this shouldn't have happened at all...

File full build.log as well as emerge --info
Comment 2 unknown 2012-10-27 18:47:51 UTC
Created attachment 327536 [details]
emerge --info
Comment 3 unknown 2012-10-27 18:48:47 UTC
Created attachment 327538 [details]
build log
Comment 4 Samuli Suominen gentoo-dev 2014-05-09 14:19:29 UTC
I couldn't reproduce this with 3.0.4, please try that, it's in Portage as of today.
If you still can reproduce this, please reopen the bug, and we will have to reconsider making the ebuild run eautoreconf to prevent it...