Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 439724 - >app-editors/leo-4.9 USE =tk is not needed anymore
Summary: >app-editors/leo-4.9 USE =tk is not needed anymore
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-26 08:18 UTC by Wang Bin
Modified: 2015-11-11 11:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wang Bin 2012-10-26 08:18:50 UTC
Leo no longer supports the Tk gui since version 4.9, please check the "What's new in Leo" page: 

http://webpages.charter.net/edreamleo/what-is-new.html?highlight=release%20note#deprecated-removed-features

Please remove "tk" USE.

Reproducible: Always




emerge -av leo

[ebuild  N     ] dev-lang/tcl-8.5.11-r1  USE="-debug -threads" 4,379 kB
[ebuild  N     ] dev-lang/tk-8.5.11-r1  USE="truetype (-aqua) -debug -threads -xscreensaver" 3,721 kB
[ebuild  N     ] dev-tcltk/blt-2.4z-r10  USE="X jpeg -static-libs" 2,272 kB
[ebuild   R    ] dev-lang/python-2.7.3-r2:2.7  USE="gdbm ncurses readline sqlite ssl threads tk* (wide-unicode) xml -berkdb -build -doc -examples -ipv6 -wininst" 11,531 kB
[ebuild  N     ] app-editors/leo-4.10  0 kB
Comment 1 Justin Lecher gentoo-dev 2015-11-11 11:36:03 UTC
commit b2142092eaf4d8d2f7e394a441b77b0d245b352d
Author: Justin Lecher <jlec@gentoo.org>
Date:   Wed Nov 11 12:11:42 2015 +0100
    
    app-editors/leo: Drop old
    
    obsoletes:
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=439724
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=539000
    
    Package-Manager: portage-2.2.23
    Signed-off-by: Justin Lecher <jlec@gentoo.org>
    
    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b2142092eaf4d8d2f7e394a441b77b0d245b352d