Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 439662 - dev-lang/python: pydoc-* init scripts should drop need net
Summary: dev-lang/python: pydoc-* init scripts should drop need net
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
: 439664 (view as bug list)
Depends on:
Blocks: need-net
  Show dependency tree
 
Reported: 2012-10-25 18:34 UTC by Matthew Schultz
Modified: 2014-10-12 12:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Schultz 2012-10-25 18:34:14 UTC
This service fails to start on a my machine with a nfs network root mounted filesystem:

Service `pydoc-2.7' needs non existent service `net'

Reproducible: Always
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-10-26 16:14:00 UTC
*** Bug 439664 has been marked as a duplicate of this bug. ***
Comment 2 Patrick Lauer gentoo-dev 2013-10-10 04:13:30 UTC
Makes no sense to have that with newer openrc, and it doesn't usually do the right thing with older openrc ...
Comment 3 Ben Kohler gentoo-dev 2014-10-10 13:24:45 UTC
Do this, please.  There is no reason net must be up for this to start, it does not need to bind to a specific IP or connect to external services.
Comment 4 Dirkjan Ochtman gentoo-dev 2014-10-12 12:38:42 UTC
Thanks for the ping. I don't think revbumping everything for this makes sense, so only newly installed python will get the net-depend-less init script.