Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 439656 - media-tv/mythtv mythbackend init script should drop need net
Summary: media-tv/mythtv mythbackend init script should drop need net
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: MythTV Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: need-net
  Show dependency tree
 
Reported: 2012-10-25 18:27 UTC by Matthew Schultz
Modified: 2015-09-16 18:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
mythbackend.init (mythbackend,1.38 KB, text/plain)
2014-12-12 20:10 UTC, Matthew Schultz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Schultz 2012-10-25 18:27:04 UTC
This service fails to start on a my machine with a nfs network root mounted filesystem:

Service `mythbackend' needs non existent service `net'

Reproducible: Always
Comment 1 Doug Goldstein gentoo-dev 2012-10-26 22:19:03 UTC
Well you should not have a non existent service on net. That's not what the tracker that you referred to is about. Future versions will move the need into the configuration file.

The issue you're seeing is unrelated.
Comment 2 Matthew Schultz 2012-10-27 04:16:23 UTC
(In reply to comment #1)
> Well you should not have a non existent service on net. That's not what the
> tracker that you referred to is about. Future versions will move the need
> into the configuration file.
> 
> The issue you're seeing is unrelated.

I'm not sure what you mean.  The interface already exists since a nfs root filesystem boots off the network.  Since the network interface already exists, openrc should not try to bring it up or down which is why I have this in /etc/conf.d/network:

rc_provide="!net"

These latest changes to openrc do not allow me to bring up any service that specifies need net in the init script until the need net line is removed or rc_need="!net" is specified in that service's configuration file.

In these future versions you're referring to, are you're saying that I will need to disable this need net in every configuration file for each service that specifies need net for a machine with a network mounted nfs root filesystem?
Comment 3 Doug Goldstein gentoo-dev 2012-10-27 06:09:55 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Well you should not have a non existent service on net. That's not what the
> > tracker that you referred to is about. Future versions will move the need
> > into the configuration file.
> > 
> > The issue you're seeing is unrelated.
> 
> I'm not sure what you mean.  The interface already exists since a nfs root
> filesystem boots off the network.  Since the network interface already
> exists, openrc should not try to bring it up or down which is why I have
> this in /etc/conf.d/network:
> 
> rc_provide="!net"

Right. You're using the supposed "newnet", which is really just BSD style configuration which is broken for a dependency based init system. And disabling the one thing that newnet is able to provide is not correct, hence the configuration is invalid.
Comment 4 Matthew Schultz 2012-10-28 04:57:08 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > Well you should not have a non existent service on net. That's not what the
> > > tracker that you referred to is about. Future versions will move the need
> > > into the configuration file.
> > > 
> > > The issue you're seeing is unrelated.
> > 
> > I'm not sure what you mean.  The interface already exists since a nfs root
> > filesystem boots off the network.  Since the network interface already
> > exists, openrc should not try to bring it up or down which is why I have
> > this in /etc/conf.d/network:
> > 
> > rc_provide="!net"
> 
> Right. You're using the supposed "newnet", which is really just BSD style
> configuration which is broken for a dependency based init system. And
> disabling the one thing that newnet is able to provide is not correct, hence
> the configuration is invalid.

William mentioned that this is needed in addition to rc_need line in the conf.d configuration file in bug 425130.  Is rc_provide="!net" not needed then and only rc_need="!net" in this scenario?
Comment 5 Matthew Schultz 2014-12-12 20:10:23 UTC
Created attachment 391520 [details]
mythbackend.init

Removed need net from mythbackend init script
Comment 6 Doug Goldstein gentoo-dev 2015-09-06 03:42:17 UTC
Sorry for the long delay but this will be addressed in the next 0.27.5 bump.
Comment 7 Doug Goldstein gentoo-dev 2015-09-16 18:04:10 UTC
Thanks for the report. Fixed in http://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9ada29b52010e465a522fdc68d4eee0da6eaa349