Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 439514 - =dev-qt/qt-creator-2.6* - 3rdparty/botan/botan.cpp:46220:21: fatal error: cpuid.h: No such file or directory
Summary: =dev-qt/qt-creator-2.6* - 3rdparty/botan/botan.cpp:46220:21: fatal error: cpu...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: PPC Linux
: Normal normal (vote)
Assignee: Markos Chandras (RETIRED)
URL: https://bugreports.qt-project.org/bro...
Whiteboard:
Keywords:
Depends on:
Blocks: 430308
  Show dependency tree
 
Reported: 2012-10-24 14:43 UTC by Johannes Geiss
Modified: 2013-03-08 09:43 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge build log (build.log,383.94 KB, text/plain)
2012-10-24 14:45 UTC, Johannes Geiss
Details
Patch to remove bundled Botan library (patch-remove_bundled_botan.diff,2.15 KB, patch)
2013-01-17 23:34 UTC, Christoph Erhardt
Details | Diff
Patch to remove bundled Botan library (qt-creator-remove-bundled-botan.patch,2.15 KB, patch)
2013-01-18 17:16 UTC, Christoph Erhardt
Details | Diff
Ebuild patch (qt-creator-2.6.1-r1.patch,2.14 KB, patch)
2013-01-18 17:18 UTC, Christoph Erhardt
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Geiss 2012-10-24 14:43:38 UTC
dev-util/qt-creator-2.6.0_rc cannot be built. File cpuid.h is missing.

Reproducible: Always

Steps to Reproduce:
emerge =qt-creator-2.6.0_rc
or
emerge qt-creator
after unmasking 2.6.0_rc
Actual Results:  
see build.log

Expected Results:  
qt-creator compiles ok.

Portage 2.1.10.65 (default/linux/powerpc/ppc32/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r3, 3.2.1-gentoo-r2-polaris ppc)
=================================================================
System uname: Linux-3.2.1-gentoo-r2-polaris-ppc-7447-7457,_altivec_supported-with-gentoo-2.1
Timestamp of tree: Tue, 23 Oct 2012 10:45:01 +0000
app-shells/bash: 4.2_p20
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.6.8, 2.7.3-r2, 3.2.3
dev-util/cmake: 2.8.6-r4
dev-util/pkgconfig: 0.26
sys-apps/baselayout: 2.1-r1
sys-apps/openrc: 0.9.8.4
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.68
sys-devel/automake: 1.11.1
sys-devel/binutils: 2.21.1-r1
sys-devel/gcc: 3.4.6-r2, 4.5.3-r2
sys-devel/gcc-config: 1.6
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc: 2.14.1-r3
Repositories: gentoo private-overlay armagetron x-m68k sabayon java-overlay
ACCEPT_KEYWORDS="ppc"
ACCEPT_LICENSE="* -@EULA"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-g -O2 -fPIC -fno-strict-aliasing -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-g -O2 -fPIC -fno-strict-aliasing -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical --nospinner --quiet-build --usepkg --binpkg-respect-use=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles installsources news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ [^] ftp://de-mirror.org/distro/gentoo/ [^] http://mirror.umd.edu/gentoo [^] "
LANG="en_US.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/armagetron /var/lib/layman/m68k /var/lib/layman/sabayon /var/lib/layman/java-overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage" [^]
USE="X Xaw3d a52 aac acl alsa altivec berkdb bluetooth branding bzip2 cairo cdda cdr cgi cjk cli consolekit cracklib crypt css cups cxx dbus device-mapper dri dts dvd dvdr dvi emboss encode esd exif extensions extras fam fastcgi fat ffmpeg firefox flac fontconfig fortran fuse gd gdbm gif gnutls gpm gtk hfs iconv icu id3tag imagemagick imap ipv6 jfs joystick jpeg jpeg2k kpathsea lcms ldap libnotify mad midi mikmod minizip mng mod modules mp3 mp4 mpeg mudflap mule musicbrainz mysql ncurses nls nptl ntfs ntfsprogs objc odbc ogg opengl openmp pam pango pcre pdf png policykit ppc ppds pppd private-headers qt3support qt4 readline reiserfs sasl sdl server session sid sieve spell sqlite srt ssl startup-notification stream svg tcpd theora threads tiff timidity truetype twolame udev udisks unicode upower usb vamp videos vorbis wxwidgets xcb xfs xml xulrunner xv xvid zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="arm i386 ppc" QEMU_USER_TARGETS="arm i386 ppc" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Johannes Geiss 2012-10-24 14:45:30 UTC
Created attachment 327296 [details]
emerge build log
Comment 2 Davide Pesavento gentoo-dev 2012-10-27 19:49:01 UTC
This comes from the bundled copy of botan 1.10.2. Is upstream aware of the issue?

I've dropped ppc{,64} keywords for now.
Comment 3 Johannes Geiss 2012-10-28 09:58:11 UTC
(In reply to comment #2)

> Is upstream aware of the issue?

No, I didn´t find the tracker :-(
Comment 4 Davide Pesavento gentoo-dev 2012-10-28 18:59:32 UTC
(In reply to comment #3)
> (In reply to comment #2)
> 
> > Is upstream aware of the issue?
> 
> No, I didn´t find the tracker :-(

I mean qt-creator upstream. They bundle botan, so it's also their problem :)
The tracker is here https://bugreports.qt-project.org/secure/Dashboard.jspa
Comment 5 Johannes Geiss 2012-11-06 06:58:38 UTC
(In reply to comment #4)

> I mean qt-creator upstream. They bundle botan, so it's also their problem :)
> The tracker is here https://bugreports.qt-project.org/secure/Dashboard.jspa

I found the bug there:
https://bugreports.qt-project.org/browse/QTCREATORBUG-8107
Comment 6 Davide Pesavento gentoo-dev 2012-11-09 20:56:10 UTC
I guess this is still unsolved in 2.6.0 final.
Comment 7 Émeric Maschino 2012-12-05 09:09:42 UTC
I can confirm that this bug is present in 2.6.0 final on IA64.
Comment 8 Davide Pesavento gentoo-dev 2012-12-05 10:15:40 UTC
Do not CC arches please!
Comment 9 Christoph Erhardt 2013-01-17 23:24:42 UTC
Upstream bug report about bundled Botan library: https://bugreports.qt-project.org/browse/QTCREATORBUG-8588
Comment 10 Christoph Erhardt 2013-01-17 23:34:21 UTC
Created attachment 335974 [details, diff]
Patch to remove bundled Botan library
Comment 11 Davide Pesavento gentoo-dev 2013-01-17 23:36:49 UTC
(In reply to comment #9)
> Upstream bug report about bundled Botan library:
> https://bugreports.qt-project.org/browse/QTCREATORBUG-8588

Thanks!
Comment 12 Christoph Erhardt 2013-01-18 17:16:07 UTC
Created attachment 336062 [details, diff]
Patch to remove bundled Botan library
Comment 13 Christoph Erhardt 2013-01-18 17:18:42 UTC
Created attachment 336064 [details, diff]
Ebuild patch

This patch updates the ebuild to use the previous patch, which should be named "qt-creator-remove-bundled-botan.patch" and put into the "files" directory. Give it a try and tell me if it works.
Comment 14 Émeric Maschino 2013-01-19 19:51:08 UTC
(In reply to comment #13)
> Created attachment 336064 [details, diff] [details, diff]
> Ebuild patch
> 
> This patch updates the ebuild to use the previous patch, which should be
> named "qt-creator-remove-bundled-botan.patch" and put into the "files"
> directory. Give it a try and tell me if it works.

Compiles fine here on my ia64 workstation. I nevertheless had to add botan-bundled in /etc/portage/profile/use.mask AND emerge qt-creator explicitely disabling botan-bundled through USE="-botan-bundled" emerge qt-creator. Without BOTH this adjustments, qt-creator still wanted to use botan-bundled and qt-creator-remove-botan-bundled.patch was never applied, leading to the compilation error reported in this bug.
Comment 15 Christoph Erhardt 2013-01-21 16:28:02 UTC
You're right, this is because the "botan-bundled" flag is currently force-enabled in /usr/portage/profiles/base/package.use.force. Obviously, it should be removed from there once this bug is officially closed.
Comment 16 Davide Pesavento gentoo-dev 2013-02-17 10:37:15 UTC
Christoph, any updates on the RTTI problem mentioned in the upstream bug?
Comment 17 Christoph Erhardt 2013-02-17 12:26:45 UTC
Sorry, I haven't managed to reproduce the RTTI issue or narrow it down. :-/ All I can tell is that everything Works For Me[tm].

I'm wondering what's the right thing to do for Gentoo. Just test it in the field and see if USE="-bundled-botan" breaks for anyone?
Comment 18 Davide Pesavento gentoo-dev 2013-02-18 09:22:01 UTC
https://codereview.qt-project.org/48179
Comment 19 Émeric Maschino 2013-02-19 21:26:51 UTC
BTW, qt-creator-2.6.2 cannot be built on my ia64 workstation:

 * Package:    dev-util/qt-creator-2.6.2
 * Repository: gentoo
 * Maintainer: hwoarang@gentoo.org pesa@gentoo.org,qt@gentoo.org
 * USE:        elibc_glibc ia64 kernel_linux linguas_fr userland_GNU
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking qt-creator-2.6.2-src.tar.gz to /var/tmp/portage/dev-util/qt-creato
r-2.6.2/work
>>> Source unpacked in /var/tmp/portage/dev-util/qt-creator-2.6.2/work
>>> Preparing source in /var/tmp/portage/dev-util/qt-creator-2.6.2/work/qt-creat
or-2.6.2-src ...
 * Disabling android plugin
 * Disabling autotools plugin
 * Disabling bazaar plugin
 * Disabling clearcase plugin
 * Disabling cmake plugin
 * Disabling cvs plugin
 * Disabling fakevim plugin
 * Disabling git plugin
 * Disabling madde plugin
 * Disabling mercurial plugin
 * Disabling perforce plugin
 * Disabling qnx plugin
 * Disabling subversion plugin
 * Disabling valgrind plugin
 * Major version of system's botan library to be used: 1.10
sed: cannot read /var/tmp/portage/dev-util/qt-creator-2.6.2/work/qt-creat
or-2.6.2-src/src/libs/3rdparty/3rdparty.pro: no such file or directory (error message translated from French for sake of clarity)
 * ERROR: dev-util/qt-creator-2.6.2 failed (prepare phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_prepare
 *   environment, line 2667:  Called die
 * The specific snippet of code:
 *           sed -i -e "s:botan::" "${S}"/src/libs/3rdparty/3rdparty.pro || die;

And indeed, /var/tmp/portage/dev-util/qt-creator-2.6.2/work/qt-creat
or-2.6.2-src/src/libs/3rdparty only contains a cplusplus directory.

qt-creator-2.6.1 with attachment 336064 [details, diff] compiles successfully.
Comment 20 Markos Chandras (RETIRED) gentoo-dev 2013-02-19 22:23:59 UTC
(In reply to comment #19)
> BTW, qt-creator-2.6.2 cannot be built on my ia64 workstation:
> 
>  * Package:    dev-util/qt-creator-2.6.2
>  * Repository: gentoo
>  * Maintainer: hwoarang@gentoo.org pesa@gentoo.org,qt@gentoo.org
>  * USE:        elibc_glibc ia64 kernel_linux linguas_fr userland_GNU
>  * FEATURES:   sandbox
> >>> Unpacking source...
> >>> Unpacking qt-creator-2.6.2-src.tar.gz to /var/tmp/portage/dev-util/qt-creato
> r-2.6.2/work
> >>> Source unpacked in /var/tmp/portage/dev-util/qt-creator-2.6.2/work
> >>> Preparing source in /var/tmp/portage/dev-util/qt-creator-2.6.2/work/qt-creat
> or-2.6.2-src ...
>  * Disabling android plugin
>  * Disabling autotools plugin
>  * Disabling bazaar plugin
>  * Disabling clearcase plugin
>  * Disabling cmake plugin
>  * Disabling cvs plugin
>  * Disabling fakevim plugin
>  * Disabling git plugin
>  * Disabling madde plugin
>  * Disabling mercurial plugin
>  * Disabling perforce plugin
>  * Disabling qnx plugin
>  * Disabling subversion plugin
>  * Disabling valgrind plugin
>  * Major version of system's botan library to be used: 1.10
> sed: cannot read /var/tmp/portage/dev-util/qt-creator-2.6.2/work/qt-creat
> or-2.6.2-src/src/libs/3rdparty/3rdparty.pro: no such file or directory
> (error message translated from French for sake of clarity)
>  * ERROR: dev-util/qt-creator-2.6.2 failed (prepare phase):
>  *   (no error message)
>  * 
>  * Call stack:
>  *     ebuild.sh, line  93:  Called src_prepare
>  *   environment, line 2667:  Called die
>  * The specific snippet of code:
>  *           sed -i -e "s:botan::" "${S}"/src/libs/3rdparty/3rdparty.pro ||
> die;
> 
> And indeed, /var/tmp/portage/dev-util/qt-creator-2.6.2/work/qt-creat
> or-2.6.2-src/src/libs/3rdparty only contains a cplusplus directory.
> 
> qt-creator-2.6.1 with attachment 336064 [details, diff] [details, diff] compiles
> successfully.

please don't hijack bugs like this. Your problem has nothing to do with this bug. Open a new one
Comment 21 Davide Pesavento gentoo-dev 2013-02-19 22:28:32 UTC
(In reply to comment #19)

Well, USE=-botan-bundled is not supported in =qt-creator-2.6*, but I'm working on it for 2.7, so stay tuned. No need to file another bug report. And btw qt-creator is not keyworded for ia64 so issues are to be expected :)
Comment 22 Davide Pesavento gentoo-dev 2013-03-08 09:43:44 UTC
2.7.0_rc finally uses system botan, which should solve this issue. I'll open a separate bug for rekeywording.