Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 439372 - sys-apps/paludis[ruby-bindings] installs unslotted to latest ruby (actually 1.9) disregarding eselect-ed ruby-version
Summary: sys-apps/paludis[ruby-bindings] installs unslotted to latest ruby (actually 1...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jeff (JD) Horelick (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-23 09:05 UTC by Franz Trischberger
Modified: 2013-10-22 16:06 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
system info (sys-info,66.25 KB, text/plain)
2012-10-23 09:05 UTC, Franz Trischberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franz Trischberger 2012-10-23 09:05:14 UTC
Created attachment 327208 [details]
system info

This caused problems to me when using playman:
* I set ruby:1.8 to be my current ruby version
* paludis installed the bindings only to ruby:1.9
* playman does not contain a #!/bin/env-directive, hence using ruby1.8

The best would be to handle this like it is done in many python packages: install to all availbable ruby slots.
As an alternative: if installed to latest ruby patch playman and place (e.g.) #!/bin/env ruby1.9 at the beginning of the file. (I did this as a temporary workaround)

Is this an issue within the paludis build system? Should it be handled in portage or fixed upstream?
_______

paludis does not install to different python versions but uses only the current active one. This fails with python:3.2:
checking for Python.h... no
  File "<string>", line 1
    import sys; print sys.prefix
                        ^
SyntaxError: invalid syntax
  File "<string>", line 1
    import sys; print sys.exec_prefix
                        ^
SyntaxError: invalid syntax
configure: error: Python.h not found in /include/python3.2
(I know - anothger issue - stumbled over it when looking how python is handled in paludis build system)
Comment 1 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-10-20 09:44:40 UTC
@ruby, I have no idea about Ruby in Gentoo, so I'd appreciate some tip. Is there a sane way to support single-Ruby install (alike python-single-r1)?
Comment 2 Hans de Graaff gentoo-dev 2013-10-21 17:44:05 UTC
(In reply to Michał Górny from comment #1)
> @ruby, I have no idea about Ruby in Gentoo, so I'd appreciate some tip. Is
> there a sane way to support single-Ruby install (alike python-single-r1)?

No, that is still on our todo list. But the "good" news is that you don't need this since paludis 1.4.2 is hardcoded to ruby 1.9. Quoting from the configure.ac:

    PKG_CHECK_MODULES(RUBY, [ruby-1.9], [
        RUBY=`pkg-config --variable=ruby ruby-1.9`
    ], [

This explains the situation reported by Franz and confirmed by me that the eselected ruby doesn't matter.

So the proper fix is to depend on dev-lang/ruby:1.9

playman should then use #!/usr/bin/ruby19 directly.
Comment 3 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-10-22 16:06:35 UTC
Added a hack for this and reported it upstream [1] + the :1.9 enforcing [2].

+  22 Oct 2013; Michał Górny <mgorny@gentoo.org> +paludis-1.4.2-r1.ebuild,
+  -paludis-1.4.2.ebuild:
+  Change the ruby dep to :1.9 and fix the script shebangs on this version.
+  Noticed by Hans de Graaff on bug #439372.

[1]:http://paludis.exherbo.org/trac/ticket/1294
[2]:http://paludis.exherbo.org/trac/ticket/1295