Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 439280 - app-emulation/vmware-modules-264.4 - missing return carriage in printk in VNetUserIfSetUplinkState() at vmnet-only/userif.c
Summary: app-emulation/vmware-modules-264.4 - missing return carriage in printk in VNe...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-10-22 16:15 UTC by Evan Teran
Modified: 2013-12-27 16:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to add missing newline (vmnet-newline.patch,448 bytes, patch)
2012-10-22 16:15 UTC, Evan Teran
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Evan Teran 2012-10-22 16:15:12 UTC
Not 100% sure whether this belongs here or at vmware's bug tracker, so I figured I'd try here :-).

when looking at my dmesg I see lines like this:

userif-3: sent link up event.<7>bridge-eth1: disabling the bridge on dev down

Since things like <7> are typically the "level" of the message, this looks like 2 messages. In fact, often the second half is clearly from another module. So my assumption is that the first message is missing a return carriage.

Looking at the sources, the problem appears to be line 959 of file vmnet-only/userif.c.

   LOG(0, (KERN_NOTICE "userif-%d: sent link %s event.", 
           userIf->port.id, linkUp?"up":"down"));

has no newline :-).

I will be attaching a patch to this report which I believe addresses the issue.

Reproducible: Always
Comment 1 Evan Teran 2012-10-22 16:15:38 UTC
Created attachment 327154 [details, diff]
patch to add missing newline
Comment 2 Andreas K. Hüttel gentoo-dev 2013-12-27 16:34:59 UTC
patch added, thx