Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 439164 - <=app-admin/rsyslog-5.8.12 USE=ssl undefined symbol: gcry_control
Summary: <=app-admin/rsyslog-5.8.12 USE=ssl undefined symbol: gcry_control
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Ultrabug
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-21 13:51 UTC by Conrad
Modified: 2013-09-10 11:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_439164.txt,4.47 KB, text/plain)
2012-10-21 13:51 UTC, Conrad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Conrad 2012-10-21 13:51:45 UTC
Created attachment 327050 [details]
emerge --info

app-admin/rsyslog USE=ssl fails to load the gnutls plugin library, stating in log
rsyslogd-2066: could not load module '/usr/lib64/rsyslog/lmnsd_gtls.so', dlopen: /usr/lib64/rsyslog/lmnsd_gtls.so: undefined symbol: gcry_control
 [try http://www.rsyslog.com/e/2066 ]

steps to reproduce:
1. emerge --sync && emerge -uDN world
2. USE=ssl emerge app-admin/rsyslog
3. enable tls module in rsyslog config
4. rc-service rsyslog restart
5. watch your log file

Tried with app-admin/rsyslog-5.8.11 and app-admin/rsyslog-5.8.12, with dev-libs/libgcrypt-1.5.0-r2 and dev-libs/libgcrypt-1.4.6
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-10-21 14:38:49 UTC
A similar bug is at https://bugs.gentoo.org/show_bug.cgi?id=337504.

I don't see whether you have specific package USE flags, but can you try emerging again (-uDN) with USE flags gnutls and gcrypt enabled? Don't forget to `revdep-rebuild` afterwards, making sure it ends up being clean.

This could indicate whether the USE flag being not properly configuring the build from the ebuild might be the problem.
Comment 2 Conrad 2012-10-21 15:06:29 UTC
globally enabling these use flags would run me into severe conflicts. However I was able to workaround this bug by changing net-libs/gnutls to USE="-nettle" like mentioned in the bug you linked. Thank you for the hint.
Comment 3 Tiziano Müller gentoo-dev 2012-10-29 16:10:45 UTC
un-CC'ing myself since I stepped down as co-maintainer of rsyslog
Comment 4 Ultrabug gentoo-dev 2013-09-10 07:54:48 UTC
This version of rsyslog is not supported and not in tree anymore. Please try with a newer version and open a new bug if the issue persists.

Cheers