Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 438976 - Add a repoman check to remember to end DESCRIPTION without a dot "."
Summary: Add a repoman check to remember to end DESCRIPTION without a dot "."
Status: RESOLVED WONTFIX
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Repoman (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Portage team
URL: http://comments.gmane.org/gmane.linux...
Whiteboard:
Keywords:
Depends on:
Blocks: 484436
  Show dependency tree
 
Reported: 2012-10-19 18:40 UTC by Pacho Ramos
Modified: 2014-08-16 09:20 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Add repoman check for trailing punctuation (0001-Have-repoman-warn-when-DESCRIPTION-ends-with-a-punct.patch,1.72 KB, patch)
2014-04-18 23:06 UTC, Michael Orlitzky
Details | Diff
Add repoman check for period only (0001-Have-repoman-warn-when-DESCRIPTION-ends-with-a-perio.patch,1.67 KB, patch)
2014-04-19 00:26 UTC, Michael Orlitzky
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2012-10-19 18:40:35 UTC
At least in spanish, it's mandatory to end phrases with a dot ".", would be possible to add a check to remember us to end DESCRIPTIONs with a dot?

Thanks

Reproducible: Always
Comment 1 Zac Medico gentoo-dev 2012-10-19 18:42:55 UTC
For a global policy like this, you need to see if there'a a consensus on the gentoo-dev mailing list first. Also, docs like that dev-manual and developer handbook need to be updated.
Comment 2 Pacho Ramos gentoo-dev 2012-10-19 19:02:07 UTC
Just sent, thanks
Comment 3 Pacho Ramos gentoo-dev 2012-10-21 09:35:04 UTC
Looks like consensus is about the opposite
Comment 4 Fabian Groffen gentoo-dev 2012-10-21 09:37:51 UTC
- how about starting with or without a capital?
- how about warning when the package name appears in DESCRIPTION?
Comment 5 Pacho Ramos gentoo-dev 2012-10-21 09:42:24 UTC
(In reply to comment #4)
> - how about starting with or without a capital?
> - how about warning when the package name appears in DESCRIPTION?

They look fine to me also, if they are not hard to implement...
Comment 6 Ulrich Müller gentoo-dev 2012-10-31 18:08:28 UTC
(In reply to comment #4)
> - how about warning when the package name appears in DESCRIPTION?

I don't think that checking for this is a good idea. If you look at packages in app-emacs, in some cases the most natural description includes the package name. For example, app-emacs/chess "A chess client and library for Emacs", or app-emacs/javascript "Major mode for editing JavaScript source text".

Other examples:

   app-emacs/anything
   app-emacs/folding
   app-emacs/jasmin
   app-emacs/mairix
   app-emacs/querty
   app-emacs/redo
   app-emacs/sawfish
   app-emacs/session
   app-emacs/sokoban
   app-emacs/ssh
   app-emacs/teco
   app-emacs/template
   app-emacs/typing
   app-emacs/uptimes
Comment 7 Michael Orlitzky gentoo-dev 2014-04-18 23:06:16 UTC
Created attachment 375248 [details, diff]
Add repoman check for trailing punctuation

I've left it as a warning for cases like "Frobnicator for 3DNow!"
Comment 8 Michael Orlitzky gentoo-dev 2014-04-19 00:26:29 UTC
Created attachment 375258 [details, diff]
Add repoman check for period only

This one only checks for a period (no '?' or '!') and also doesn't explode when DESCRIPTION="" in case you're into that sort of thing.
Comment 9 Brian Dolbec gentoo-dev 2014-04-19 05:40:00 UTC
Pushed a slightly modified patch as we discussed on IRC.

commit:
http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=06637c4215d55c57517739214c6e0fd6f8f53914
Comment 10 Brian Dolbec gentoo-dev 2014-08-04 02:04:53 UTC
released in portage-2.2.11
Comment 11 Alexander Berntsen (RETIRED) gentoo-dev 2014-08-12 21:56:37 UTC
Reverted in git following QA instructing the portage team to do so.
Comment 12 Pacho Ramos gentoo-dev 2014-08-15 09:53:22 UTC
What occurred with this then? (I remember the gentoo-dev ML thread end up with people asking to drop the dots)
Comment 13 Brian Dolbec gentoo-dev 2014-08-15 14:32:11 UTC
Pacho, a few people bitched very loudly, then QA asked us to remove it since they did not approve it.
Comment 14 Pacho Ramos gentoo-dev 2014-08-16 09:15:24 UTC
Ah, ok, I see a big thread in my mail client now (sorry for not checking it before but I have a ton of pending mails to read :S)

Will anyway post the URL that I used as reference to make it clear that this was already discussed in the past ;)
Comment 15 Pacho Ramos gentoo-dev 2014-08-16 09:20:55 UTC
Well, reading the new thread I only want to say that I only wanted to prevent other people from adding by error a dot at the end of DESCRIPTIONS and, then, progressively solve that. I didn't want to overload repoman, bypass QA or similar -_-

http://www.gossamer-threads.com/lists/gentoo/dev/290983 -> this is the new thread to remember in the future why this was rejected