Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 438700 - x11-libs/libfm - Remove udisks|gdu use dependencies from gnome-base/gvfs
Summary: x11-libs/libfm - Remove udisks|gdu use dependencies from gnome-base/gvfs
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Markos Chandras (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-17 12:16 UTC by Dominique Michel
Modified: 2014-02-07 23:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch that add udisks USE flag to libfm (libfm-1.0.1-r1.ebuild.patch,1.01 KB, patch)
2012-10-17 12:27 UTC, Dominique Michel
Details | Diff
libfm-use-udev.patch (libfm-udev.patch,1.12 KB, patch)
2014-01-26 03:04 UTC, Dustin C. Hatch
Details | Diff
libfm-use-automount.patch (libfm-automount.patch,1.26 KB, patch)
2014-01-26 03:06 UTC, Dustin C. Hatch
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Michel 2012-10-17 12:16:25 UTC
In portage, udisks is disabled in libfm with "configure --disable-udisks", and libfm depend on udisks or gdu:

RDEPEND="${COMMON_DEPEND}
	|| ( gnome-base/gvfs[udev,udisks] gnome-base/gvfs[udev,gdu] )"

This force the installation of udisks or gdu, and of the associated depends including polkit:

# emerge -vp =libfm-1.0.1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-apps/gptfdisk-0.8.5  0 kB
[ebuild  N     ] dev-libs/libatasmart-0.19  USE="-static-libs" 0 kB
[ebuild  N     ] sys-fs/cryptsetup-1.4.3  USE="nls (-selinux) -static -static-libs" 0 kB
[ebuild  N    #] sys-auth/polkit-0.107-r1  USE="gtk introspection nls pam -examples -kde (-selinux) -systemd" 0 kB
[ebuild  N     ] sys-auth/consolekit-0.4.5_p20120320-r1  USE="acl pam policykit -debug -doc (-selinux) {-test}" 0 kB
[ebuild  N     ] gnome-extra/polkit-gnome-0.105  0 kB
[ebuild   R    ] sys-auth/pambase-20120417-r1  USE="consolekit* cracklib sha512 -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux) -systemd" 0 kB
[ebuild  N     ] sys-fs/udisks-2.0.0  USE="crypt gptfdisk introspection -debug -systemd" 730 kB
[ebuild   R    ] gnome-base/gvfs-1.12.3-r1  USE="archive avahi bluetooth cdda fuse gnome-keyring gphoto2 http udev udisks* -afp -bluray -doc -gdu -ios -samba" 0 kB
[ebuild   R    ] x11-libs/libfm-1.0.1::gentoo [1.0.1::x-test] USE="vala -debug -doc -examples (-udisks%)" 0 kB

Total: 10 packages (7 new, 3 reinstalls), Size of downloads: 730 kB

The following mask changes are necessary to proceed:
#required by sys-fs/udisks-2.0.0, required by gnome-base/gvfs-1.12.3-r1[udisks], required by x11-libs/libfm-1.0.1, required by @selected, required by @world (argument)
# /etc/portage/package.mask:
#=dev-scheme/guile-gnome-platform-2.16.1-r1
#=media-sound/snd-ls-0.9.9.2_beta
=sys-auth/polkit-0.107-r1

The following USE changes are necessary to proceed:
#required by sys-auth/polkit-0.107-r1[-systemd], required by gnome-extra/polkit-gnome-0.105
>=sys-auth/consolekit-0.4.5_p20120320-r1 policykit
#required by x11-libs/libfm-1.0.1, required by @selected, required by @world (argument)
=gnome-base/gvfs-1.12.3-r1 udisks
#required by sys-auth/polkit-0.107-r1[-systemd,pam], required by gnome-extra/polkit-gnome-0.105
>=sys-auth/pambase-20120417-r1 consolekit

##################

In my system, I meged libfm with --disable-udisks and

RDEPEND="${COMMON_DEPEND}
      gnome-base/gvfs[udev]"

The result is

# emerge -vp gvfs

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] gnome-base/gvfs-1.12.3-r1  USE="archive avahi bluetooth cdda fuse gnome-keyring gphoto2 http udev -afp -bluray -doc -gdu -ios -samba -udisks"

In pcmanfm, in its left panel, the removable disks get updated when I insert or remove/unmount them, thanks to udev only.

In consequence, It would be better to change this dependency, or to change this dependency and add a conditional udisks USE flag.
Comment 1 Dominique Michel 2012-10-17 12:27:01 UTC
Created attachment 326766 [details, diff]
patch that add udisks USE flag to libfm

I bet on an udisks USE flags.
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2012-10-17 12:33:39 UTC
erm we already discussed that udisks will remain disabled in the ebuild, so no useflag is needed. What I need to investigate is whether udisks|gdu is mandatory in gvfs or not
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2012-10-17 14:47:17 UTC
Now that I think about it, a udisks useflag could be added but we a big fat warning like "It is well known that udisks support in libfm is broken. Before reporting any bugs, make sure you tried building libfm without this flag"
Comment 4 Rafał Mużyło 2012-10-17 16:44:45 UTC
I'm not sure if "do they show ?" is the correct question here.

More likely it's "do they mount/unmount correctly via pcmanfm if the device isn't i.e. marked as user-mountable in fstab ?".
GVolumeMonitor needs an external implementation and the default one in gvfs needs either gdu or udisks2.

Are you sure you don't have another mount helper program installed ?
Comment 5 Markos Chandras (RETIRED) gentoo-dev 2012-10-17 16:52:05 UTC
(In reply to comment #4)
> I'm not sure if "do they show ?" is the correct question here.
> 
> More likely it's "do they mount/unmount correctly via pcmanfm if the device
> isn't i.e. marked as user-mountable in fstab ?".
> GVolumeMonitor needs an external implementation and the default one in gvfs
> needs either gdu or udisks2.
> 
> Are you sure you don't have another mount helper program installed ?

Yeah that puzzles me. The fact that they show on the left panel does not mean that the automount as user works as is
Comment 6 Dominique Michel 2012-10-17 20:26:48 UTC
I am looking in my runlevels. I see than I have localmount (openrc), mtab (openrc), dbus and nothing in /etc/local.d

Also, as I understand it, automounting of external/plubale devices work only in a *kit system. As soon than policykit is installed, it take control of udev and automounting doesn't work, or need extra software like gvfs or udisks. Polkit is a daemon that manage the permissions into the system, but it is possible to manage them in many cases without any daemon. Groups permissions doesn't need a daemon, but polkit, for what I know, take over the group permissions management. And so on. 

When *kit become a gnome depènd, it get installed during a world update, and the first visible regression was fvwm that stopped to start from startx with "exec fvwm" into .xinirc. It was necessary to change it to "exec ck-launch-session fvwm". And I was not the only one. It is the same problem with lxde, *box and other window managers. The second visible consequence was automounting that stopped to work.

Recently, I managed to get ride of *kit by adding "-polkit -consolekit -gnome -udisks" into /etc/make.conf. The first visible consequence was that fvwm is working fine without ck-launch-session. The second one is automounting that is working again. It is why the plugable devices get updated in pcman in my system.

In consequence, to add an udisks use flag in libfm and merge it with USE="-libfm" alone will not make automounting to work, but it is a part of the solution that consist in an "kit free system. A side effect is than it will be gnome free too, as it is a hard dependency in gnome on polkit.

In the present situation, the 3 portage desktop profiles have USE="polkit" in their default setup. For what I know, only gnome and a few other wm/desktop really depend on it (cannot be installed without it). Even most parts of kde can be installed with USE="-polkit". 

Also, udisks is know to be broken in lxde at that time. 

All that imply, if I am right, that I was wrong to bet on an udisks USE flag in libfm, and that the right solution to get automounting to work in lxde and all the *kit free wm is an *kit free desktop profile. But that's another discussion.

For this bug, this is definitely wrong to do a "configure --disable-udisks", and to have udisks/gdu in the depend. 

But to add a comment is a good idea in any case, because automounting without user intervention need an *kit free system. Also, to be able to mount/unmount from pcman, the partitons configured in /etc/fstab must have "users" in their config line.
Comment 7 Dominique Michel 2012-10-17 20:35:16 UTC
Sorry, it was

to add an udisks use flag in libfm and merge it with USE="-udisks" alone will not make automounting to work,
Comment 8 Rafał Mużyło 2012-10-17 22:08:04 UTC
> For this bug, this is definitely wrong to do a "configure --disable-udisks", 
> and to have udisks/gdu in the depend.

That's not true.
'--enable-udisks' makes libfm add its own udisks-based volume monitor, that has a higher priority than the default one from gvfs, with '--disable-udisks', libfm simply relies on the one from gvfs. So it's actually the *expected* course of action.

> A side effect is than it will be gnome free too, as it is a hard dependency in gnome on polkit.
Please elaborate on this point.

Given your description, I'm nearly sure you've got something like sys-apps/uam (or perhaps even your own udev rules), that handle automounting.
Comment 9 Dominique Michel 2012-10-18 15:52:57 UTC
(In reply to comment #8)
> > For this bug, this is definitely wrong to do a "configure --disable-udisks", 
> > and to have udisks/gdu in the depend.
> 
> That's not true.
> '--enable-udisks' makes libfm add its own udisks-based volume monitor, that
> has a higher priority than the default one from gvfs, with
> '--disable-udisks', libfm simply relies on the one from gvfs. So it's
> actually the *expected* course of action.

In my system, gvfs doesn't have udisks support (in fact udisk2 in gvfs-1.12.3) but have udev support, and libfm build fine with this. So I don't understand why udisk is mandatory in this case. The possibility should exist to not have this depend on udisks/gdu.

> 
> > A side effect is than it will be gnome free too, as it is a hard dependency in gnome on polkit.
> Please elaborate on this point.

# emerge -vp gnome

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-gfx/shared-color-profiles-0.1.5  0 kB
[ebuild  N     ] net-misc/netkit-fingerd-0.17-r3  0 kB
[ebuild  N     ] sys-power/pm-quirks-20100619  0 kB
[ebuild  N     ] dev-libs/libx86-1.1-r1  0 kB
[ebuild  N     ] media-libs/webrtc-audio-processing-0.1  USE="-static-libs" 0 kB
[ebuild  N     ] dev-libs/libatomic_ops-7.2d  1,234 kB
[ebuild  N     ] net-libs/libasyncns-0.8-r2  USE="-debug -doc" 0 kB
[ebuild  N     ] dev-libs/json-c-0.9-r1  USE="-static-libs" 0 kB
[ebuild  N     ] sys-auth/nss-myhostname-0.3  0 kB
[ebuild  N     ] net-misc/dhcpcd-5.6.2  USE="zeroconf" 83 kB
[ebuild  N     ] net-wireless/wireless-regdb-20110428-r1  0 kB
[ebuild  N     ] net-im/telepathy-connection-managers-1  USE="-icq -irc -jabber -msn -sip -yahoo -zeroconf" 0 kB
[ebuild  N     ] net-misc/mobile-broadband-provider-info-20120614  0 kB
[ebuild  NS    ] app-text/docbook-sgml-dtd-4.1-r3:4.1 [3.0-r3:3.0, 3.1-r3:3.1] 0 kB
[ebuild  N     ] dev-libs/libnl-3.2.13:3  USE="-doc -static-libs -utils" 0 kB
[ebuild  N     ] app-admin/apg-2.3.0b-r5  USE="cracklib" 0 kB
[ebuild  NS    ] app-text/docbook-sgml-dtd-4.0-r3:4.0 [3.0-r3:3.0, 3.1-r3:3.1] 0 kB
[ebuild  N     ] sys-apps/gptfdisk-0.8.5  0 kB
[ebuild  N     ] gnome-extra/gnome-audio-2.22.2  USE="-debug" 0 kB
[ebuild  N     ] gnome-extra/gnome-user-docs-3.4.2  USE="{-test}" 0 kB
[ebuild  N     ] media-libs/gexiv2-0.4.1  USE="-static-libs" 0 kB
[ebuild  N     ] sys-apps/lsb-release-1.4  0 kB
[ebuild  N     ] dev-util/fix-la-relink-command-0.1.1  0 kB
[ebuild  N     ] sys-apps/vbetool-1.1  0 kB
[ebuild  N     ] x11-apps/sessreg-1.0.7  0 kB
[ebuild  N     ] net-dns/bind-tools-9.9.2  USE="ipv6 readline ssl xml -doc -gssapi -idn -urandom" 7,115 kB
[ebuild  N     ] net-misc/whois-5.0.20  USE="iconv nls -idn" 69 kB
[ebuild  NS    ] dev-lang/vala-0.16.1-r2:0.16 [0.14.2-r2:0.14] USE="vapigen {-test}" 0 kB
[ebuild  N     ] x11-themes/gnome-backgrounds-3.4.2  0 kB
[ebuild  NS    ] dev-lang/vala-0.12.1-r1:0.12 [0.14.2-r2:0.14] USE="vapigen {-test}" 0 kB
[ebuild  N     ] gnome-extra/yelp-xsl-3.4.2  0 kB
[ebuild  N     ] x11-apps/mesa-progs-8.0.1  0 kB
[ebuild  N     ] x11-themes/gnome-icon-theme-extras-3.4.0  0 kB
[ebuild  N     ] net-libs/libnice-0.1.3  USE="gstreamer -upnp" 0 kB
[ebuild  N     ] net-libs/farstream-0.1.2-r1  USE="introspection -msn -python {-test} -upnp" 0 kB
[ebuild  N     ] media-libs/libraw-0.14.7  USE="jpeg2k lcms openmp -demosaic -examples -static-libs" 0 kB
[ebuild  N     ] gnome-base/libgnomekbd-3.4.0.2  USE="introspection {-test}" 0 kB
[ebuild  NS    ] x11-libs/libwnck-3.4.3:3 [2.31.0:1] USE="introspection startup-notification -doc -tools" 0 kB
[ebuild  N     ] app-admin/gnome-system-log-3.4.1  0 kB
[ebuild  N     ] media-gfx/gnome-font-viewer-3.4.0  0 kB
[ebuild  N     ] sys-apps/baobab-3.4.1  0 kB
[ebuild  N     ] gnome-extra/gucharmap-3.4.1.1:2.90  USE="cjk introspection -debug -doc {-test}" 0 kB
[ebuild  N     ] app-arch/file-roller-3.4.2  USE="-nautilus (-packagekit)" 0 kB
[ebuild  N     ] gnome-extra/gcalctool-6.4.2.1  0 kB
[ebuild  N     ] app-dicts/gnome-dictionary-3.4.0  USE="ipv6 -debug -doc" 0 kB
[ebuild  N     ] gnome-extra/gtkhtml-4.4.4:4.0  0 kB
[ebuild  NS    ] dev-libs/libunique-3.0.2:3 [1.1.6-r1:1] USE="introspection -debug -doc {-test}" 0 kB
[ebuild  N     ] app-accessibility/at-spi2-core-2.4.2:2  USE="introspection -doc" 0 kB
[ebuild  N     ] net-libs/telepathy-glib-0.18.2  USE="introspection vala -debug {-test}" 0 kB
[ebuild  N     ] gnome-extra/gnome-screensaver-3.4.4  USE="pam -debug -doc -systemd" 0 kB
[ebuild  N     ] net-im/telepathy-logger-0.4.0-r1  USE="introspection {-test}" 0 kB
[ebuild  N     ] net-im/telepathy-mission-control-5.12.3  USE="-connman -debug -gnome-keyring -networkmanager -upower" 0 kB
[ebuild  N     ] gnome-extra/gconf-editor-3.0.1  0 kB
[ebuild  N     ] net-libs/telepathy-farstream-0.4.0  USE="-examples -python" 0 kB
[ebuild  N     ] x11-themes/gtk-engines-2.20.2:2  USE="-accessibility -lua" 0 kB
[ebuild  N     ] net-libs/gtk-vnc-0.5.1  USE="gtk3 introspection -examples -pulseaudio -python -sasl -vala" 0 kB
[ebuild  N     ] net-dialup/ppp-2.4.5-r3  USE="gtk ipv6 pam -activefilter -atm -dhcp -eap-tls -radius" 69 kB
[ebuild  N     ] x11-themes/gnome-themes-standard-3.4.2  0 kB
[ebuild  N     ] gnome-extra/gnome-system-monitor-3.4.1  USE="-systemd" 0 kB
[ebuild  N     ] gnome-extra/zenity-3.4.0  USE="libnotify webkit -debug" 0 kB
[ebuild  N     ] gnome-extra/yelp-3.4.2  USE="-debug" 0 kB
[ebuild  N     ] net-misc/vinagre-3.4.2  USE="ssh telepathy -avahi -spice {-test}" 0 kB
[ebuild  N     ] dev-libs/libgweather-3.4.1:2  USE="introspection -doc" 0 kB
[ebuild  N     ] net-libs/rest-0.7.12:0.7  USE="gnome introspection -doc {-test}" 0 kB
[ebuild  N     ] sys-libs/libosinfo-0.2.0  USE="introspection vala -doc {-test}" 0 kB
[ebuild  N     ] media-gfx/shotwell-0.12.3  LINGUAS="es fr sv -ar -ast -bg -bn -ca -cs -da -de -el -en_GB -et -eu -fi -gl -he -hi -hr -hu -ia -id -it -ja -kk -ko -lt -lv -mk -nb -nl -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -ta -ta_IN -te -te_IN -th -tr -uk -vi -zh_CN -zh_TW" 0 kB
[ebuild  N     ] dev-libs/libgusb-0.1.3  USE="-static-libs" 0 kB
[ebuild  N     ] dev-libs/libatasmart-0.19  USE="-static-libs" 0 kB
[ebuild  N     ] x11-misc/notification-daemon-0.7.6  0 kB
[ebuild  N     ] media-gfx/gnome-screenshot-3.4.1::sabayon  0 kB
[ebuild  N     ] sys-power/pm-utils-1.4.1-r2  USE="alsa -debug -ntp" VIDEO_CARDS="-intel -radeon" 0 kB
[ebuild  N     ] x11-wm/metacity-2.34.8  USE="{-test} -xinerama" 0 kB
[ebuild  N     ] x11-wm/mutter-3.4.1-r1  USE="introspection -debug {-test} -xinerama" 0 kB
[ebuild  N     ] games-board/aisleriot-3.2.3.2-r1  USE="-debug -gnome" 0 kB
[ebuild  N     ] net-misc/vino-3.4.2  USE="crypt ipv6 jpeg libnotify ssl telepathy zlib -avahi -debug -gnome-keyring -networkmanager" 0 kB
[ebuild  N     ] www-client/epiphany-3.4.3  USE="introspection jit nss -avahi -debug -doc {-test}" 0 kB
[ebuild  N     ] gnome-extra/gnome-search-tool-3.4.0  0 kB
[ebuild  N     ] app-text/docbook-xml-simple-dtd-4.1.2.4-r3  0 kB
[ebuild  N     ] app-text/docbook-xml-simple-dtd-1.0-r2:1.0  0 kB
[ebuild  N     ] sys-fs/cryptsetup-1.4.3  USE="nls (-selinux) -static -static-libs" 0 kB
[ebuild  N     ] app-text/docbook-sgml-utils-0.6.14-r1  USE="-jadetex" 0 kB
[ebuild  N     ] app-text/xmlto-0.0.25  USE="-latex" 0 kB
[ebuild  N     ] x11-apps/xhost-1.0.5  USE="ipv6" 0 kB
[ebuild  N     ] media-libs/memphis-0.2.3:0.2  USE="introspection -debug -doc -static-libs -vala" 0 kB
[ebuild  N     ] media-libs/libchamplain-0.12.3:0.12  USE="gtk introspection -debug -doc -vala" 0 kB
[ebuild  N     ] dev-python/pycups-1.9.62  USE="-doc -examples" 0 kB
[ebuild  N     ] app-mobilephone/obexd-0.47  USE="usb -eds -nokia -server" 0 kB
[ebuild  N     ] net-libs/gnome-online-accounts-3.4.2  USE="introspection -debug -doc -gnome" 0 kB
[ebuild  N     ] net-wireless/gnome-bluetooth-3.4.2-r1:2  USE="introspection -debug -doc -sendto" 0 kB
[ebuild  N     ] app-admin/system-config-printer-common-1.3.11-r1  USE="-doc -policykit" 0 kB
[ebuild  N     ] dev-python/m2crypto-0.21.1  USE="-doc -examples" 0 kB
[ebuild  N     ] gnome-extra/evolution-data-server-3.4.4  USE="gnome-online-accounts introspection ipv6 ldap weather -doc -kerberos {-test} -vala" 0 kB
[ebuild  N     ] gnome-extra/gnome-games-3.4.2  USE="aisleriot clutter glchess introspection sudoku -artworkextra {-test}" 0 kB
[ebuild  N     ] dev-python/pyatspi-2.4.0  0 kB
[ebuild  N     ] net-wireless/crda-1.1.2-r4  0 kB
[ebuild  N     ] dev-libs/folks-0.6.9  USE="eds -debug -socialweb {-test} -tracker -utils -vala" 0 kB
[ebuild  N     ] mail-client/evolution-3.4.4:2.0  USE="crypt gnome-online-accounts ldap ssl -clutter -connman -doc -gstreamer -kerberos -map -networkmanager -python" 0 kB
[ebuild  N     ] net-analyzer/nmap-6.01  USE="gtk ssl -lua -ncat -ndiff -nmap-update -nping" 0 kB
[ebuild  N     ] app-accessibility/caribou-0.4.4  0 kB
[ebuild  N     ] net-wireless/wpa_supplicant-1.0-r1  USE="dbus readline ssl -debug -eap-sim -fasteap -gnutls -madwifi (-ps3) -qt4 (-selinux) -wimax -wps" 0 kB
[ebuild  N     ] media-gfx/eog-3.4.3-r1:1  USE="exif introspection jpeg lcms svg tiff -debug -doc -xmp" 0 kB
[ebuild  N     ] app-misc/tracker-0.14.2-r1  USE="exif flac gif gtk iso jpeg mp3 pdf tiff vorbis xml (-applet) -cue -doc -eds -firefox-bookmarks -flickr -gnome-keyring -gsf -gstreamer -iptc -laptop -nautilus -networkmanager -playlist -rss {-test} -thunderbird -upnp -xine -xmp" 0 kB
[ebuild  N     ] net-analyzer/gnome-nettool-3.2.0  USE="-debug" 0 kB
[ebuild  N     ] app-admin/system-config-printer-gnome-1.3.11  USE="-gnome-keyring" LINGUAS="es fr sv -ar -as -bg -bn -bn_IN -br -bs -ca -cs -cy -da -de -el -en_GB -et -fa -fi -gu -he -hi -hr -hu -hy -id -is -it -ja -ka -kn -ko -lo -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt -pt_BR -ro -ru -si -sk -sl -sr -sr@latin -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 0 kB
[ebuild  N     ] gnome-extra/gnome-contacts-3.4.1  0 kB
[ebuild  N     ] gnome-extra/gnome-documents-0.4.2  0 kB
[ebuild  N     ] gnome-base/gnome-core-libs-3.4.1:3.0  USE="cups -python" 0 kB
[ebuild  N     ] app-crypt/seahorse-3.4.1  USE="ldap -avahi -debug" 0 kB
[ebuild  N     ] app-editors/gedit-3.4.2  USE="introspection python spell -doc {-test} -zeitgeist" 0 kB
[ebuild  N     ] sci-geosciences/geocode-glib-0.99.0  USE="introspection {-test}" 0 kB
[ebuild  N    #] sys-auth/polkit-0.107-r1  USE="gtk introspection nls pam -examples -kde (-selinux) (-systemd)" 0 kB
[ebuild  N     ] sys-auth/consolekit-0.4.5_p20120320-r1  USE="acl pam policykit -debug -doc (-selinux) {-test}" 0 kB
[ebuild  N     ] gnome-extra/polkit-gnome-0.105  0 kB
[ebuild   R    ] sys-auth/pambase-20120417-r1  USE="consolekit* cracklib sha512 -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux) -systemd" 0 kB
[ebuild  N     ] sys-power/upower-0.9.18  USE="introspection -debug -doc -ios -systemd" 0 kB
[ebuild  N     ] net-misc/networkmanager-0.9.6.0  USE="bluetooth dhcpcd introspection nss ppp wext -avahi -connection-sharing -dhclient -doc -gnutls -modemmanager -resolvconf -systemd -vala -wimax" 0 kB
[ebuild  N     ] x11-misc/colord-0.1.23  USE="gusb introspection udev -doc -examples -scanner -vala" 535 kB
[ebuild  N     ] sys-apps/accountsservice-0.6.25  USE="introspection -doc -systemd -vala" 327 kB
[ebuild  N     ] gnome-base/gnome-panel-3.4.2.1  USE="introspection -eds -networkmanager" 0 kB
[ebuild  N     ] sys-auth/rtkit-0.10  0 kB
[ebuild  N     ] app-admin/openrc-settingsd-1.0.1  USE="-systemd" 0 kB
[ebuild  N     ] net-print/cups-pk-helper-0.2.4  147 kB
[ebuild  N     ] sys-fs/udisks-2.0.0:2  USE="crypt gptfdisk introspection -debug -systemd" 730 kB
[ebuild   R    ] gnome-base/gvfs-1.12.3-r1  USE="archive avahi bluetooth cdda fuse gnome-keyring gphoto2 http udev udisks* -afp -bluray -doc -gdu -ios -samba" 0 kB
[ebuild  N     ] gnome-extra/nm-applet-0.9.6.2  USE="bluetooth -gconf" 0 kB
[ebuild  N     ] gnome-base/gnome-fallback-3.4.1:3.0  USE="cups" 0 kB
[ebuild  N     ] gnome-base/gnome-applets-3.4.1  USE="ipv6 -gnome -networkmanager -policykit" 0 kB
[ebuild  N     ] net-libs/libsocialweb-0.25.20  USE="gnome introspection networkmanager -connman -doc -vala" 0 kB
[ebuild  N     ] gnome-extra/gnome-color-manager-3.4.2  USE="-clutter (-packagekit) -raw" 0 kB
[ebuild  N     ] gnome-extra/gnome-power-manager-3.4.0  USE="{-test}" 0 kB
[ebuild  N     ] media-sound/pulseaudio-2.1-r1  USE="X alsa asyncns bluetooth caps dbus gdbm glib gtk ipv6 jack libsamplerate orc realtime ssl tcpd udev webrtc-aec -avahi -doc -equalizer -gnome -lirc (-oss) (-system-wide) -systemd {-test} -xen" 0 kB
[ebuild   R    ] media-plugins/alsa-plugins-1.0.26  USE="ffmpeg jack libsamplerate pulseaudio* -debug -speex" 0 kB
[ebuild  N     ] gnome-base/gnome-settings-daemon-3.4.2  USE="colord cups policykit short-touchpad-timeout udev -debug (-packagekit) -smartcard -systemd {-test} -wacom" 0 kB
[ebuild  N     ] net-im/empathy-3.4.2.3  USE="geocode geoloc map networkmanager spell v4l -debug -eds -gnome -gnome-online-accounts -legacy-call -sendto {-test}" 0 kB
[ebuild  N     ] gnome-base/gnome-session-3.4.2.1  USE="ipv6 -debug -doc -systemd" 0 kB
[ebuild  N     ] gnome-base/gnome-control-center-3.4.2-r1:2  USE="bluetooth cheese colord cups gnome-online-accounts networkmanager socialweb -debug -systemd -wacom" 0 kB
[ebuild  N     ] gnome-base/gnome-shell-3.4.2  USE="bluetooth networkmanager -systemd" 0 kB
[ebuild  N     ] gnome-base/gnome-core-apps-3.4.1:3.0  USE="bluetooth cdr cups networkmanager" 0 kB
[ebuild  N     ] gnome-base/gdm-3.4.1-r3  USE="fallback gnome-shell introspection ipv6 ldap tcpd xklavier -accessibility -audit -consolekit -debug -fprint -plymouth (-selinux) -smartcard -systemd {-test} -xinerama" 2 kB
[ebuild  N     ] gnome-extra/gnome-tweak-tool-3.4.0.1  0 kB
[ebuild  N     ] gnome-base/gnome-extra-apps-3.4.1:3.0  USE="shotwell tracker" 0 kB
[ebuild  N     ] gnome-base/gnome-3.4.1:2.0  USE="bluetooth cdr cups extras fallback -accessibility" 0 kB

Total: 142 packages (133 new, 6 in new slots, 3 reinstalls), Size of downloads: 10,307 kB


The following mask changes are necessary to proceed:
#required by sys-fs/udisks-2.0.0, required by gnome-base/gvfs-1.12.3-r1[udisks], required by sci-geosciences/geocode-glib-0.99.0, required by net-im/empathy-3.4.2.3[geocode], required by gnome-base/gnome-core-apps-3.4.1, required by gnome-base/gnome-3.4.1, required by gnome (argument)
# /etc/portage/package.mask:
#=dev-scheme/guile-gnome-platform-2.16.1-r1
#=media-sound/snd-ls-0.9.9.2_beta
=sys-auth/polkit-0.107-r1

The following USE changes are necessary to proceed:
#required by sys-auth/polkit-0.107-r1, required by gnome-base/gnome-panel-3.4.2.1, required by gnome-base/gnome-applets-3.4.1, required by gnome-base/gnome-3.4.1[fallback], required by gnome (argument)
>=sys-auth/consolekit-0.4.5_p20120320-r1 policykit
#required by gnome-base/gnome-3.4.1, required by gnome (argument)
=gnome-base/gvfs-1.12.3-r1 udisks
#required by sys-auth/polkit-0.107-r1[pam], required by gnome-base/gnome-panel-3.4.2.1, required by gnome-base/gnome-applets-3.4.1, required by gnome-base/gnome-3.4.1[fallback], required by gnome (argument)
>=sys-auth/pambase-20120417-r1 consolekit
#required by media-sound/pulseaudio-2.1-r1[alsa], required by gnome-base/gnome-settings-daemon-3.4.2, required by gnome-base/gnome-session-3.4.2.1, required by gnome-base/gnome-shell-3.4.2, required by gnome-base/gnome-3.4.1, required by gnome (argument)
>=media-plugins/alsa-plugins-1.0.26 pulseaudio
#required by gnome-base/gnome-control-center-3.4.2-r1, required by gnome-base/gnome-shell-3.4.2, required by gnome-base/gnome-3.4.1, required by gnome (argument)
>=gnome-base/gnome-settings-daemon-3.4.2 policykit

I try with
USE="-fallback -extras -cups -cdr -bluetooth" emerge -vp gnome
but the result is the same. Portage want to unmask policykit and the same USE flag changes.

> 
> Given your description, I'm nearly sure you've got something like
> sys-apps/uam (or perhaps even your own udev rules), that handle automounting.

You are right, I just checked, and I forget to mention uam. The only custom udev rules are for my multi-device dvb card, so they are not relevant here. I only use the UUID in /etc/make.conf for the hdd, so I don't need any udev rules for them.
Comment 10 Markos Chandras (RETIRED) gentoo-dev 2012-10-18 15:57:18 UTC
So maybe it is not libfm that handles automounting but sys-apps/uam?
Comment 11 Dominique Michel 2012-10-18 17:37:01 UTC
(In reply to comment #10)
> So maybe it is not libfm that handles automounting but sys-apps/uam?

Sure, but that change nothing for this bug: I don't want my system to be polluted by *kit and this is exactly what libfm in portage is doing. I would understand it, if the depend on udisks was mandatory, but this depend is not mandatory, that even to get automounting to work in pcmanfm. I can even do manual mount/umount from the contextual menu.
Comment 12 Markos Chandras (RETIRED) gentoo-dev 2012-10-18 17:46:59 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > So maybe it is not libfm that handles automounting but sys-apps/uam?
> 
> Sure, but that change nothing for this bug: I don't want my system to be
> polluted by *kit and this is exactly what libfm in portage is doing. I would
> understand it, if the depend on udisks was mandatory, but this depend is not
> mandatory, that even to get automounting to work in pcmanfm. I can even do
> manual mount/umount from the contextual menu.

You are not following what I am saying. Maybe gvfs[udisks] is mandatory for libfm to handle automounting. You are not having this problem because you are not using libfm for mounting our devices but sys-apps/uam. So by not using [udisks] in gvfs, your libfm is broken but you can't see that because you are using sys-apps/uam.
Comment 13 Rafał Mużyło 2012-10-18 17:58:59 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > So maybe it is not libfm that handles automounting but sys-apps/uam?
> 
> Sure, but that change nothing for this bug: I don't want my system to be
> polluted by *kit and this is exactly what libfm in portage is doing. I would
> understand it, if the depend on udisks was mandatory, but this depend is not
> mandatory, that even to get automounting to work in pcmanfm. I can even do
> manual mount/umount from the contextual menu.

Actually, it's the key point of the problem - as libfm expects to work with a GVolumeMonitor and the default one is the one from gvfs (which depends on udisks), it's effectively crippled (in regard of automount) if one is not available.

As for the first part, I didn't say you need to emerge whole Gnome, so pasting that little tree was off-topic.

(on semi-related note: while I don't use Gnome and am not a fan of udisks, I've seen the sources of uam script and while can't say much about its technical correctness, the concept seems *at least* as flawed as udisks)
Comment 14 Rafał Mużyło 2012-10-18 18:06:06 UTC
@comment 12: just a little note: libfm is actually quite buggy in regard of automount - it's author decided to add '-DG_DISABLE_ASSERT -DG_DISABLE_CHECKS -DG_DISABLE_CAST_CHECKS' as an "optimization tweak", but all that it effectively does is masking how often the lib fails to work correctly. I've got an ebuild, that does away with that silliness and as I play with hotplug, I can see the glib warnings in the console on just about any action.
Comment 15 Dominique Michel 2012-10-18 18:23:27 UTC
(In reply to comment #12)
> (In reply to comment #11)
> 
> You are not following what I am saying. Maybe gvfs[udisks] is mandatory for
> libfm to handle automounting. You are not having this problem because you
> are not using libfm for mounting our devices but sys-apps/uam. So by not
> using [udisks] in gvfs, your libfm is broken but you can't see that because
> you are using sys-apps/uam.

That's too bad. LXDE could have been a good alternative for an *kit system.
Comment 16 Dominique Michel 2012-10-18 19:20:58 UTC
(In reply to comment #13)
> (In reply to comment #11)
> > (In reply to comment #10)
> > > So maybe it is not libfm that handles automounting but sys-apps/uam?
> > 
> > Sure, but that change nothing for this bug: I don't want my system to be
> > polluted by *kit and this is exactly what libfm in portage is doing. I would
> > understand it, if the depend on udisks was mandatory, but this depend is not
> > mandatory, that even to get automounting to work in pcmanfm. I can even do
> > manual mount/umount from the contextual menu.
> 
> Actually, it's the key point of the problem - as libfm expects to work with
> a GVolumeMonitor and the default one is the one from gvfs (which depends on
> udisks), it's effectively crippled (in regard of automount) if one is not
> available.
> 
> As for the first part, I didn't say you need to emerge whole Gnome, so
> pasting that little tree was off-topic.

Sorry. I am not a fan of gnome either. I am using fvwm with fvwm-crystal most of the time. But lxde could have been a good alternative for a *kit free system.

> 
> (on semi-related note: while I don't use Gnome and am not a fan of udisks,
> I've seen the sources of uam script and while can't say much about its
> technical correctness, the concept seems *at least* as flawed as udisks)

For me, this is *kit that is flawed. The recent inclusion of a java script interpreter in polkit was the drop that made me to get ride of it, and of anything that depend on it. I just don't understand how so many developpers can trust a software that is so unmanageable it need a turing complete language like JS to handle its configuration, and make software that depend on it.
Comment 17 Markos Chandras (RETIRED) gentoo-dev 2012-10-18 19:23:08 UTC
(In reply to comment #15)
> (In reply to comment #12)
> > (In reply to comment #11)
> > 
> > You are not following what I am saying. Maybe gvfs[udisks] is mandatory for
> > libfm to handle automounting. You are not having this problem because you
> > are not using libfm for mounting our devices but sys-apps/uam. So by not
> > using [udisks] in gvfs, your libfm is broken but you can't see that because
> > you are using sys-apps/uam.
> 
> That's too bad. LXDE could have been a good alternative for an *kit system.

I wonder how to tackle this problem. It seems like having a "broken/udisk-less libfm" and using another program for automounting is desired by some people. Would it make sense to have a policykit useflag to switch between gvfs and gvfs[udisks]? Or is this approach broken by design? Or use it as is and pull all the *kit stack.
Comment 18 Rafał Mużyło 2012-10-18 21:07:34 UTC
udisks pulls polkit cause it needs a framework for managing authorization of its actions
It might not matter much if you're the only user, but otherwise...

A better name for the useflag would be gvfs-automount - it should say what it does, not what it pulls somewhere up the tree.
Comment 19 Markos Chandras (RETIRED) gentoo-dev 2012-10-18 21:21:11 UTC
yeah that makes sense
Comment 20 Dominique Michel 2012-10-20 10:55:30 UTC
I found a very easy way to crash pcmanfm: select an usb drive on the left panl. It will be shown in the right panel. From the contextaul menu in the left panel, unmount this usb drive. pcmanfm crash every time. As my setup is not supported by gentoo, I will report this bug upstream.

In order to know if this is specific to my *kit free setup or not, can you tell me if pcmanfm crash on your system with the same manipulation?
Comment 21 Markos Chandras (RETIRED) gentoo-dev 2012-10-21 08:22:28 UTC
Obviously I cant reproduce it otherwise I would have never committed a package with such a broken behavior. I am pretty sure it is caused by mixing libfm and uam.
Comment 22 Markos Chandras (RETIRED) gentoo-dev 2012-10-23 22:06:04 UTC
I think this runtime behavior is not optimal for users. I mean having both libfm and uam (or whatever userspace automounter one may uses) will lead to nasty runtime behavior. I am inclined to close this bug as WONTFIX because the disadvantages outweigh the advantages.
Comment 23 Dominique Michel 2012-10-24 16:13:12 UTC
I try to remove uam and relaod the udeb rules with "udevadm trigger reload" and get the ysame reproductible crash. To be sure, I restarted udev with "/etc/init.d/udev restart", and still get exactly the same crash. So, this is not related to uam.

Also, pcmanfm can be used outside of lxde, and here, anything is possible.
Comment 24 Dustin C. Hatch 2013-10-26 00:00:31 UTC
I stumbled across this bug today because I have the same feelings as Dominique; I would like to use pcmanfm as a graphical file browser, but I do not want *kit installed on my system. I do not want any sort of automounting, and I use pmount for userspace mounting. To that end, I simply removed

	|| ( gnome-base/gvfs[udev,udisks] gnome-base/gvfs[udev,gdu] )

from RDEPEND in a copy of libfm-1.1.2.2.ebuild in my overlay. Both libfm and pcmanfm compile and install without any problems. I haven't noticed any runtime crashes, even when working with pmount-mounted devices. Clicking the "eject" button, or clicking "Unmount Volume" from the context menu forthese has no effect, but that's to be expected.

Unless I am missing something, I don't see any reason why the dependency on gvfs couldn't be made optional via a USE flag.
Comment 25 Dominique Michel 2013-12-28 23:37:15 UTC
II just get an answer here from one of the pcmanfm developer: http://sourceforge.net/tracker/?func=detail&atid=801867&aid=3614684&group_id=156956

"Unfortunately I cannot help you, pcmanfm does not containt and will never
contain system-specific tools, it uses what GIO implements, and it never
depends on gvfs, ask your distribution maintainers about dependencies."
Comment 26 Dominique Michel 2013-12-29 00:29:11 UTC
Justin's sugestion to completely remove gvfs support from libfm work fine here. Simple and nice. As him, the eject icon doesn't work for the usb drive, but it work just fine with the DVD drive.
Comment 27 Rafał Mużyło 2013-12-29 04:22:59 UTC
(In reply to Dominique Michel from comment #25)
> II just get an answer here from one of the pcmanfm developer:
> http://sourceforge.net/tracker/
> ?func=detail&atid=801867&aid=3614684&group_id=156956
> 
> "Unfortunately I cannot help you, pcmanfm does not containt and will never
> contain system-specific tools, it uses what GIO implements, and it never
> depends on gvfs, ask your distribution maintainers about dependencies."

...and it's already been explained how/when gio uses gvfs in this (automount) context. gvfs volume monitor is the default implementation.
Comment 28 Markos Chandras (RETIRED) gentoo-dev 2013-12-29 10:50:09 UTC
Last time i checked with upstream, they told me that the udisks support in libfm is broken (that was a year ago). I am not sure if it has been improved or not. But if it works for you, we can have the useflag, i don't mind.
Comment 29 Rafał Mużyło 2013-12-29 14:28:17 UTC
(In reply to Markos Chandras from comment #28)
> Last time i checked with upstream, they told me that the udisks support in
> libfm is broken (that was a year ago). I am not sure if it has been improved
> or not. But if it works for you, we can have the useflag, i don't mind.

I suspect what they've meant was "*direct* udisks support is broken" - you know, that part from comment 8.
Comment 30 Markos Chandras (RETIRED) gentoo-dev 2013-12-29 15:32:13 UTC
(In reply to Rafał Mużyło from comment #29)
> (In reply to Markos Chandras from comment #28)
> > Last time i checked with upstream, they told me that the udisks support in
> > libfm is broken (that was a year ago). I am not sure if it has been improved
> > or not. But if it works for you, we can have the useflag, i don't mind.
> 
> I suspect what they've meant was "*direct* udisks support is broken" - you
> know, that part from comment 8.

sorry yes that's why I meant.
Comment 31 Markos Chandras (RETIRED) gentoo-dev 2013-12-29 15:37:45 UTC
The proposed patch seems to work for me so I will commit it soon.
Comment 32 Markos Chandras (RETIRED) gentoo-dev 2013-12-30 10:35:46 UTC
+  30 Dec 2013; Markos Chandras <hwoarang@gentoo.org> libfm-1.1.4.ebuild,
+  libfm-9999.ebuild, metadata.xml:
+  Add udisks use-flag per bug #438700 for systems without *kit packages. Patch
+  by Dominique Michel <dominique.michel@vtxnet.ch>
+
Comment 33 Dominique Michel 2013-12-30 13:10:15 UTC
Thank you.
Comment 34 Dustin C. Hatch 2014-01-21 05:01:36 UTC
I still don't see why this needs to depend on gvfs at all. As I said, I don't have or want to have a volume management application; I just want a file browser. Please consider replacing `!udisks?` with `udev?` and adding udev to IUSE. That way, if I set USE="-udisks -udev" I get exactly what I expect: no volume management at all.
Comment 35 Markos Chandras (RETIRED) gentoo-dev 2014-01-21 18:01:53 UTC
This bug has derailed long time ago it seems. We also need a patch for your proposal.
Comment 36 Dustin C. Hatch 2014-01-26 03:04:09 UTC
Created attachment 368732 [details, diff]
libfm-use-udev.patch

This patch implements the suggestion from comment #34. A `udev` USE flag controls the dependency on gnome-base/gvfs, regardless of udisks.
Comment 37 Dustin C. Hatch 2014-01-26 03:06:27 UTC
Created attachment 368734 [details, diff]
libfm-use-automount.patch

This patch provides the same functionality as attachment 368732 [details, diff], but in a different way. I came up with this version after looking at other packages in the tree that optionally depend on gnome-base/gvfs, and I think it is more explicit about what's going on.
Comment 38 Markos Chandras (RETIRED) gentoo-dev 2014-01-26 11:25:24 UTC
(In reply to Dustin C. Hatch from comment #37)
> Created attachment 368734 [details, diff] [details, diff]
> libfm-use-automount.patch
> 
> This patch provides the same functionality as attachment 368732 [details, diff] [details,
> diff], but in a different way. I came up with this version after looking at
> other packages in the tree that optionally depend on gnome-base/gvfs, and I
> think it is more explicit about what's going on.

Could you point me to such a package? Why not use 'gvfs' instead of 'automount' since all the 'automount' use flag does is to pull this package but with different use-deps?
Comment 39 Dustin C. Hatch 2014-01-26 16:12:59 UTC
(In reply to Markos Chandras from comment #38)
> (In reply to Dustin C. Hatch from comment #37)
> > Created attachment 368734 [details, diff] [details, diff] [details, diff]
> > libfm-use-automount.patch
> > 
> > This patch provides the same functionality as attachment 368732 [details, diff] [details, diff] [details,
> > diff], but in a different way. I came up with this version after looking at
> > other packages in the tree that optionally depend on gnome-base/gvfs, and I
> > think it is more explicit about what's going on.
> 
> Could you point me to such a package? Why not use 'gvfs' instead of
> 'automount' since all the 'automount' use flag does is to pull this package
> but with different use-deps?

The only package in the tree that has IUSE=gvfs is media-sound/xmms2, and it depends on gnome-base/gnome-vfs.

There are only a few packages that optionally depend on gnome-base/gvfs:

* gnome-base/gnome-light[automount]
* media-gfx/gimp[gnome]
* media-sound/clementine[mtp]
* media-gideo/bonobo-dvd[gnome]
* xfce-base/thunar[udev]

The only two that really apply here are gnome-light and thunar, and I just thought gnome-light's "automount" flag was more expressive. It could easily be changed to udev, though.
Comment 40 Markos Chandras (RETIRED) gentoo-dev 2014-01-26 20:30:02 UTC
Thanks for the report. 'automount' sounds reasonable.
Comment 41 Markos Chandras (RETIRED) gentoo-dev 2014-02-07 22:43:12 UTC
I added "+automount" because i think most users need automount support in pcmanfm. At least I need it :)

I also added REQUIRED_USE="udisks? ( automount )" to indicate that if udisks is enabled then automount must be enabled.

Committed with these fixes.
Comment 42 Markos Chandras (RETIRED) gentoo-dev 2014-02-07 22:43:12 UTC
I added "+automount" because i think most users need automount support in pcmanfm. At least I need it :)

I also added REQUIRED_USE="udisks? ( automount )" to indicate that if udisks is enabled then automount must be enabled.

Committed with these fixes.
Comment 43 Dustin C. Hatch 2014-02-07 23:00:07 UTC
(In reply to Markos Chandras from comment #41)
> I added "+automount" because i think most users need automount support in
> pcmanfm. At least I need it :)
> 
I considered that, but I hate IUSE-defaults with the fire of a thousand suns, so I figured if you wanted it, you could add it. I'd prefer "off with the ability to turn on," but I'll take "on with the ability to turn off" over "on whether you like it or not"

> I also added REQUIRED_USE="udisks? ( automount )" to indicate that if udisks
> is enabled then automount must be enabled.
> 
Seems reasonable

> Committed with these fixes.
Thanks!