Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 438622 - net-wireless/broadcom-sta-6.30.223.30 version bump
Summary: net-wireless/broadcom-sta-6.30.223.30 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: M. B.
URL: https://bbs.archlinux.org/viewtopic.p...
Whiteboard:
Keywords: EBUILD, PATCH
Depends on:
Blocks:
 
Reported: 2012-10-16 19:25 UTC by Ricardo I. Vieitez
Modified: 2015-10-18 06:14 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
broadcom-sta-6.20.155.1.ebuild (broadcom-sta-6.20.155.1.ebuild,2.28 KB, text/plain)
2013-03-01 15:23 UTC, M. B.
Details
broadcom-sta-6.20.155.1.ebuild (broadcom-sta-6.20.155.1.ebuild,2.35 KB, text/plain)
2013-03-01 16:24 UTC, M. B.
Details
broadcom-sta-6.30.223.30.ebuild (broadcom-sta-6.30.223.30.ebuild,2.29 KB, text/plain)
2013-04-18 10:41 UTC, M. B.
Details
broadcom-sta-6.30.223.30.ebuild (broadcom-sta-6.30.223.30.ebuild,2.97 KB, text/plain)
2013-04-26 10:09 UTC, M. B.
Details
broadcom-sta-6.30.223.30.ebuild (broadcom-sta-6.30.223.30.ebuild,2.74 KB, text/plain)
2013-04-28 09:24 UTC, Sergey Popov
Details
broadcom-sta-6.30.223.30.ebuild (broadcom-sta-6.30.223.30.ebuild,2.63 KB, text/plain)
2013-04-28 21:18 UTC, M. B.
Details
Makefile.patch (Makefile.patch,497 bytes, text/plain)
2013-04-28 21:19 UTC, M. B.
Details
broadcom-sta-6.30.223.30-r1.ebuild (broadcom-sta-6.30.223.30-r1.ebuild,2.79 KB, text/plain)
2013-05-01 19:48 UTC, M. B.
Details
add-support-for-linux-3.9.0.patch (add-support-for-linux-3.9.0.patch,397 bytes, patch)
2013-05-01 19:49 UTC, M. B.
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ricardo I. Vieitez 2012-10-16 19:25:20 UTC
My new Dell Vostro V3560 comes with a network adapter that reports itself as:

08:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

Doing some research, apparently the actual chipset of my wireless adapter is: Broadcom 4365. However, the issue at stake here is that this is neither recognized by the kernel nor by broadcom-sta.

Apparently, there is a newer and unreleased version of the Broadcom driver that deals with modern hardware, and that ships with Dell laptops with Ubuntu preinstalled. A more detailed account can be found on this thread: https://bbs.archlinux.org/viewtopic.php?id=145884 .

The driver in question is available for amd64 and x86, and the resources are here:

https://www.dropbox.com/s/n76dcsdtayvp0wm/wireless-bcm43142-dkms-6.20.55.19_i386.deb
https://www.dropbox.com/s/jerkl6uqal5ylv3/wireless-bcm43142-dkms-6.20.55.19_amd64.deb
Comment 1 Ulenrich 2012-10-23 00:59:52 UTC
Please activate the people at broadcom.com to publish their firmware!

This new firmware is published by a chinese with a canonical email. But that email address bounces back. 

Is this a chinese trojan spy attack, trying to dominate the world?
Think of it: it is closed door firmware :(
Comment 2 Peter Leugner 2013-01-19 16:59:10 UTC
Version 6.20.155.1 can be found here:
https://launchpad.net/ubuntu/+source/bcmwl
Comment 3 M. B. 2013-03-01 15:23:33 UTC
Created attachment 340646 [details]
broadcom-sta-6.20.155.1.ebuild

boxed it up for gentoo usage.

tested and works against 3.5; gonna test it against 3.7 as well. supposedly also works with 3.8 and 3.6.
Comment 4 M. B. 2013-03-01 16:24:48 UTC
Created attachment 340656 [details]
broadcom-sta-6.20.155.1.ebuild

okay, i made a booboo

this one should work, though. also against 3.7 now (confirmed).
Comment 5 Pacho Ramos gentoo-dev 2013-03-01 22:09:26 UTC
As you have the hardware to test, would you be willing to proxy maintain this?
http://www.gentoo.org/proj/en/qa/proxy-maintainers/index.xml
Comment 6 M. B. 2013-03-02 08:05:33 UTC
Hmm. I would be willing to, BUT ...

1. In its current form the driver is very buggy. Bug #399747 is still not fixed.
2. Every couple of minutes (10-30) "net_ratelimit" kicks in and the connection is severed for 20-60 seconds - which makes me stamp it "unusable" at this point. This occured to me with both 3.5.7 and 3.7.9.
3. Build against 3.8.1 fails with "FATAL: modpost: GPL-incompatible module wl.ko uses GPL-only symbol '__rcu_read_unlock'". I'm really unsure how to tackle this, apart from filing a bug at Ubuntu's ...

4. It's still not released officially by Broadcom; the only source i found so far is the Ubuntu repo.
Comment 7 Pacho Ramos gentoo-dev 2013-03-02 08:19:35 UTC
Have you tried other alternatives?
https://wiki.archlinux.org/index.php/Broadcom_wireless#Introduction
Comment 8 M. B. 2013-03-02 08:26:35 UTC
Yes, i have.
B43 doesn't support my chipset (BCM4313 / 14e4:4727).
brcmsmac builds fine, loads fine, but has an astonishing lack of sensitivity/signal strength. That means i am only able to associate to a wlan station that's <5 meter away; one wall and the show is over. Scanning shows nothing, while the house i live in bristles with APs.

so i am kind of forced to try broadcom-sta, though i will try investigating brcmsmac further.
Comment 9 Pacho Ramos gentoo-dev 2013-03-02 08:27:41 UTC
Are you running latest kernel-3.8?
Comment 10 M. B. 2013-03-02 10:31:31 UTC
i run 3.5.7 right now, otherwise i have no internet.

but i can confirm the brcmsmac behavior for 3.5.7, 3.3.something, 3.7 and 3.8.
Comment 11 Pacho Ramos gentoo-dev 2013-03-02 11:36:18 UTC
(In reply to comment #10)
> i run 3.5.7 right now, otherwise i have no internet.
> 
> but i can confirm the brcmsmac behavior for 3.5.7, 3.3.something, 3.7 and
> 3.8.

Please check with latest kernel (3.8.x) if possible, if still failing, open a bug here (please CC me to track). That is the only way to get things working in future releases as I am seeing that this proprietary driver has a lot of issues in different distributions
Comment 12 M. B. 2013-04-18 10:41:39 UTC
Created attachment 345880 [details]
broadcom-sta-6.30.223.30.ebuild

brcmsmac remains unusable with 3.8 for me. i will investigate further when i find the time.

meanwhile there is a new release of the 6-series. it seems to be (relatively) stable; no crash or network outages in the past 30 minutes or so.

this is a quick ebuild with no further testing. i will tidy it up in the next couple of days.
Comment 13 M. B. 2013-04-26 10:09:03 UTC
Created attachment 346628 [details]
broadcom-sta-6.30.223.30.ebuild

So far this version of the driver seems to be quite stable; it also fixes bug #399747 - net-wireless/broadcom-sta floods logs with "could not get rate/rssi", which was still happening with 6.20.

it still floods with "@wl_cfg80211_get_station : Wrong Mac address"", though.

in syslog-ng i work around with this (in syslog-ng.conf):

filter f_buggywl { not message("@wl_cfg80211_get_station : Wrong Mac address"); };
#log { source(src); destination(messages); };
#log { source(src); destination(console_all); };
log { source(src); filter(f_buggywl); destination(messages); };
log { source(src); filter(f_buggywl); destination(console_all); };
Comment 14 Sergey Popov gentoo-dev 2013-04-28 09:24:08 UTC
Created attachment 346768 [details]
broadcom-sta-6.30.223.30.ebuild

Improved ebuild:

- fix ebuild header, use default src_compile from linux-mod eclass;
- restrict arches properly through KEYWORDS, bump EAPI to 5;
- improve src_unpack by utilizing unpacker eclass;
- improve src_prepare by proper using of epatch, add epatch_user;
- use src_install from linux-mod eclass.

IMO those sed script in src_prepare() should be converted to patch too...
Comment 15 M. B. 2013-04-28 21:18:34 UTC
Created attachment 346822 [details]
broadcom-sta-6.30.223.30.ebuild

I concur with sed -> patch.

The patch necessary for this ebuild is the next attachment.
Comment 16 M. B. 2013-04-28 21:19:26 UTC
Created attachment 346824 [details]
Makefile.patch

btw, i incorporated all of your changes.
Comment 17 Constantine E. Kozlov 2013-04-30 07:28:07 UTC
Can confirm successful work on kernel 3.8.10.
If needed, can help with tests/checks, anyway this is the only working driver for me (I have bcm43142 hybrid wireless card) except of 6.20.55.19, which was shipped with laptop and has patches to work with kernels till 3.7. Hadn't tried it with >=3.8.
Comment 18 Sergey Popov gentoo-dev 2013-05-01 07:23:22 UTC
+*broadcom-sta-6.30.223.30 (01 May 2013)
+
+  01 May 2013; Sergey Popov <pinkbyte@gentoo.org>
+  +broadcom-sta-6.30.223.30.ebuild,
+  +files/broadcom-sta-6.30.223.30-makefile.patch, metadata.xml:
+  Version bump, wrt bug #438622. Ebuild by M. B. <tomboy64 AT sina.cn>, who
+  will maintain this package through proxy maintainers
Comment 19 M. B. 2013-05-01 19:48:25 UTC
Created attachment 347066 [details]
broadcom-sta-6.30.223.30-r1.ebuild

- make broadcom-sta-6.30 compile against kernel 3.9 (see patch in next attachment)
- tidy up the ebuild
- fix CONFIG_CHECKs
- test to build cleanly against linux-3.0.35-gentoo linux-3.0.75-gentoo linux-3.2.44-gentoo linux-3.4.34-gentoo linux-3.4.42-gentoo linux-3.5.7-gentoo linux-3.6.11-gentoo-r1 linux-3.7.10-gentoo-r1 linux-3.8.3-gentoo-r1 linux-3.8.4-gentoo linux-3.8.5-gentoo linux-3.8.6-gentoo linux-3.8.7-gentoo linux-3.8.8-gentoo linux-3.8.9-gentoo linux-3.8.10-gentoo linux-3.9.0-gentoo
Comment 20 M. B. 2013-05-01 19:49:27 UTC
Created attachment 347068 [details, diff]
add-support-for-linux-3.9.0.patch

please include. Makefile.patch is still necessary as well.
Comment 21 M. B. 2013-05-02 23:57:09 UTC
I upgraded the broadcom-sta-5.100.82.112-r3.ebuild with numerous patches; it now builds fine against:
linux-3.0.35-gentoo linux-3.0.75-gentoo linux-3.2.44-gentoo linux-3.4.34-gentoo linux-3.4.42-gentoo linux-3.5.7-gentoo linux-3.6.11-gentoo-r1 linux-3.7.10-gentoo-r1 linux-3.8.10-gentoo linux-3.8.3-gentoo-r1 linux-3.8.4-gentoo linux-3.8.5-gentoo linux-3.8.6-gentoo linux-3.8.7-gentoo linux-3.8.8-gentoo linux-3.8.9-gentoo linux-3.9.0-gentoo.
Loading was tested against 3.7.10-gentoo-r1 and 3.8.10-gentoo. However, as with brcmsmac, it does neither scan nor associate to the two APs i have to test with. It is very well possible, though, that this is due to my chipset (bcm4313)

broadcom-sta-6.30.223.30-r1.ebuild received a little housecleaning as well compared to the version I posted here. No real changes, though.

Version 5 has one distinctive advantage over version 6, though, in that it compiles fine with the Preemption Model set to "Preemptible Kernel".

Due to the number of new patches (7), I decided not to uploaded this stuff here. Please get it from my overlay, tbc in layman.
(git.overlays.gentoo.org/user/tbc.git)



Especially for broadcom-sta-5.100.82.112-r3.ebuild i require feedback! Does it work fine for you or not?
Comment 22 Sergey Popov gentoo-dev 2013-05-03 07:35:42 UTC
(In reply to comment #21)
> Due to the number of new patches (7), I decided not to uploaded this stuff
> here. Please get it from my overlay, tbc in layman.
> (git.overlays.gentoo.org/user/tbc.git)
> 
> Especially for broadcom-sta-5.100.82.112-r3.ebuild i require feedback! Does
> it work fine for you or not?

Please open another bug for enhancements of broadcom-sta-6* ebuild. This was for bumping version from 5 to 6 and it's certainly fixed
Comment 23 M. B. 2013-05-03 10:33:32 UTC
please see bug #468398 for Improvements for net-wireless/broadcom-sta-6.30.223.30, bug #468388 for Improvements for net-wireless/broadcom-sta-5.100.82.112.