Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 438560 - media-sound/rhythmbox-2.98 version bump
Summary: media-sound/rhythmbox-2.98 version bump
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Keywords: InVCS, PMASKED
Depends on:
Reported: 2012-10-16 10:45 UTC by Mehmet Giritli
Modified: 2013-07-27 10:20 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Mehmet Giritli 2012-10-16 10:45:56 UTC
Bump request for rhythmbox 2.98

Reproducible: Always
Comment 1 Gilles Dartiguelongue (RETIRED) gentoo-dev 2012-10-22 17:42:23 UTC
I worked on this this weekend and it was an horrible failure.
Fails to start without plugin disabled etc.
Need to work with upstream but not much time for that now.

I'll probably add it to the tree but masked so that people can play with it.
Comment 2 Gilles Dartiguelongue (RETIRED) gentoo-dev 2012-10-25 21:27:48 UTC
+*rhythmbox-2.98 (25 Oct 2012)
+  25 Oct 2012; Gilles Dartiguelongue <>
+  rhythmbox-0.12.8-r1.ebuild, rhythmbox-0.13.3.ebuild, rhythmbox-2.96.ebuild,
+  rhythmbox-2.97.ebuild, +rhythmbox-2.98.ebuild:
+  Version bump but masked since it is too broken, bug #438560. Pin gstreamer
+  dependencies to slot.

Here you go. If you feel brave enough, please feel free to submit bug reports to upstream and copy the URL here. TIA.
Comment 3 Mehmet Giritli 2012-12-30 09:17:58 UTC
With my gnome 3.6 upgrade, I tried this finally. Neither totem nor rb worked correctly. Rb appeared to play a song but no sound was produced. Also pulseaudio did not show rb as a app when rb was playing. In the case of totem (describing it here as it might be related), totem played 1 or 2 secs of a track and then paused the playback. I cleared the dconf settings for both and everything started to work. Totem is working without a glitch but rb goes back to the above described state once you reboot your computer. RB Going back to broken doesnt happen between program restarts, only reboots. As soon as I wipe dconf settings for rb like this:

dconf reset -f /org/gnome/rhythmbox/

everything gets back to normal until the next reboot. I think it has something to do with pulseaudio - gst - rb triangle.

Portage (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.4, glibc-2.15-r3, x86_64)
System uname:
Timestamp of tree: Thu, 27 Dec 2012 21:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 3.1.8 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-portage
ACCEPT_LICENSE="* -@EULA dlj-1.1 googleearth AdobeFlash-10 AdobeFlash-10.1 AdobeFlash-10.3 Oracle-BCLA-JavaSE google-talkplugin skype-"
CFLAGS="-O2 -pipe -march=amdfam10"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=amdfam10"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext 64bit X a52 aac acl acpi alsa amd64 apng applet aspell bash-completion beagle berkdb bluetooth bluray branding brasero bzip2 cairo ccache cdda cddax cddb cdr cdrom cdrtools cli colord consolekit cpufreq cracklib crypt css cups cxx dbus dconf deskbar device-mapper dga disk-partition dri dtmf dts dvd dvdnav dvdr dvi dvipdfm eds emboss encode exif extra faac faad fam fbcon fbcondecor ffmpeg firefox flac g3dvl galago gcj gdbm gdu geoclue gif gnome gnome-keyring gnome-online-accounts gnutls gpm gps graphics gstreamer gtk gtk3 h323 hddtemp iconv imap inotify jabber java java6 javascript jingle jpeg jpeg2k kms kpathsea laptop lcms libmpeg2 libnotify libsamplerate mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib musicbrainz nautilus ncurses networkmanager nls nptl nsplugin offensive ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pstricks pulseaudio python qt3support qt4 readline samba science sdl sendto session smp sms socialweb speex spell sqlite sse sse2 sse4a ssl startup-notification svg tcpd theora threads tiff totem tracker transcode truetype udev udisks unicode upnp upnp-av upower usb v4l v4l2 vaapi vdpau vim-syntax vorbis wav wavpack wmf wps wxwidgets x264 xcb xml xv xvid zeitgeist zemberek zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="tr en en_GB en_US" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 4 Calvin Walton 2012-12-31 01:07:01 UTC
One thing to watch out for is that if you have the html (webkit) option enabled on rhythmbox, it will link to both gstreamer-1.0 and gstreamer-0.10 in the same binary. This causes strange failures and crashes.

This is because rhythmbox needs gstreamer-0.10, but the gnome 3.6 version of webkit pulls in gstreamer-1.0.
Comment 5 Mehmet Giritli 2013-01-01 13:17:26 UTC
(In reply to comment #4)
> One thing to watch out for is that if you have the html (webkit) option
> enabled on rhythmbox, it will link to both gstreamer-1.0 and gstreamer-0.10
> in the same binary. This causes strange failures and crashes.
> This is because rhythmbox needs gstreamer-0.10, but the gnome 3.6 version of
> webkit pulls in gstreamer-1.0.

Thanks Calvin, your comment explained a lot as I discovered that everything is fine as long as you don't activate context plugin and been wondering why. But 1.0 port is now in master apparently, so the next release should fix that too.

Perhaps this version should remain hard masked.
Comment 6 Gilles Dartiguelongue (RETIRED) gentoo-dev 2013-01-02 14:50:39 UTC
This is the plan :p
But we still need to fix dependencies for older revisions :)
Comment 7 Pacho Ramos gentoo-dev 2013-07-27 10:20:20 UTC
2.99.1 in the tree