Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 438542 - sys-kernel/genkernel-3.4.24_p2 and unstable 3.4.44.1 fail to build sys-kernel/gentoo-sources-3.4.9
Summary: sys-kernel/genkernel-3.4.24_p2 and unstable 3.4.44.1 fail to build sys-kernel...
Status: RESOLVED DUPLICATE of bug 432604
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Gentoo Genkernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-16 05:57 UTC by tazinblack
Modified: 2012-10-24 16:37 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Kernel config (.config,84.71 KB, text/plain)
2012-10-16 06:01 UTC, tazinblack
Details
emerge --info (emerge_info.txt,4.16 KB, text/plain)
2012-10-16 06:04 UTC, tazinblack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tazinblack 2012-10-16 05:57:48 UTC
genkernsl versions as above fail to build kernel from gentoo-sources 3.4.9

Reproducible: Always

Steps to Reproduce:
1.cd /usr/src/linux
2.genkernel --makeopts="-j4" --menuconfig all
3.
Actual Results:  
genkernel --makeopts="-j4" --menuconfig all
* Gentoo Linux Genkernel; Version 3.4.44.1
* Running with options: --makeopts=-j4 --menuconfig all

* Using genkernel.conf from /etc/genkernel.conf
* Sourcing arch-specific config.sh from /usr/share/genkernel/arch/x86_64/config.sh ..
* Sourcing arch-specific modules_load from /usr/share/genkernel/arch/x86_64/modules_load ..

* Linux Kernel 3.4.9-gentoo for x86_64...
* .. with config file /etc/kernels/kernel-config-x86_64-3.4.9-gentoo
* kernel: Using config from /etc/kernels/kernel-config-x86_64-3.4.9-gentoo
*         Previous config backed up to .config--2012-10-16--07-25-56.bak
* kernel: >> Running mrproper...
*         >> Running oldconfig...
* kernel: >> Cleaning...
* kernel: >> Invoking menuconfig...
#
# configuration written to .config
#


*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.

*         >> Compiling 3.4.9-gentoo bzImage...
*         >> Not installing firmware as it's included in the kernel already (CONFIG_FIRMWARE_IN_KERNEL=y)...
*         >> Compiling 3.4.9-gentoo modules...
* ERROR: Failed to compile the "modules" target...
* 
* -- Grepping log... --
* 
*  Thermal Zone (ACPI_THERMAL) [M/n/?] m
*  Debug Statements (ACPI_DEBUG) [N/y/?] n
*  PCI slot detection driver (ACPI_PCI_SLOT) [N/m/y/?] n
*  Container and Module Devices (EXPERIMENTAL) (ACPI_CONTAINER) [M/y/?] m
*  Smart Battery System (ACPI_SBS) [N/m/y/?] n
*  Hardware Error Device (ACPI_HED) [N/m/y/?] n
*  Boottime Graphics Resource Table support (ACPI_BGRT) [N/m/y/?] (NEW)   ACPI Platform Error Interface (APEI) (ACPI_APEI) [N/y/?] n
*--
* Bus options (PCI etc.)
*
*PCI support (PCI) [Y/n/?] y
*  Support mmconfig PCI config space access (PCI_MMCONFIG) [Y/n] y
*  PCI Express support (PCIEPORTBUS) [Y/n/?] y
*    Root Port Advanced Error Reporting support (PCIEAER) [Y/n/?] y
*      PCI Express ECRC settings control (PCIE_ECRC) [N/y/?] n
*      PCIe AER error injector support (PCIEAER_INJECT) [N/m/y/?] n
*--
*Print additional diagnostics on RCU CPU stall (RCU_CPU_STALL_INFO) [N/y/?] (NEW) Enable tracing for RCU (RCU_TRACE) [N/y/?] n
*Self test for the backtrace code (BACKTRACE_SELF_TEST) [N/m/y/?] n
*Force extended block device numbers and spread them (DEBUG_BLOCK_EXT_DEVT) [N/y/?] n
*Force weak per-cpu definitions (DEBUG_FORCE_WEAK_PER_CPU) [N/y/?] n
*Debug access to per_cpu maps (DEBUG_PER_CPU_MAPS) [N/y/?] n
*CPU notifier error injection module (CPU_NOTIFIER_ERROR_INJECT) [N/m/y/?] n
*--
*  CC [M]  drivers/net/wan/hdlc_raw.o
*  CC [M]  drivers/net/usb/mcs7830.o
*  CC [M]  drivers/net/wan/hdlc_raw_eth.o
*  CC [M]  drivers/usb/atm/ueagle-atm.o
*  CC [M]  drivers/scsi/advansys.o
*drivers/scsi/advansys.c:71:2: Warnung: #warning this driver is still not properly converted to the DMA API
*--
*  CC [M]  drivers/scsi/lpfc/lpfc_mbox.o
*  CC [M]  drivers/scsi/lpfc/lpfc_nportdisc.o
*  CC [M]  drivers/scsi/qla2xxx/qla_dbg.o
*  CC [M]  drivers/scsi/lpfc/lpfc_scsi.o
*  CC [M]  drivers/scsi/lpfc/lpfc_attr.o
*cc1: warnings being treated as errors
*--
* Running with options: --makeopts=-j4 --menuconfig all
* Using genkernel.conf from /etc/genkernel.conf
* Sourcing arch-specific config.sh from /usr/share/genkernel/arch/x86_64/config.sh ..
* Sourcing arch-specific modules_load from /usr/share/genkernel/arch/x86_64/modules_load ..
*
* ERROR: Failed to compile the "modules" target...
* 
* -- End log... --
* 
* Please consult /var/log/genkernel.log for more information and any
* errors that were reported above.
* 
* Report any genkernel bugs to bugs.gentoo.org and
* assign your bug to genkernel@gentoo.org. Please include
* as much information as you can in your bug report; attaching
* /var/log/genkernel.log so that your issue can be dealt with effectively.
* 
* Please do *not* report compilation failures as genkernel bugs!
Comment 1 tazinblack 2012-10-16 06:01:28 UTC
Created attachment 326678 [details]
Kernel config

This is my Kernelconfig
Comment 2 tazinblack 2012-10-16 06:04:40 UTC
Created attachment 326680 [details]
emerge --info

This is my output from emerge --info
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2012-10-16 06:18:55 UTC
You should NOT add arch teams in CC, If you do not know what we do.
Comment 4 tazinblack 2012-10-16 13:59:25 UTC
(In reply to comment #3)
> You should NOT add arch teams in CC, If you do not know what we do.

Sorry, I did not know that this is the CC list. I thought this is the field where you can select the platforms where the problem exists.
Comment 5 Göktürk Yüksek gentoo-dev 2012-10-16 14:06:56 UTC
Can you possibly attach the whole build log? This could be the same as Bug 425816.
Comment 6 Göktürk Yüksek gentoo-dev 2012-10-16 14:21:26 UTC
(In reply to comment #5)
> Can you possibly attach the whole build log? This could be the same as Bug
> 425816.

Actually, I can confirm that it is the same bug. Can you try the patch in the mentioned bug and see if it helps?
Comment 7 tazinblack 2012-10-17 08:03:29 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Can you possibly attach the whole build log? This could be the same as Bug
> > 425816.
> 
> Actually, I can confirm that it is the same bug. Can you try the patch in
> the mentioned bug and see if it helps?

So you want me what to do? Could you please tell some details?
Comment 8 Franz Trischberger 2012-10-17 09:09:02 UTC
> Actually, I can confirm that it is the same bug. Can you try the patch in
> the mentioned bug and see if it helps?

I don't think that are the same bugs. The mentioned one has an unused variable, the patch suppresses all warnings coming from unused variables, so -Werror can't stop compilation.
tazinblack has a warning (treated as error) by a preprocessor-define "#warning" -has nothing to do with an unused variable.

I would like to know if building without genkernel produces an error, too.
Could you
* unpack vanilla sources in your $HOME (or simply backup .config and run make mrproper in the srcdir)
* copy the .config from the currently failing gentoo-sources over there
* make oldconfig
* make
Does that produce an error, too?

I just tried enabling ADVANSYS and LPFC - built fine with gentoo-sources-3.6.2. I even installed 3.4.9 - went fine, too (enabled advansys + lpfc). advansys triggered the warning which was NOT treated as error, lpfc-scsi.c compiled fine, too (without the patch, won't look into that further...)

I strongly assume that has to do with genkernel.
Could you grep your drivers/scsi/Makefile for "Werror"?

For the patch: simply edit drivers/scsi/lpfc/Makefile and put -Wno-unused before the -Werror
Comment 9 tazinblack 2012-10-17 11:04:58 UTC
(In reply to comment #8)
> > Actually, I can confirm that it is the same bug. Can you try the patch in
> > the mentioned bug and see if it helps?
> 
> I don't think that are the same bugs. The mentioned one has an unused
> variable, the patch suppresses all warnings coming from unused variables, so
> -Werror can't stop compilation.
> tazinblack has a warning (treated as error) by a preprocessor-define
> "#warning" -has nothing to do with an unused variable.
> 
> I would like to know if building without genkernel produces an error, too.
> Could you
> * unpack vanilla sources in your $HOME (or simply backup .config and run
> make mrproper in the srcdir)
> * copy the .config from the currently failing gentoo-sources over there
> * make oldconfig
> * make
> Does that produce an error, too?
> 
Yes that also produces the error, too :

  CC [M]  drivers/scsi/lpfc/lpfc_scsi.o
cc1: warnings being treated as errors
drivers/scsi/lpfc/lpfc_scsi.c: In Funktion »lpfc_bg_setup_bpl«:
drivers/scsi/lpfc/lpfc_scsi.c:1900:11: Fehler: Variable »rc« wird nicht verwendet
drivers/scsi/lpfc/lpfc_scsi.c: In Funktion »lpfc_bg_setup_bpl_prot«:
drivers/scsi/lpfc/lpfc_scsi.c:2037:11: Fehler: Variable »rc« wird nicht verwendet
drivers/scsi/lpfc/lpfc_scsi.c: In Funktion »lpfc_bg_setup_sgl«:
drivers/scsi/lpfc/lpfc_scsi.c:2256:11: Fehler: Variable »rc« wird nicht verwendet
drivers/scsi/lpfc/lpfc_scsi.c: In Funktion »lpfc_bg_setup_sgl_prot«:
drivers/scsi/lpfc/lpfc_scsi.c:2386:11: Fehler: Variable »rc« wird nicht verwendet
make[3]: *** [drivers/scsi/lpfc/lpfc_scsi.o] Fehler 1
make[2]: *** [drivers/scsi/lpfc] Fehler 2
make[1]: *** [drivers/scsi] Fehler 2
make: *** [drivers] Fehler 2


> I just tried enabling ADVANSYS and LPFC - built fine with
> gentoo-sources-3.6.2. I even installed 3.4.9 - went fine, too (enabled
> advansys + lpfc). advansys triggered the warning which was NOT treated as
> error, lpfc-scsi.c compiled fine, too (without the patch, won't look into
> that further...)
> 
> I strongly assume that has to do with genkernel.
> Could you grep your drivers/scsi/Makefile for "Werror"?
> 
grep -i Werror drivers/scsi/Makefile does not find a match


> For the patch: simply edit drivers/scsi/lpfc/Makefile and put -Wno-unused
> before the -Werror
I'm just on it to try this one ...
Comment 10 Göktürk Yüksek gentoo-dev 2012-10-17 18:57:32 UTC
(In reply to comment #8)
> > Actually, I can confirm that it is the same bug. Can you try the patch in
> > the mentioned bug and see if it helps?
> 
> I don't think that are the same bugs. The mentioned one has an unused
> variable, the patch suppresses all warnings coming from unused variables, so
> -Werror can't stop compilation.
> tazinblack has a warning (treated as error) by a preprocessor-define
> "#warning" -has nothing to do with an unused variable.
> 
He has "-j4", so there's no clear way of knowing that without the entire log.
I just unpacked =gentoo-sources-3.4.9, copied his '.config' and the first error
I hit is related to lpfc. On the other hand that #warning inside the module
passed fine for me.
Comment 11 Göktürk Yüksek gentoo-dev 2012-10-17 19:00:01 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > Can you possibly attach the whole build log? This could be the same as Bug
> > > 425816.
> > 
> > Actually, I can confirm that it is the same bug. Can you try the patch in
> > the mentioned bug and see if it helps?
> 
> So you want me what to do? Could you please tell some details?

All you need to do is; download the patch file in Bug 425816 to your kernel directory, then do
  patch -p0 -i <patch_file>
and try to recompile your kernel.
Comment 12 tazinblack 2012-10-18 05:51:01 UTC
(In reply to comment #9)
> > For the patch: simply edit drivers/scsi/lpfc/Makefile and put -Wno-unused
> > before the -Werror
> I'm just on it to try this one ...

Yes, this works with genkernel as well as without
Comment 13 tazinblack 2012-10-18 05:58:06 UTC
(In reply to comment #11)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > (In reply to comment #5)
> > > > Can you possibly attach the whole build log? This could be the same as Bug
> > > > 425816.
> > > 
> > > Actually, I can confirm that it is the same bug. Can you try the patch in
> > > the mentioned bug and see if it helps?
> > 
> > So you want me what to do? Could you please tell some details?
> 
> All you need to do is; download the patch file in Bug 425816 to your kernel
> directory, then do
>   patch -p0 -i <patch_file>
> and try to recompile your kernel.

Isn't that the same as mentioned in comment #8, which I already did manually?
Comment 14 tazinblack 2012-10-18 06:42:46 UTC
ok, tested your path as requetes in comment #11 and it worked.
Comment 15 Ben Kohler gentoo-dev 2012-10-24 15:13:04 UTC
This is clearly a dupe of bug #432604
Comment 16 Sergey Popov gentoo-dev Security 2012-10-24 16:37:56 UTC

*** This bug has been marked as a duplicate of bug 432604 ***