Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 438478 - lxde-base/lxsession should depend on sys-power/upower
Summary: lxde-base/lxsession should depend on sys-power/upower
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: LXDE team (DEFUNCT)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-15 15:50 UTC by Dominique Michel
Modified: 2013-08-23 19:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
add udisks USE flag to x11-libs/libfm-1.0.1-r1.ebuild (libfm-1.0.1-r1.ebuild.patch,904 bytes, text/plain)
2012-10-15 15:56 UTC, Dominique Michel
Details
add udisks USE flag to lxde-base/lxsession-0.4.6.1-r1.ebuild (lxsession-0.4.6.1-r1.ebuild.patch,550 bytes, patch)
2012-10-15 16:02 UTC, Dominique Michel
Details | Diff
add udisks USE flag to x11-libs/libfm-1.0.1-r1.ebuild (libfm-1.0.1-r1.ebuild.patch,904 bytes, patch)
2012-10-15 16:03 UTC, Dominique Michel
Details | Diff
adding upower USE flag to lxsession-0.4.6.1-r1.ebuild (lxsession-0.4.6.1-r1_upower.ebuild.patch,550 bytes, patch)
2012-10-17 07:37 UTC, Dominique Michel
Details | Diff
add upower USE flag description (metadata.xml_upower.patch,331 bytes, patch)
2012-10-17 07:38 UTC, Dominique Michel
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Michel 2012-10-15 15:50:10 UTC
When I try to install lxde-meta, portage want to install polkit, cpnsolekit and udisks. I don't want udisks as polkit (and consolekit) depend on it, and I don't want polkit in my system, this is non negociable.

On http://wiki.lxde.org/en/LXDE:PCManFM_build_and_setup_guide udisks is not listed as dependency. I downloaded libfm, and it is a --enable-udisks configure option. So, I modified the lxsession and libfm ebuilds, and after emerging lxde-meta, it work like a charm without udisks.

Reproducible: Always

Steps to Reproduce:
1. USE="-udisks -polkit -consolekit" emerge lxde-meta
2.
3.
Actual Results:  
The above command fail and tell me than I must change my USE flags.

Expected Results:  
Than lxde-meta will be installed without udisks support.
Comment 1 Dominique Michel 2012-10-15 15:56:59 UTC
Created attachment 326616 [details]
add udisks USE flag to x11-libs/libfm-1.0.1-r1.ebuild
Comment 2 Dominique Michel 2012-10-15 16:02:12 UTC
Created attachment 326618 [details, diff]
add udisks USE flag to lxde-base/lxsession-0.4.6.1-r1.ebuild
Comment 3 Dominique Michel 2012-10-15 16:03:07 UTC
Created attachment 326620 [details, diff]
add udisks USE flag to x11-libs/libfm-1.0.1-r1.ebuild
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2012-10-15 18:24:12 UTC
We discussed this so many times in the past. Closing as duplicate of 435414

*** This bug has been marked as a duplicate of bug 435414 ***
Comment 5 Markos Chandras (RETIRED) gentoo-dev 2012-10-16 20:31:13 UTC
Reopening to handle the lxessions request. libfm is discussed (over and over) in bug #435414
Comment 6 Dominique Michel 2012-10-17 07:37:16 UTC
Created attachment 326744 [details, diff]
adding upower USE flag to lxsession-0.4.6.1-r1.ebuild
Comment 7 Dominique Michel 2012-10-17 07:38:14 UTC
Created attachment 326746 [details, diff]
add upower USE flag description
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2012-10-17 08:04:33 UTC
(In reply to comment #7)
> Created attachment 326746 [details, diff] [details, diff]
> add upower USE flag description

upower stats are coming from udev don't they? I think udev is more appropriate.
Comment 9 Dominique Michel 2012-10-17 11:55:11 UTC
Yes, but upower is a separate package, and it depend not only on udev but also on polkit. And other packages are using the USE upower:

# euses upower
kde-base/kdelibs:upower - Use upower for power management
kde-misc/synaptiks:upower - Handle mouse devices correctly across suspend and resume with upower
net-im/telepathy-mission-control:upower - Use sys-power/upower to detect suspend and resume
Comment 10 Markos Chandras (RETIRED) gentoo-dev 2012-10-17 12:01:39 UTC
Fair enough. I see no problem then
Comment 11 Samuli Suominen gentoo-dev 2013-08-23 19:13:11 UTC
Fixed in 0.4.6.1 ebuild without revbump, i've added comments in the ebuild for the actual maintainer too.