Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 437484 - dev-lang/perl-5.16.1 - Pod::Perldoc (perldoc) failures caused by typo
Summary: dev-lang/perl-5.16.1 - Pod::Perldoc (perldoc) failures caused by typo
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL: https://rt.cpan.org/Public/Bug/Displa...
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-10-07 04:51 UTC by Dave Armstrong
Modified: 2014-05-27 06:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
fix typo in Pod::Perldoc v3.17 (pod-perldoc.patch,350 bytes, patch)
2012-10-07 04:51 UTC, Dave Armstrong
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Armstrong 2012-10-07 04:51:08 UTC
Created attachment 325870 [details, diff]
fix typo in Pod::Perldoc v3.17

There's a bug in the perl module Pod::Perldoc (v3.17) that ships with Perl 5.16.1 that causes "perldoc" to fail under certain conditions.  My observation has been that the "-i" flag (for case insensitive matching) reliability triggers it).  In such cases, the following error message results:

"Can't locate object method "Is_dos" via package "Pod::Perldoc" at /usr/lib64/perl5/5.16.1/Pod/Perldoc.pm line 1424".

Both the cause and the solution are quite simple and summarized succinctly in the CPAN bug report to which I linked.  Attached is the patch from CPAN, with the only difference being the paths in the patch header -- I modified it to include the Perl version for maintenance purposes.
Comment 1 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-05-27 06:41:10 UTC
Should be fine in last stable