Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 436744 - vim.eclass - add lua support
Summary: vim.eclass - add lua support
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All All
: Normal enhancement with 4 votes (vote)
Assignee: Vim Maintainers
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-10-01 02:09 UTC by ujihisa
Modified: 2013-08-13 22:19 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
lua support for vim.eclass (vim.eclass.patch,1.54 KB, patch)
2012-10-01 04:05 UTC, ujihisa
Details | Diff
patch for vim.eclass (b.patch,1.46 KB, patch)
2013-03-14 05:13 UTC, ujihisa
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ujihisa 2012-10-01 02:09:22 UTC
vim.eclass supports the following foreign language interfaces currently: perl, python and ruby. Vim supports lua as well, so why don't we let vim.eclass support lua?

https://gist.github.com/3809088

The patch worked for me; I emerged vim and gvim with USE=lua. The Vim says +lua in :version and :lua print '123' worked in the Vim.

# I'm new to Gentoo development. I looked for a place for requesting new feature but couldn't find besides this bug report forum. If it's wrong place, I'm happy to report this to the right place if you can let me know about it.
Comment 1 ujihisa 2012-10-01 04:05:40 UTC
Created attachment 325438 [details, diff]
lua support for vim.eclass
Comment 2 ujihisa 2013-03-14 05:13:39 UTC
Created attachment 341982 [details, diff]
patch for vim.eclass

The line number of the original file, vim.eclass, looks changed slightly, so I updated my patch. Note that the previous patch still works well.
Comment 3 Ole Reifschneider gentoo-dev 2013-07-02 15:25:59 UTC
This would be really nice. What is the problem here?
Comment 4 Jakub S 2013-07-03 09:24:58 UTC
This definitely would be great. Without this plugins like https://github.com/Shougo/neocomplete.vim cannot be used with vim available in gentoo which is pretty silly if you ask me.
Comment 5 Tim Harder gentoo-dev 2013-07-25 00:24:52 UTC
This is waiting for bug #469010 so old ebuilds can be dropped or for me to migrate away from using the vim eclass which will probably be done around the upcoming 7.4 release.
Comment 6 Tim Harder gentoo-dev 2013-08-13 22:19:23 UTC
Added to >=7.4 in CVS.