Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 436598 - net-fs/openafs-1.6.1-r1 USE=doc - dodoc: doc/txt/winnotes is a directory
Summary: net-fs/openafs-1.6.1-r1 USE=doc - dodoc: doc/txt/winnotes is a directory
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrej Filipcic
URL:
Whiteboard:
Keywords: PATCH
: 442844 454242 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-29 13:21 UTC by Andrew Savchenko
Modified: 2013-03-24 06:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.xz (build.log.xz,33.62 KB, text/plain)
2012-09-29 13:22 UTC, Andrew Savchenko
Details
emerge --info (emerge.info,7.53 KB, text/plain)
2012-09-29 13:22 UTC, Andrew Savchenko
Details
openafs-1.6.1-r1.ebuild.patch (openafs-1.6.1-r1.ebuild.patch,344 bytes, patch)
2012-09-29 13:25 UTC, Andrew Savchenko
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Savchenko gentoo-dev 2012-09-29 13:21:50 UTC
Hello,

openafs-1.6.1-r1 fails to install docs:
!!! dodoc: doc/txt/winnotes is a directory

A fix is simple: use dodoc -r.
Comment 1 Andrew Savchenko gentoo-dev 2012-09-29 13:22:40 UTC
Created attachment 325308 [details]
build.log.xz
Comment 2 Andrew Savchenko gentoo-dev 2012-09-29 13:22:49 UTC
Created attachment 325310 [details]
emerge --info
Comment 3 Andrew Savchenko gentoo-dev 2012-09-29 13:25:26 UTC
Created attachment 325312 [details, diff]
openafs-1.6.1-r1.ebuild.patch

Fix docs installation.
Comment 4 Juergen Rose 2012-10-13 13:12:47 UTC
The patch worked for me. Could anybody add the patched ebuild to the portage tree?
Comment 5 Jeroen Roovers gentoo-dev 2012-11-12 12:50:40 UTC
*** Bug 442844 has been marked as a duplicate of this bug. ***
Comment 6 Juergen Rose 2012-11-19 13:16:17 UTC
The patch works also for openafs-1.6.1-r2. Why it is not added to portage tree?
Comment 7 Denis M. (Phr33d0m) 2013-03-11 13:22:38 UTC
*** Bug 454242 has been marked as a duplicate of this bug. ***
Comment 8 Juergen Rose 2013-03-12 10:35:43 UTC
I have to repeat my question, if this patch is working for openafs-1.6.1-r1, openafs-1.6.1-r2 and openafs-1.6.2_pre3, why it is not add to the normal portage tree?
Comment 9 Andrej Filipcic 2013-03-12 10:52:15 UTC
(In reply to comment #8)
> I have to repeat my question, if this patch is working for openafs-1.6.1-r1,
> openafs-1.6.1-r2 and openafs-1.6.2_pre3, why it is not add to the normal
> portage tree?

waiting to be committed.
Comment 10 Juergen Rose 2013-03-18 07:05:07 UTC
The same issue now happens with openafs-1.6.2 from the sabayon overlay.
Comment 11 SpanKY gentoo-dev 2013-03-24 06:04:27 UTC
updated versions are in the tree now