Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 435762 - net-misc/networkmanager-0.9.6.0 disconnects shortly after establishing connection
Summary: net-misc/networkmanager-0.9.6.0 disconnects shortly after establishing connec...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-21 17:56 UTC by qdii
Modified: 2013-07-27 11:13 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
NetworkManager log of a connection session (followed by a disconnection) (nm-log-disconnection,5.74 KB, text/plain)
2012-09-21 17:57 UTC, qdii
Details
dmesg when NetworkManager is used (dmesg-when-networkmanager-is-used,525 bytes, text/plain)
2012-09-21 17:59 UTC, qdii
Details
dmesg when dhcpcd and wpa_supplicant are used instead of NetworkManager (dmesg-when-dhcpcd-and-wpa-supplicant-are-used,408 bytes, text/plain)
2012-09-21 18:00 UTC, qdii
Details
kernel config (tuxonice 3.4.11) (.config,90.42 KB, text/plain)
2012-09-24 13:01 UTC, qdii
Details

Note You need to log in before you can comment on or make changes to this bug.
Description qdii 2012-09-21 17:56:06 UTC
Shortly after a connection is established, NetworkManager disconnects from the AP. Connecting using dhcpcd and wpa_supplicant seems to be working fine, however.

Reproducible: Always

Steps to Reproduce:
1. Start NetworkManager
2. Establish a connection to an AP
Actual Results:  
A disconnection happens.

Expected Results:  
Connection to be established.

emerge --info:

Portage 2.1.11.19 (default/linux/amd64/10.0/desktop/gnome, gcc-4.7.1, glibc-2.15-r2, 3.4.10-tuxonice x86_64)
=================================================================
System uname: Linux-3.4.10-tuxonice-x86_64-Intel-R-_Core-TM-_i5-2430M_CPU_@_2.40GHz-with-gentoo-2.2
Timestamp of tree: Fri, 21 Sep 2012 15:00:01 +0000
ccache version 3.1.8 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.6.8, 2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.10.5-r1::pentoo
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.4
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        1.5.26-r1, 2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo pentoo gentoo-zh x-qdiilay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy ccache clean-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parallel-install protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr en es eo"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/pentoo /var/lib/layman/gentoo-zh /home/qdii/qdiilay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ios ipv6 jpeg laptop lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 readline sdl session socialweb spell sse sse2 ssl startup-notification svg tcpd tiff touchpad truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="i386-pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr en es eo" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 qdii 2012-09-21 17:57:42 UTC
Created attachment 324522 [details]
NetworkManager log of a connection session (followed by a disconnection)

Added NetworkManager log
Comment 2 qdii 2012-09-21 17:59:02 UTC
Created attachment 324524 [details]
dmesg when NetworkManager is used
Comment 3 qdii 2012-09-21 18:00:11 UTC
Created attachment 324526 [details]
dmesg when dhcpcd and wpa_supplicant are used instead of NetworkManager
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-09-23 22:24:10 UTC
Please report this problem directly to networkmanager developers:

https://bugzilla.gnome.org/enter_bug.cgi?product=NetworkManager

Attach the logs, your kernel config, and information about the wireless card and driver that you are using. And then please post the bug url here so we can keep track of it.

(I am asking you to write the upstream report because I cannot reproduce the problem, and networkmanager developers will probably need to ask you some questions about your setup so that they can figure out the cause of the bug.)
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-09-23 22:34:13 UTC
Since the bug appears to be related to ipv6, as a temporary workaround, you may try to disable ipv6 for wlan0 through the gnome-control-center or nm-applet gui (options → ipv6 settings → method=ignore)
Comment 6 qdii 2012-09-24 13:01:24 UTC
The upstream bug report can be seen here:
https://bugzilla.gnome.org/show_bug.cgi?id=684711
Comment 7 qdii 2012-09-24 13:01:45 UTC
Created attachment 324830 [details]
kernel config (tuxonice 3.4.11)
Comment 8 qdii 2012-09-24 13:02:37 UTC
The (In reply to comment #7)
> Created attachment 324830 [details]
> kernel config (tuxonice 3.4.11)

The bug was reported on tuxonice 3.4.10 but is still present on tuxonice 3.4.11.
Comment 9 qdii 2012-09-24 13:04:49 UTC
(In reply to comment #5)
> Since the bug appears to be related to ipv6, as a temporary workaround, you
> may try to disable ipv6 for wlan0 through the gnome-control-center or
> nm-applet gui (options → ipv6 settings → method=ignore)

I tried setting ipv6 to ignore, but it did not help.
Comment 10 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-10-26 23:03:17 UTC
Is this error still present in networkmanager-0.9.6.4?
Comment 11 Pavel Šimerda (pavlix) 2013-03-02 14:54:57 UTC
Cannot it be the following bug in dhclient?

https://bugzilla.redhat.com/show_bug.cgi?id=662254
https://bugzilla.gnome.org/show_bug.cgi?id=680596

There is a lot of dhclient fixes in Fedora that were not accepted upstream.
Comment 12 Hugo Mildenberger 2013-04-10 02:08:46 UTC
This is already a  rather old bug ... but a possible cause is that net.wlan* was started outside of NetworkManager. With OpenRC, the command rc-update show should not list any net.* entries, and and /etc/rc.conf should have rc_hotplug="!net.*"
Comment 13 Pacho Ramos gentoo-dev 2013-06-16 12:03:14 UTC
What is the status of this with 0.9.8.2? Also, it's not clear to me if it's a dhclient problem (can't you test with a dhcpclient alternative) or a kernel driver one :S
Comment 14 Dan Lee 2013-07-18 09:48:32 UTC
Found this https://bbs.archlinux.org/viewtopic.php?id=148493 , so set ipv6 to "link local only" should work, but you need do it again after next boot.
Comment 15 Pacho Ramos gentoo-dev 2013-07-27 11:13:45 UTC
please retest with 0.9.8.2-r3