Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 435674 - app-mobilephone/gnome-phone-manager-0.68: phonemgr.c:47:2: error: too many arguments to function 'bluetooth_client_get_device_model
Summary: app-mobilephone/gnome-phone-manager-0.68: phonemgr.c:47:2: error: too many ar...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Mobile Phone Developers (INACTIVE)
Depends on:
Reported: 2012-09-20 17:06 UTC by Juergen Rose
Modified: 2013-04-09 12:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

/var/tmp/portage/app-mobilephone/gnome-phone-manager-0.68/temp/build.log (build.log,40.25 KB, text/plain)
2012-09-20 17:07 UTC, Juergen Rose

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2012-09-20 17:06:28 UTC
'emerge gnome-phone-manager' fails with:
make[2]: Entering directory `/var/tmp/portage/app-mobilephone/gnome-phone-manager-0.68/work/gnome-phone-manager-0.68/gnome-bluetooth'
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -DGNOMELOCALEDIR=\""/usr/share/locale"\" -DDATA_DIR="\"/usr/share/gnome-phone-manager\"" -DVERSION="\"0.68\"" -DPACKAGE="\"gnome-phone-manager\"" -I./../libgsm -I./../libgsm -I./../src -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare   -pthread -I/usr/include/gnome-bluetooth -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libpng15 -I/usr/include/libdrm -I/usr/include/gconf/2 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include   -march=native -O2 -pipe -c -o libphonemgr_la-phonemgr.lo `test -f 'phonemgr.c' || echo './'`phonemgr.c
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -DGNOMELOCALEDIR=\"/usr/share/locale\" -DDATA_DIR=\"/usr/share/gnome-phone-manager\" -DVERSION=\"0.68\" -DPACKAGE=\"gnome-phone-manager\" -I./../libgsm -I./../libgsm -I./../src -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -pthread -I/usr/include/gnome-bluetooth -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libpng15 -I/usr/include/libdrm -I/usr/include/gconf/2 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -march=native -O2 -pipe -c phonemgr.c  -fPIC -DPIC -o .libs/libphonemgr_la-phonemgr.o
phonemgr.c: In function 'get_type':
phonemgr.c:47:2: error: too many arguments to function 'bluetooth_client_get_device_model'
/usr/include/gnome-bluetooth/bluetooth-client.h:66:15: note: declared here
make[2]: *** [libphonemgr_la-phonemgr.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-mobilephone/gnome-phone-manager-0.68/work/gnome-phone-manager-0.68/gnome-bluetooth'
make[1]: *** [all-recursive] Error 1

root@leopard:/root(33)#  emerge --info '=app-mobilephone/gnome-phone-manager-0.68'
Portage (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r2, 3.5.4-gentoo x86_64)
                        System Settings
System uname: Linux-3.5.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
Timestamp of tree: Thu, 20 Sep 2012 14:30:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.4
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo lisp science sunrise bicatali x11 sage-on-gentoo arcon ibormuth java-overlay x-portage x-cpan x-g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype- googleearth AdobeFlash-10.3 cadsoft Oracle-BCLA-JavaSE"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr ru"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/lisp /var/lib/layman/science /var/lib/layman/sunrise /var/lib/layman/bicatali /var/lib/layman/x11 /var/lib/layman/sage-on-gentoo /var/lib/layman/arcon /var/lib/layman/ibormuth /var/lib/layman/java-overlay /usr/local/portage /var/lib/cpan /var/lib/g-octave"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit cracklib crypt css cuda cups curl cxx daap db dbi dbm dbus declarative devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse g3dvl gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gstreamer gtk gtk3 gudev guile harness hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 ide imagemagick imap inotify ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdepim kdrive kerberos keymap kpathsea kqemu kvm ladspa lame lapack latex lcms ldap lensfun libffi libkms libnotify libsamplerate live lm_sensors lua lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mng modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking networkmanager nfs nls nntp nptl nsplugin ntfs ntp numpy nvidia obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp overview pam pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime readline reiserfs reports rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soup sox speex spell sql sqlite sse sse2 sse4 ssl subtitles subversion sudo suexec svg svm swig szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus threads thunderbird tidy tiff tk tools truetype udev unicode usb userlocales utempter vaapi video virtualbox visio vorbis wav webdav webdav-serf webkit wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings
app-mobilephone/gnome-phone-manager-0.68 was built with the following:
USE="gnome (multilib) -debug"

root@leopard:/root(34)# emerge -pqv '=app-mobilephone/gnome-phone-manager-0.68'
[ebuild   R   ] app-mobilephone/gnome-phone-manager-0.68  USE="gnome -debug" 

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Comment 1 Juergen Rose 2012-09-20 17:07:18 UTC
Created attachment 324406 [details]
Comment 2 Juergen Rose 2012-10-05 11:54:16 UTC
Any news?
Comment 3 Gilles Dartiguelongue (RETIRED) gentoo-dev 2012-10-05 22:23:17 UTC
Yes, I have seen the same behavior on my machines.

I intend to integrate upstream patches from git that already fix this issue asap.
Comment 4 rainer 2012-11-03 21:38:52 UTC
I am encountering the same error.
The status should be set to confirmed.
The error has been around now for a long time already.
Comment 5 Juergen Rose 2012-12-18 08:18:12 UTC
It still does not work.
Comment 6 Gilles Dartiguelongue (RETIRED) gentoo-dev 2012-12-18 08:29:47 UTC
Yes, things like this don't automagically fix themselves...

This package has several build issues due to various API changes in packages it uses so best thing would probably be to ask upstream for a new release.
Comment 7 Juergen Rose 2013-02-24 15:32:07 UTC
This project seems to be rather dead. The last file in the download directory is from October  16th 2011. The last mail in the related mailing list was at July 2012. Can we do something to support this project?
Comment 8 Juergen Rose 2013-02-24 15:51:55 UTC
I also tried to compile the code from the git repository git:// It fails with:
make[3]: Entering directory `/usr/src_impala/GnomePhoneManager/phonemgr/libgsm'
  CC       phonemgr-listener.lo
phonemgr-listener.c: In function 'phonemgr_listener_emit_message':
phonemgr-listener.c:360:2: warning: pointer targets in passing argument 1 of 'gn_char_def_alphabet' differ in signedness [-Wpointer-sign]
/usr/include/gnokii/encoding.h:35:16: note: expected 'unsigned char *' but argument is of type 'char *'
phonemgr-listener.c: In function 'phonemgr_listener_init':
phonemgr-listener.c:411:2: warning: 'g_mutex_new' is deprecated (declared at /usr/include/glib-2.0/glib/deprecated/gthread.h:271) [-Wdeprecated-declarations]
phonemgr-listener.c: In function 'phonemgr_listener_finalize':
phonemgr-listener.c:430:3: warning: 'g_mutex_free' is deprecated (declared at /usr/include/glib-2.0/glib/deprecated/gthread.h:273) [-Wdeprecated-declarations]
phonemgr-listener.c: In function 'phonemgr_listener_connect':
phonemgr-listener.c:516:2: warning: 'g_thread_create' is deprecated (declared at /usr/include/glib-2.0/glib/deprecated/gthread.h:100): Use 'g_thread_new' instead [-Wdeprecated-declarations]
  CC       phonemgr-utils.lo
In file included from phonemgr-utils.c:30:0:
/usr/include/evolution-data-server-3.6/libebook/e-contact.h:10:2: error: #error "Only <libebook/libebook.h> should be included directly."
In file included from /usr/include/evolution-data-server-3.6/libebook/e-contact.h:18:0,
                 from phonemgr-utils.c:30:
/usr/include/evolution-data-server-3.6/libebook/e-vcard.h:24:2: error: #error "Only <libebook/libebook.h> should be included directly."
phonemgr-utils.c: In function 'phonemgr_utils_start_parse':
phonemgr-utils.c:423:2: warning: 'g_atexit' is deprecated (declared at /usr/include/glib-2.0/glib/gutils.h:239) [-Wdeprecated-declarations]
phonemgr-utils.c: In function 'phonemgr_utils_connect':
phonemgr-utils.c:525:2: warning: 'gn_cfg_memory_read' is deprecated (declared at /usr/include/gnokii.h:271) [-Wdeprecated-declarations]
phonemgr-utils.c:538:2: warning: 'gn_cfg_phone_load' is deprecated (declared at /usr/include/gnokii.h:278) [-Wdeprecated-declarations]
phonemgr-utils.c:546:2: warning: 'gn_gsm_initialise' is deprecated (declared at /usr/include/gnokii.h:263) [-Wdeprecated-declarations]
make[3]: *** [phonemgr-utils.lo] Error 1
Comment 9 Pacho Ramos gentoo-dev 2013-02-24 16:24:21 UTC
Applying Fedora patches should help:
Comment 10 Pacho Ramos gentoo-dev 2013-04-07 07:52:36 UTC
+*gnome-phone-manager-0.69 (07 Apr 2013)
+  07 Apr 2013; Pacho Ramos <>
+  +files/0001-Adapt-to-Evolution-Data-Server-API-changes.patch,
+  +gnome-phone-manager-0.69.ebuild:
+  Version bump, also fixes building with eds-3.6

It builds fine for me
Comment 11 Juergen Rose 2013-04-09 12:26:15 UTC
It builds for me, too.