Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 435648 - x11-libs/libpciaccess-0.13.1 Segmentation fault always occurs when starting X, using later versions xf86-video-vesa-2.3.0-r1
Summary: x11-libs/libpciaccess-0.13.1 Segmentation fault always occurs when starting X...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: FreeBSD (show other bugs)
Hardware: All FreeBSD
: Normal normal (vote)
Assignee: Gentoo/BSD Team
URL: http://bugs.debian.org/cgi-bin/bugrep...
Whiteboard:
Keywords: PATCH
: 471040 (view as bug list)
Depends on:
Blocks: 477604
  Show dependency tree
 
Reported: 2012-09-20 14:21 UTC by Yuta SATOH
Modified: 2013-08-03 09:08 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuta SATOH 2012-09-20 14:21:26 UTC
x11-base/xorg-server-1.11.4-r1 works. However, later versions Segmentation fault occurs.

I found similar cases in the Debian bug tracker.
Details please see URL.

Reproducible: Always





I have confirmed that the problem has been fixed by applying this patch to x11-libs/libpciaccess-0.13.1 .

http://anonscm.debian.org/gitweb/?p=pkg-xorg/lib/libpciaccess.git;a=blob_plain;f=debian/patches/FreeBSD-implement-map_legacy-and-legacy_io.patch

Package list of test environment
x11-libs/libpciaccess-0.13.1 (patched)
x11-drivers/xf86-video-vesa-2.3.2
x11-base/xorg-server-1.13.0
Comment 1 Yuta SATOH 2012-09-20 14:42:26 UTC
I was a little mistake the first line.

Combination of x11-base/xorg-server-1.11.4-r1 and x11-drivers/xf86-video-vesa-2.3.0 works.
Comment 2 Alexis Ballier gentoo-dev 2012-09-20 14:45:56 UTC
did you try the patch attached there ? has it been upstreamed ?
Comment 3 Yuta SATOH 2012-09-23 08:33:48 UTC
(In reply to comment #2)
> did you try the patch attached there ? has it been upstreamed ?

Thank you for your comment.

I already tried the patch at the time of reporting.
And I confirmed that X start with a combination of the latest xorg-server and vesa driver.

I don't have to report upstream.
The patch was written by the Debian developer.
I'm not the author of the patch.

Do I report to upstream and is it no problems ?
Comment 4 Alexis Ballier gentoo-dev 2012-09-23 13:02:11 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > did you try the patch attached there ? has it been upstreamed ?
> 
> Thank you for your comment.
> 
> I already tried the patch at the time of reporting.
> And I confirmed that X start with a combination of the latest xorg-server
> and vesa driver.

good

> I don't have to report upstream.
> The patch was written by the Debian developer.
> I'm not the author of the patch.

debian people probably have reported it, so it was more to have a link to it


> Do I report to upstream and is it no problems ?

if you dont find any report of this, yes please, explaining the problem and giving a link to the debian bug report
Comment 6 Yuta SATOH 2013-08-03 08:58:10 UTC
fixed in libpciaccess-0.13.2
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-08-03 09:08:28 UTC
*** Bug 471040 has been marked as a duplicate of this bug. ***