Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 435614 - STABLEREQ net-misc/strongswan-5.0.0
Summary: STABLEREQ net-misc/strongswan-5.0.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Bjarke Istrup Pedersen (RETIRED)
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 436682
Blocks:
  Show dependency tree
 
Reported: 2012-09-20 08:27 UTC by Bjarke Istrup Pedersen (RETIRED)
Modified: 2012-10-17 03:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
strongswan-5.0.0 build log (strongswan-5.0.0:20120920-164808.log,759.28 KB, text/plain)
2012-09-21 09:15 UTC, Vicente Olivert Riera (RETIRED)
Details
Fix build when USE="ikev1 -ikev2" (fix-build-ikve-wtihout-ivke2.patch,1.06 KB, patch)
2012-09-21 11:18 UTC, Anthony Basile
Details | Diff
cmake build log (build.log.tar,14.36 KB, application/x-tar)
2012-09-25 02:06 UTC, mike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2012-09-20 08:27:38 UTC
Please stabilize net-misc/strongswan-5.0.0 - has been in the tree without any real bugs for quite a while.
Comment 1 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-09-21 09:15:48 UTC
Created attachment 324480 [details]
strongswan-5.0.0 build log
Comment 2 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-09-21 09:16:24 UTC
Testing on amd64:

1- Missing RDEPEND sys-libs/glibc
2- Fails to compile if ikev2 USE flag is not activated


# emerge --info
Portage 2.1.11.9 (default/linux/amd64/10.0/desktop, gcc-4.5.4, glibc-2.15-r2, 3.4.9-gentoo x86_64)
=================================================================
System uname: Linux-3.4.9-gentoo-x86_64-AMD_Sempron-tm-_Processor_3800+-with-gentoo-2.1
Timestamp of tree: Thu, 20 Sep 2012 03:00:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo peratu
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -g0"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles multilib-strict news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms split-log strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="es_ES.utf8"
LC_ALL="es_ES.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="es"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://atom/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv jpeg lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vdpau vorbis wxwidgets x264 xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="es" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 3 Anthony Basile gentoo-dev 2012-09-21 09:19:17 UTC
(In reply to comment #2)
> Testing on amd64:
> 
> 1- Missing RDEPEND sys-libs/glibc
> 

We don't put dependencies on the toolchain.  Is there some special reason why you think you need RDEPEND on glibc?  eg it uses glibc-ism that aren't available in any other libcs?
Comment 4 Anthony Basile gentoo-dev 2012-09-21 09:58:18 UTC
(In reply to comment #2)
> Testing on amd64:
> 2- Fails to compile if ikev2 USE flag is not activated

Okay confirmed.  Its a missing symbol:

libtool: link: x86_64-pc-linux-gnu-gcc -DIPSEC_DIR=\"/usr/libexec/ipsec\" -DIPSEC_PIDDIR=\"/var/run\" "-DPLUGINS=\"curl ldap mysql sqlite aes des sha1 sha2 md5 random nonce x509 revocation constraints pubkey pkcs1 pkcs8 pgp dnskey pem openssl fips-prf gmp xcbc cmac hmac attr attr-sql kernel-netlink resolve socket-default stroke sql updown xauth-generic\"" -O2 -pipe -Wl,-O1 -Wl,--as-needed -o .libs/charon charon.o  ../../src/libstrongswan/.libs/libstrongswan.so ../../src/libhydra/.libs/libhydra.so ../../src/libcharon/.libs/libcharon.so -lm -lpthread -ldl -Wl,-rpath -Wl,/usr/lib64/ipsec
../../src/libcharon/.libs/libcharon.so: undefined reference to `ike_auth_lifetime_create'
collect2: ld returned 1 exit status
make[3]: *** [charon] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-misc/strongswan-5.0.0/work/strongswan-5.0.0/src/charon'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/net-misc/strongswan-5.0.0/work/strongswan-5.0.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-misc/strongswan-5.0.0/work/strongswan-5.0.0'
make: *** [all] Error 2


Almost everyone will want IKEv2, but before we force it on, let me take a look at what's going on in the build system.
Comment 5 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2012-09-21 10:52:29 UTC
Should be fixed now, I have removed the ikev1 and ikev2 useflags, since it makes no sense having them anymore.

No, i'm not going to make it depend on the toolchain, since that would also mean it should depend on gcc, binutils ect. , which really should be on an system building the package anyway.
Comment 6 Anthony Basile gentoo-dev 2012-09-21 11:18:47 UTC
Created attachment 324490 [details, diff]
Fix build when USE="ikev1 -ikev2"

The text at the top of the patch explains what's going on.  It should go upstream.
Comment 7 Anthony Basile gentoo-dev 2012-09-21 11:21:30 UTC
(In reply to comment #5)
> Should be fixed now, I have removed the ikev1 and ikev2 useflags, since it
> makes no sense having them anymore.
> 
> No, i'm not going to make it depend on the toolchain, since that would also
> mean it should depend on gcc, binutils ect. , which really should be on an
> system building the package anyway.

I agree that ikev1 and ikev2 should almost always be on.  I don't know the value in exposing these configure options to our users, so I think your choise is reasonable.  Upstream should still be made aware.  Should I do it?  Or do you want to?
Comment 8 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2012-09-21 11:36:30 UTC
(In reply to comment #7)
> I agree that ikev1 and ikev2 should almost always be on.  I don't know the
> value in exposing these configure options to our users, so I think your
> choise is reasonable.  Upstream should still be made aware.  Should I do it?
> Or do you want to?

I'm quite busy for the next few days, so if you'll do it, it would be great :)

Now that we got this fixed, please go on with stabilizing - build errors that has been fixed shouldn't be a blocker for stabilizing, since it doesn't change functionality.
Comment 9 Anthony Basile gentoo-dev 2012-09-22 13:13:12 UTC
Upstream bug report: http://wiki.strongswan.org/issues/229
Comment 10 Anthony Basile gentoo-dev 2012-09-24 02:57:54 UTC
stable ppc

also keyword ~ppc64
Comment 11 Anthony Basile gentoo-dev 2012-09-24 03:42:29 UTC
stable arm
Comment 12 Agostino Sarubbo gentoo-dev 2012-09-24 10:35:57 UTC
it fails fowners:

chown: impossibile accedere a "/tmp/portage/net-misc/strongswan-5.0.0/image//etc/ipsec.secrets": File o directory non esistente
fowners failed
Comment 13 mike 2012-09-25 02:06:51 UTC
Created attachment 324912 [details]
cmake build log

x86 not ok (repoman ok, compile fails because of dependency dev-util/cmake-2.8.8-r3 -> see build.log.tar)
Comment 14 mike 2012-09-25 02:18:00 UTC
(In reply to comment #13)
> Created attachment 324912 [details]
> cmake build log
> 
> x86 not ok (repoman ok, compile fails because of dependency
> dev-util/cmake-2.8.8-r3 -> see build.log.tar)

recheck with cmake-2.8.9 gives same results
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2012-09-25 15:23:59 UTC
@peratu,  you should exclude gcc/glibc and all package from @system when you check RDEPEND
Comment 16 Raúl Porcel (RETIRED) gentoo-dev 2012-09-30 17:04:04 UTC
sparc keywords dropped
Comment 17 Agostino Sarubbo gentoo-dev 2012-09-30 18:00:06 UTC
amd64 stable, thanks to everyone.
Comment 18 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2012-09-30 18:06:58 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > Created attachment 324912 [details]
> > cmake build log
> > 
> > x86 not ok (repoman ok, compile fails because of dependency
> > dev-util/cmake-2.8.8-r3 -> see build.log.tar)
> 
> recheck with cmake-2.8.9 gives same results

Could you please post the output of: emerge --info ?
I would like to see your use flags to see what pulls cmake into the dependency graph.
Comment 19 mike 2012-09-30 23:58:18 UTC
(In reply to comment #18)
The origin of the cmake-dependency is:
net-misc/strongswan-5.0.0 -> virtual/mysql-5.1 -> dev-db/mysql-5.1.62-r1 -> dev-util/cmake-2.8.9 (mysql use-flag)

I just recompiled strongswan a 3rd time and now everything works fine (perhaps as a result of an upstream-report?).

After all, here is the output of emerge --info

Portage 2.1.11.9 (default/linux/x86/10.0, gcc-4.5.4, glibc-2.15-r2, 3.3.8-gentoo i686)
=================================================================
System uname: Linux-3.3.8-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_L9400_@_1.86GHz-with-gentoo-2.1
Timestamp of tree: Sun, 30 Sep 2012 18:45:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.7
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs ccache collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync1.de.gentoo.org/gentoo-portage"
USE="X acl bash-completion berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 jpeg modules mudflap ncurses nptl openmp pam pcre png pppd readline session sse sse2 sse3 ssl tcpd unicode x86 zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 20 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2012-10-10 15:58:05 UTC
Since mysql is stable, this shouldn't be blocking stabilizing strongswan.

Better, you should open a bug about cmake breaking with mysql.
Comment 21 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-10-17 03:46:47 UTC
x86 stable, closing