Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 435134 - [gnome-overlay] gnome-base/gdm-3.5.9 tries to reuse console already in use
Summary: [gnome-overlay] gnome-base/gdm-3.5.9 tries to reuse console already in use
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: NeedPatch
Depends on:
Blocks: gnome3.6
  Show dependency tree
 
Reported: 2012-09-15 17:02 UTC by John Covici
Modified: 2013-08-24 13:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (temp.txt,15.97 KB, text/plain)
2012-09-15 17:04 UTC, John Covici
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Covici 2012-09-15 17:02:07 UTC
When I start gdm, it tries to use console 7 even though I have up to 11 as normal login consoles.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.start gdm on a system where you have console 7 and > in use.
Actual Results:  
gdm tries to use console 7 and messes things up royally.

Expected Results:  
gdm should use the console after the last one in use.

Previous versions of gdm did do this correctly, although on my system they had other problems.
Comment 1 John Covici 2012-09-15 17:04:21 UTC
Created attachment 323908 [details]
emerge --info
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-09-15 18:44:49 UTC
If you are using gdm with USE=-systemd, then in /etc/conf.d/xdm, make sure to set DISPLAYMANAGER="gdm" and CHECKVT="11" (or whatever other console is guaranteed to not be used for anything). Then /etc/init.d/xdm should in theory use that console when launching gdm.
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-09-15 18:46:06 UTC
Also, gdm-3.5.9 is long obsolete. Please update to 3.5.91-r2.
Comment 4 John Covici 2012-10-10 10:57:47 UTC
This is still present in gdm 3.6.0-r1
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-10-10 11:24:38 UTC
Then we probably need a gentoo-specific patch for gdm to read the value of CHECKVT from /etc/conf.d/xdm at runtime.

Something like the following logic:

if using systemd, do the automagic systemd thing.
else try parsing /etc/conf.d/xdm for the initial vt.
else fall back to GDM_INITIAL_VT for the initial vt.
Comment 6 Gilles Dartiguelongue gentoo-dev 2013-01-22 22:45:52 UTC
This report does not contain any update wrt. verifications suggested by Alexandre. Please update the report with them.
Comment 7 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-01-23 03:54:39 UTC
(In reply to comment #6)
> This report does not contain any update wrt. verifications suggested by
> Alexandre. Please update the report with them.

Unless someone wrote and committed the patch that I described in comment #5, the problem is still present in our gdm-3.6.x.
Comment 8 John Covici 2013-01-23 05:44:53 UTC
In earlier versions of gdm, they did not check /etc/conf.d/xdm, but actually checked to see if the console was in use -- I have 11 text consoles already running and I don't want gdm to try to use console 7 because its logged in or has login running.  Maybe you could check /etc/inittab, or check the processes.
Comment 9 Gilles Dartiguelongue gentoo-dev 2013-01-23 23:20:12 UTC
so changing CHECKVT to 11/12 does not fix the issue ?
Please note that upstream does not care about this part of the code, really, it never worked properly in the 3.* series and will probably never will as upstream now relies on systemd to handle this. No matter how many patches we tried...
Comment 10 John Covici 2013-02-04 19:55:21 UTC
(In reply to comment #9)
> so changing CHECKVT to 11/12 does not fix the issue ?
> Please note that upstream does not care about this part of the code, really,
> it never worked properly in the 3.* series and will probably never will as
> upstream now relies on systemd to handle this. No matter how many patches we
> tried...


What is checkvt?  Is it some config option and if so, where does it go?
Comment 11 Pacho Ramos gentoo-dev 2013-08-24 13:22:42 UTC
this no longer occurs in 3.8