Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 434926 - >=net-im/skype-4.0.0.7 - login failure, stuck at "signing in" with JFS filesystem
Summary: >=net-im/skype-4.0.0.7 - login failure, stuck at "signing in" with JFS filesy...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-13 16:43 UTC by Mattia Rossi
Modified: 2013-04-20 16:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_434926.txt,6.06 KB, text/plain)
2012-09-13 16:50 UTC, Mattia Rossi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mattia Rossi 2012-09-13 16:43:18 UTC

    
Comment 1 Mattia Rossi 2012-09-13 16:50:11 UTC
Created attachment 323692 [details]
emerge --info

Ok, her's the Problem. Since updating to Skype 4.0.0.7 I can't login anymore.
This means, that Skype just sits there with the circle on top circling, saying: signing in.

Everything else is grayed out.

Removing the .Skype directory didn't help, upgrading to 4.0.0.8 and 4.0.0.8-r1 didn't help, Downgrading didn't help either! I can't get any version of Skype to work anymore.

Network connection is up and runnig (otherwise I wouldn't be able to write this).
Have no clue on what's wrong.

Exiting Skype doesn't terminate it, terminating it manually (15) doesn't help, have to kill it (9).

Any hints?

emerge --info is attached, System updated today.
Comment 2 Cameron 2012-09-23 12:27:37 UTC
I had the same problem tonight with a fresh install of skype 4.0.0.8-r1 including a wipe of ~/.Skype

Initially I had qt-static use flag set which I unset, and also noticed a problem with pulseaudio crashing which was fixed with a reemerge.

I then also reran skype, went into Options - Advanced and changed incoming port for connections from 0 to some random number above 10000 before attempting to sign in. Then it worked.

I tried to reproduce this bug by uninstalling and wiping ~/.Skype but could not get login issue to occur again.

Trust this helps.
Comment 3 Mattia Rossi 2012-10-04 13:56:06 UTC
Ok, just back from vacation, tried to wipe .Skype, made sure qt-static was not set, checked whether I use pulseaudio, which I don't, set the port to something above 10000, but couldn't get Skype to work. Tried various combinations, uninstalled and reinstalled Skype, no chance.
I guess there's nothing to do except to stop using Skype :-(
Comment 4 Mattia Rossi 2012-12-20 14:54:35 UTC
Well, at least I've been able to track the issue down now.

For some reason skype seems not to be able to create the necessary database (either the .db files or the DbTemp files) on the disk to start a skype login session, if your disk is formatted with the JFS filesystem.

I have no idea as to why, but it's definitely the problem. I've tried creating the .Skype folder on an EXT4 partition and link the one on the JFS partition to it, and it works flawlessly.
It also works if the content of .Skype (linked - EXT4) is then copied back to the .Skype directory on the JFS partition (unlinked of course), everything works as well.

So I guess that this probably was a Skype problem since some early version, and the reason it worked for me was that I backed up my .Skype folder when I upgraded my PC (the previous one was on a reiserfs), and used that copy on my new JFS system, therefore not disscovering the problem, until I mistakenly wiped all my hidden folders in the home directory.

So as a workaround for JFS users out there that want Skype: try to create a .Skype folder on a different machine with a different filesystem, and copy it over to your machine. Problem solved.

Sucks, but given that it's proprietary code, this will probably never get fixed.
Comment 5 Max Klinger 2013-01-03 04:30:48 UTC
Also wanted to add that we see the same symptoms for a remote mounted fs over nfs with a 3.3.5+ kernel. More details here https://jira.skype.com/browse/SCL-837
Possible JFS also has trouble flock'ing.
Comment 6 Pacho Ramos gentoo-dev 2013-01-03 13:07:10 UTC
Could you report your JFS issue to upstream also?
Comment 7 Samuli Suominen gentoo-dev 2013-04-20 16:29:40 UTC
should be reported at upstream, nothing we can do at ebuild level since this is binary only application