Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 434904 - app-admin/rsyslog-5.8.11 - fix imgssapi plugin
Summary: app-admin/rsyslog-5.8.11 - fix imgssapi plugin
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ultrabug
URL: http://www.mail-archive.com/rsyslog@l...
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: 434902
  Show dependency tree
 
Reported: 2012-09-13 15:04 UTC by Richard Ostrow
Modified: 2013-09-10 07:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for rsyslog-5.8.11 ebuild (and rsyslogd) to fix imgssapi support (rsyslog-5.8.11.gssapi.patch,1.65 KB, patch)
2012-09-13 15:05 UTC, Richard Ostrow
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Ostrow 2012-09-13 15:04:20 UTC
The imgssapi plugin will segfault on initialization if used. The attached patch appears to resolve this issue (works in my environment). Has no effect on the omgssapi plugin, so kerberos senders do not need this patch - only receivers.

Reproducible: Always

Steps to Reproduce:
1. Add "$ModLoad imgssapi" to /etc/rsyslog.conf
2. Set $InputGSSServerServiceName to something reasonable
3. Set $InputGSSServerRun to a port
4. Run rsyslogd
5. Watch it almost immediately segfault
Actual Results:  
rsyslogd segfaults

Expected Results:  
rsyslogd runs with the imgssapi plugin
Comment 1 Richard Ostrow 2012-09-13 15:05:32 UTC
Created attachment 323666 [details, diff]
Patch for rsyslog-5.8.11 ebuild (and rsyslogd) to fix imgssapi support

Not needed if not using the imgssapi plugin. omgssapi does not exhibit this behavior.
Comment 2 Ultrabug gentoo-dev 2012-09-17 14:23:43 UTC
Hi Richard, before we go further with this patch, did you propose it upstream ? If not it would be very cool to do so !

Thank you
Comment 3 Tiziano Müller gentoo-dev 2012-10-29 16:10:37 UTC
un-CC'ing myself since I stepped down as co-maintainer of rsyslog
Comment 4 Ultrabug gentoo-dev 2013-09-10 07:54:37 UTC
This version of rsyslog is not supported and not in tree anymore. Please try with a newer version and open a new bug if the issue persists.

Cheers