Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 434574 - app-portage/genlop: bashcomp script fails when make.conf is in /etc/portage/
Summary: app-portage/genlop: bashcomp script fails when make.conf is in /etc/portage/
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords: PATCH
: 439234 447058 651070 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-10 12:08 UTC by Luis Ressel
Modified: 2018-10-31 15:54 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for /usr/share/bash-completion/genlop (patch,456 bytes, patch)
2012-09-10 12:08 UTC, Luis Ressel
Details | Diff
Proposed patch for genlop's bashcomp script (patch,300 bytes, patch)
2012-10-03 20:30 UTC, Luis Ressel
Details | Diff
Similar patch (genlop.patch,636 bytes, patch)
2012-11-24 11:18 UTC, quazgar
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Ressel 2012-09-10 12:08:38 UTC
Created attachment 323406 [details, diff]
Patch for /usr/share/bash-completion/genlop

If make.conf is in /etc/portage/ instead of /etc/ (portage supports that, and since today it is default for new stage3s), genlop's bash-completion script doesn't work. A patch is attached.
Comment 1 Luis Ressel 2012-09-10 12:11:00 UTC
See also #424777 , but I don't have permission to add that to the "See-Also"-field.
Comment 2 Luis Ressel 2012-10-03 20:30:27 UTC
Created attachment 325614 [details, diff]
Proposed patch for genlop's bashcomp script

As Jeroen pointed out, my patch is far from optimal, so let's do it the simple way...
Comment 3 Zac Medico gentoo-dev 2012-10-23 04:05:07 UTC
*** Bug 439234 has been marked as a duplicate of this bug. ***
Comment 4 quazgar 2012-11-24 11:18:40 UTC
Created attachment 330418 [details, diff]
Similar patch

I would replace the old location entirely, because otherwise pressing <Tab> causes error messages to appear in the shell. Also, should not /etc/make.globals also be changed to /usr/share/portage/config/make.globals?
Comment 5 Jeroen Roovers gentoo-dev 2012-12-13 16:13:07 UTC
*** Bug 447058 has been marked as a duplicate of this bug. ***
Comment 6 Luis Ressel 2014-01-28 19:10:51 UTC
ping
Comment 7 Andrew Udvare 2014-11-23 11:45:19 UTC
rubik's cube, yes. I made a symlink to the actual make.globals in /etc for the time being, because if not, when using tab the entire shell gets screwed up.

$ fgrep -n make.globals /usr/share/bash-completion/completions/genlop 
19:     portagedir="$( (source /etc/make.globals

Needs to be /usr/share/portage/config/make.globals
Comment 9 Horst Prote 2018-10-31 15:54:10 UTC
*** Bug 651070 has been marked as a duplicate of this bug. ***