Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 433497 - sys-fs/aufs3-3_p20120813 - cc1: error: unrecognized command line option ‘-mno-red-zone’
Summary: sys-fs/aufs3-3_p20120813 - cc1: error: unrecognized command line option ‘-mno...
Status: RESOLVED DUPLICATE of bug 432392
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: PPC Linux
: Normal normal with 1 vote (vote)
Assignee: Justin Lecher
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-31 07:26 UTC by Massimo Burcheri
Modified: 2012-09-13 14:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log of 'MAKEOPTS="V=1" emerge -auv sys-fs/aufs3' (build.log,5.37 KB, text/plain)
2012-09-04 08:08 UTC, Massimo Burcheri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Massimo Burcheri 2012-08-31 07:26:51 UTC
sys-fs/aufs3-3_p20120813 fails to build on ~ppc. ~amd64 is fine.

[ebuild  N    ] sys-fs/aufs3-3_p20120813  USE="kernel-patch -debug -doc -fuse -hfs -inotify -nfs -pax_kernel -ramfs" 


Reproducible: Always

Actual Results:  
>>> Compiling source in /var/tmp/portage/sys-fs/aufs3-3_p20120813/work/aufs3-standalone ...
make -j2 CC=powerpc-unknown-linux-gnu-gcc CONFIG_AUFS_FS=m KDIR=/usr/src/linux 
-I/var/tmp/portage/sys-fs/aufs3-3_p20120813/work/aufs3-standalone/include -DCONFIG_AUFS_FS_MODULE -UCONFIG_AUFS -DCONFIG_AUFS_BRANCH_MAX_127 -DCONFIG_AUFS_SBILIST -DCONFIG_AUFS_RDU
make -C /usr/src/linux M=/var/tmp/portage/sys-fs/aufs3-3_p20120813/work/aufs3-standalone/fs/aufs EXTRA_CFLAGS="-I/var/tmp/portage/sys-fs/aufs3-3_p20120813/work/aufs3-standalone/include -DCONFIG_AUFS_FS_MODULE -UCONFIG_AUFS -DCONFIG_AUFS_BRANCH_MAX_127 -DCONFIG_AUFS_SBILIST -DCONFIG_AUFS_RDU" modules
make[1]: Entering directory `/usr/src/linux-3.2.1-gentoo-r2'
  CC [M]  /var/tmp/portage/sys-fs/aufs3-3_p20120813/work/aufs3-standalone/fs/aufs/module.o
  CC [M]  /var/tmp/portage/sys-fs/aufs3-3_p20120813/work/aufs3-standalone/fs/aufs/sbinfo.o
cc1: error: unrecognized command line option ‘-mno-red-zone’
cc1: error: invalid option for -mcmodel: 'kernel'
cc1: error: unrecognized command line option ‘-mcmodel=kernel’
cc1: error: unrecognized command line option ‘-maccumulate-outgoing-args’
cc1: error: unrecognized command line option ‘-mno-red-zone’
cc1: error: invalid option for -mcmodel: 'kernel'
cc1: error: unrecognized command line option ‘-mcmodel=kernel’
cc1: error: unrecognized command line option ‘-maccumulate-outgoing-args’
make[2]: *** [/var/tmp/portage/sys-fs/aufs3-3_p20120813/work/aufs3-standalone/fs/aufs/module.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: *** [/var/tmp/portage/sys-fs/aufs3-3_p20120813/work/aufs3-standalone/fs/aufs/sbinfo.o] Error 1
make[1]: *** [_module_/var/tmp/portage/sys-fs/aufs3-3_p20120813/work/aufs3-standalone/fs/aufs] Error 2
make[1]: Leaving directory `/usr/src/linux-3.2.1-gentoo-r2'
make: *** [fs/aufs/aufs.ko] Error 2
 [31;01m*[0m ERROR: sys-fs/aufs3-3_p20120813 failed (compile phase):


Portage 2.1.11.9 (default/linux/powerpc/ppc32/10.0/desktop, gcc-4.6.3, glibc-2.14.1-r3, 3.2.1-gentoo-r2 ppc)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.2.1-gentoo-r2-ppc-7447A,_altivec_supported-with-gentoo-2.1
Timestamp of tree: Sat, 25 Aug 2012 00:45:01 +0000
distcc 3.1 powerpc-unknown-linux-gnu [disabled]
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13::<unknown repository>, 2.68
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo x-portage sunrise mv
ACCEPT_KEYWORDS="ppc"
ACCEPT_LICENSE="* -@EULA"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-mcpu=7450 -O2 -pipe -maltivec -mabi=altivec -fomit-frame-pointer"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /usr/share/X11/xkb"
CXXFLAGS="-mcpu=7450 -O2 -pipe -maltivec -mabi=altivec -fomit-frame-pointer -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.halifax.rwth-aachen.de/gentoo http://de-mirror.org/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/sunrise /var/lib/layman/mv"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl aim alsa altivec ansi apng aspell automount bash-completion bluetooth branding bzip2 cairo cdda cdparanoia cdr cdrom cli consolekit cracklib crypt cups custom-optimization cxx dbus device-mapper dga divx4linux dri dts dvd dvdr dvdread embedded emboss encode exif fam fbcon ffmpeg firefox flac fontconfig fortran gcj gdbm gecko-sdk geoip gif gimp glibc-omitfp gpm gstreamer gtk gtk2 hbci ibam iconv icq id3 ieee1394 imap ipc jabber java javascript jpeg kdeenablefinal kdehiddenvisibility kontact kpathsea lame lcms libcaca libnotify mad mikmod mjpeg mmap mng modules mp3 mp4 mpeg mplayer msn mudflap musepack musicbrainz ncurses network nls nonfsv4 nptl nsplugin ogg opengl openmp optimization pam pango pcre pdf perl pic png policykit ppc ppcsha1 ppds pppd pthreads python qt3support qt4 quicktime quotes radeon readline redeyes samba sasl scanner sdl semantic-desktop session spell ssl startup-notification strong-optimization subtitles subversion svg tcpd tiff truetype udev udisks unicode upower usb userlocales vcd vim vim-syntax vorbis webkit wifi wxwidgets xcb xcomposite xine xml xmp xprint xscreensaver xv xvid yahoo zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Ulenrich 2012-09-01 00:12:05 UTC
This is a build error. Writing about a commandline option in the summary everybody may think this is an upstream programming bug :(

... also your build error message calls it like this ...
Comment 2 Jeroen Roovers gentoo-dev 2012-09-03 18:09:28 UTC
Please don't CC arch teams.
Comment 3 Jeroen Roovers gentoo-dev 2012-09-03 18:10:02 UTC
Looks like it passes CFLAGS to the CPP.
Comment 4 Justin Lecher gentoo-dev 2012-09-03 20:18:30 UTC
could you please attach a build.log with MAKEOPTS="V=1"?
Comment 5 Massimo Burcheri 2012-09-04 08:08:19 UTC
Created attachment 322886 [details]
build.log of 'MAKEOPTS="V=1" emerge -auv sys-fs/aufs3'
Comment 6 Justin Lecher gentoo-dev 2012-09-04 08:14:14 UTC
It is not keyworded for ppc at all. so no support here, sorry.
Comment 7 Massimo Burcheri 2012-09-04 13:44:29 UTC
I guess it must be an ebuild failure since I got it building like this:

$ for action in fetch unpack compile; do ebuild /usr/portage/sys-fs/aufs3/aufs3-3_p20120813.ebuild $action; done
$ cd /var/tmp/portage/sys-fs/aufs3-3_p20120813/work/aufs3-standalone
$ make
$ ebuild /usr/portage/sys-fs/aufs3/aufs3-3_p20120813.ebuild qmerge
Comment 8 Justin Lecher gentoo-dev 2012-09-04 14:37:36 UTC
no, the buildsystem doesn't support ppc and thats why it is not keyworded atm.
Comment 9 Justin Lecher gentoo-dev 2012-09-04 14:38:03 UTC
Please see bug 432392
Comment 10 Massimo Burcheri 2012-09-13 14:22:30 UTC

*** This bug has been marked as a duplicate of bug 432392 ***