Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 433175 - dev-lang/python-2.7.3-r2: Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib64/python2.7/threading.pyc'> ignored (PATCH)
Summary: dev-lang/python-2.7.3-r2: Exception AttributeError: AttributeError("'_DummyTh...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL: http://hg.python.org/cpython/rev/ab9d...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-29 16:18 UTC by Leho Kraav (:macmaN @lkraav)
Modified: 2018-04-21 15:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leho Kraav (:macmaN @lkraav) 2012-08-29 16:18:09 UTC
This was recently discovered to be a problem [1] and was patched in all branches. I have no idea when 2.7.4 will be released, so I'd like to propose 2.7.3-r3 with this [2].

 [1]: http://bugs.python.org/issue14308
 [2]: http://hg.python.org/cpython/rev/ab9d6c4907e7

Reproducible: Always
Comment 1 Marien Zwart (RETIRED) gentoo-dev 2012-09-03 17:57:51 UTC
If I understand correctly this is an exception triggered during thread shutdown that makes it to logs. Is there harmful behaviour fixed by this other than log noise in some conditions?
Comment 2 Leho Kraav (:macmaN @lkraav) 2012-09-03 18:23:18 UTC
I don't think I'm really qualified to answer any better than the discussion on bpo bug report. On basic level, I'm not sure why the "normal" should be to start filtering this out in my logs.
Comment 3 Doug Goldstein gentoo-dev 2016-03-20 03:37:00 UTC
@python: This looks like it can be closed if it was fixed in Python 2.7.4?