Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 433173 - kde-base/kdebase-pam please enable systemd seat using system-local-login
Summary: kde-base/kdebase-pam please enable systemd seat using system-local-login
Status: RESOLVED DUPLICATE of bug 422495
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-29 14:23 UTC by Ulenrich
Modified: 2012-09-03 08:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulenrich 2012-08-29 14:23:08 UTC
systemd loginctl should show shomething like
   SESSION        UID USER             SEAT            
         1       1000 ral              seat0  

but the wrong /etc/pam.d/system-auth is included.
/etc/pam.d/system-login would enable systemd as it has 
-session        optional        pam_systemd.so

Using the local version /etc/pam.d/system-local-login there might be possible 
local specials included. It is essentialy the same as of now. 
The actual kdebase-pam files should look like:
/etc/pam.d/kde
---
#%PAM-1.0
auth       include      system-local-login

account    include      system-local-login

password   include      system-local-login

session    include      system-local-login
---

/etc/pam.d/kde-np
---
#%PAM-1.0

auth       required     pam_nologin.so
auth       required     pam_permit.so

account    include      system-local-login

password   include      system-local-login

session    include      system-local-login
---

Reproducible: Always




This bug: https://bugs.gentoo.org/show_bug.cgi?id=422495
claims kdm the package to be, but it is kdebase-pam.
Comment 1 Johannes Huber gentoo-dev 2012-09-03 08:35:10 UTC

*** This bug has been marked as a duplicate of bug 422495 ***