Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 432976 - net-libs/telepathy-logger-qt-0.5.0: fails to build with >=dev-libs/boost-1.50.0-r2
Summary: net-libs/telepathy-logger-qt-0.5.0: fails to build with >=dev-libs/boost-1.50...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard: tracking upstream
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-27 14:26 UTC by Alex Turbov
Modified: 2013-05-01 11:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch #1: fixes for qt-gstreamer (qt-gstreamer-0.10.2-fix-missed-boost-include-dir.patch,2.16 KB, patch)
2012-09-05 07:26 UTC, Alex Turbov
Details | Diff
patch #2: fixes for buggy qt-gstreamer detector in telepathy-logger-qt (telepathy-logger-qt-0.5.0-fix-buggy-qtglib-detector.patch,1.49 KB, patch)
2012-09-05 07:27 UTC, Alex Turbov
Details | Diff
patch #3: same as #2, but for net-im/ktp-text-ui (ktp-text-ui-0.4.1-fix-buggy-qtglib-detector.patch,1.46 KB, patch)
2012-09-05 07:27 UTC, Alex Turbov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Turbov 2012-08-27 14:26:34 UTC
telepathy-logger-qt doesn't use boost directly, but via qt-gstreamer which is use some header-only boost libraries.

Reproducible: Always
Comment 1 Michael Weber (RETIRED) gentoo-dev 2012-08-28 10:55:07 UTC
Please attach the build.log and your `emerge --info` output
Comment 2 Johannes Huber gentoo-dev 2012-09-04 13:46:14 UTC
(In reply to comment #1)
> Please attach the build.log and your `emerge --info` output

Ping! Please provide the requested infos.
Comment 3 Alex Turbov 2012-09-05 07:25:26 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Please attach the build.log and your `emerge --info` output
> 
> Ping! 
Pong!

> Please provide the requested infos.
forget it! I've done the job while you are waited...

so, first of all, as I told before, qt-gstreamer uses some boost header-obly libs, but does not provides an #include dir for them as a dependency in it's .pc files, so later telepathy-logger-qt, using cmake's pkg_check_modules (in cmake/modules/FindQtGLib.cmake), can't properly detect losted (implicit) dependency from boost. (so here is a patch #1 for it)

but this is a half of the problem. unfortunately FindQtGLib.cmake too stupid also, and after using pkg_check_modules, which would returns everything required for success compilation, it just ignore it's output and tried to redetect (in a stupid way) #include dir again (as well as libraries). so it is why here is the patch #2.

later, when I tried to compile kde-telepathy-meta, I've found another one package w/ the same problem: net-im/ktp-text-ui (see patch #3)
Comment 4 Alex Turbov 2012-09-05 07:26:22 UTC
Created attachment 322964 [details, diff]
patch #1: fixes for qt-gstreamer
Comment 5 Alex Turbov 2012-09-05 07:27:22 UTC
Created attachment 322966 [details, diff]
patch #2: fixes for buggy qt-gstreamer detector in telepathy-logger-qt
Comment 6 Alex Turbov 2012-09-05 07:27:59 UTC
Created attachment 322968 [details, diff]
patch #3: same as #2, but for net-im/ktp-text-ui
Comment 7 Johannes Huber gentoo-dev 2012-09-05 07:31:10 UTC
Thanks for your work, please file the patches upstream for review and link here back.
Comment 8 Alex Turbov 2012-09-05 07:35:02 UTC
(In reply to comment #7)
> Thanks for your work, please file the patches upstream for review and link
> here back.

sorry, maybe later (I suppose never)... cuz I spent too much time already...
Comment 9 Alex Turbov 2012-09-09 05:32:59 UTC
(In reply to comment #7)
> Thanks for your work, please file the patches upstream for review and link
> here back.

here is the bug report to qt-gstreamer upstream: 
https://bugzilla.gnome.org/show_bug.cgi?id=683455
Comment 10 Johannes Huber gentoo-dev 2012-09-09 09:53:53 UTC
(In reply to comment #9)
> here is the bug report to qt-gstreamer upstream: 
> https://bugzilla.gnome.org/show_bug.cgi?id=683455

thanks
Comment 11 Diego Elio Pettenò (RETIRED) gentoo-dev 2013-03-03 11:26:48 UTC
Hello all,

boost-1.52.0-r6 is likely going stable anytime soon, but this bug is even still open in ~arch. Please consider whether the package is dead and should just be removed.

Thanks,
Diego
Comment 12 Michael Palimaka (kensington) gentoo-dev 2013-04-08 12:32:29 UTC
What is the status here? It builds for me fine with boost-1.52.0-r6.
Comment 13 Tomáš Chvátal (RETIRED) gentoo-dev 2013-04-12 17:51:04 UTC
This thing works with boost 1.50 on version 0.6.0 for sure (tested right now).

Removing from the blocker because something else must be there to break it.
Comment 14 Johannes Huber gentoo-dev 2013-05-01 11:13:19 UTC
(In reply to comment #12)
> What is the status here? It builds for me fine with boost-1.52.0-r6.


(In reply to comment #13)
> This thing works with boost 1.50 on version 0.6.0 for sure (tested right
> now).
> 
> Removing from the blocker because something else must be there to break it.


Works for me too. No idea what it was. But seems fixed...