Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 432864 - x11-drivers/xf86-video-intel: add debug USE flag
Summary: x11-drivers/xf86-video-intel: add debug USE flag
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords: InOverlay, PATCH
: 497386 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-26 14:36 UTC by Reinis Danne
Modified: 2014-03-18 22:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for live ebuild (xf86-video-intel-9999.ebuild.patch,613 bytes, patch)
2012-08-26 14:38 UTC, Reinis Danne
Details | Diff
Updated patch (xf86-video-intel-9999.ebuild_debug.patch,584 bytes, patch)
2012-09-14 08:03 UTC, Reinis Danne
Details | Diff
Updated patch (xf86-video-intel-9999.ebuild_debug.patch,746 bytes, patch)
2012-09-14 15:51 UTC, Reinis Danne
Details | Diff
debug_ability.patch (0001-x11-drivers-xf86-video-intel-add-debug-ability.patch,1.11 KB, text/plain)
2013-08-07 15:08 UTC, David Heidelberg (okias)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reinis Danne 2012-08-26 14:36:54 UTC
Useful to get full debug output in Xorg log file for sending to upstream.

Reproducible: Always
Comment 1 Reinis Danne 2012-08-26 14:38:00 UTC
Created attachment 322268 [details, diff]
Patch for live ebuild
Comment 2 Reinis Danne 2012-09-14 08:03:41 UTC
Created attachment 323734 [details, diff]
Updated patch
Comment 3 Reinis Danne 2012-09-14 15:51:14 UTC
Created attachment 323778 [details, diff]
Updated patch

There are multiple debug levels for intel driver, this patch adds use flags for basic level and full debug.

There are also memory and pixmap debug levels, I can add them also if needed.
Comment 4 David Heidelberg (okias) 2013-08-07 15:08:39 UTC
Created attachment 355334 [details]
debug_ability.patch

Can you try this patch?
Comment 5 David Heidelberg (okias) 2014-01-12 16:01:24 UTC
it's still valid?
Comment 6 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-01-26 18:05:52 UTC
*** Bug 497386 has been marked as a duplicate of this bug. ***
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-01-26 18:11:21 UTC
A debug flag has been added to the live ebuild in the x11 overlay.

full-debug is a bit more complex, it needs to pass --enable-debug=full to configure.
Comment 8 Rémi Cardona gentoo-dev 2014-02-03 22:06:10 UTC
I just synced the overlay ebuild into portage. So we have a debug USE flag there too (for 2.99.909). Is this enough or should we aim for debug-full?
Comment 9 Mike Auty gentoo-dev 2014-02-03 22:07:56 UTC
I think that debug is good enough.  Enabling debug-full (I believe) would create huge Xorg.0.logs (as in several hundred megabytes), so to avoid people having this happen to them without realizing it, we should leave it at that.  Thanks very much for getting it all sorted so quickly!  5:)