Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 432378 - app-shells/bash-completion - hard-coded path "/sbin/modinfo" in /usr/share/bash-completion/module-init-tools
Summary: app-shells/bash-completion - hard-coded path "/sbin/modinfo" in /usr/share/ba...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Shell Tools Herd Bugs
URL: https://bugs.archlinux.org/task/28574
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-23 01:31 UTC by Charles G. Waldman
Modified: 2013-07-23 11:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles G. Waldman 2012-08-23 01:31:53 UTC
kmod package moved modinfo binary from /sbin to /usr/bin, but the module-init-tools bash completion script has /sbin/modinfo hard-coded.  

Reproducible: Always

Steps to Reproduce:
1. install kmod
2. eselect bashcomp enable --global module-init-tools
3. modprobe snd <TAB>
Actual Results:  
bash: /sbin/modinfo: No such file or directory


Expected Results:  
list of possible module parameters, for example, for snd module,
"cards_limit  debug major slots" 


why not trust $PATH?
Comment 1 Howard B. Golden 2012-11-03 18:30:08 UTC
The alsaconf script also references /sbin/modinfo directly. Therefore, it might be a good idea to set-up a symbolic link from /sbin/modinfo to /usr/bin/kmod instead of changing other references throughout other packages.
Comment 2 Samuli Suominen gentoo-dev 2013-07-23 11:21:41 UTC
(In reply to Howard B. Golden from comment #1)
> The alsaconf script also references /sbin/modinfo directly. Therefore, it
> might be a good idea to set-up a symbolic link from /sbin/modinfo to
> /usr/bin/kmod instead of changing other references throughout other packages.

alsaconf is no longer installed (it's incompatible with sys-apps/kmod because depmod from kmod doesn't generate modules.pcimap or .usbmap files)

and kmod installs to / and modinfo to both /bin and /sbin

futhermore I don't see the mentioned hardcoding in bash-completion-2.1-r1, or sys-apps/kmod-14-r1 anymore

I think it's safe to close this as FIXED now