Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 432206 - net-misc/arm with dev-lang/python:3.2 - SyntaxError: invalid syntax in print "TorCtl successfully installed" ( File "/usr/share/arm/prereq.py", line 65 )
Summary: net-misc/arm with dev-lang/python:3.2 - SyntaxError: invalid syntax in print ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
: 525900 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-21 14:57 UTC by Giczi Levente
Modified: 2014-10-19 20:41 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
arm-1.4.5.0_p20140714.ebuild (arm-1.4.5.0_p20140714.ebuild,1.54 KB, text/plain)
2014-07-22 22:52 UTC, Manuel Rüger (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giczi Levente 2012-08-21 14:57:43 UTC
I have installed net-misc/arm-1.4.5.0 and i have python 3.2 ad default one tried run arm with this result:

  File "/usr/share/arm/prereq.py", line 65
    print "TorCtl successfully installed"
                                        ^
SyntaxError: invalid syntax

If I change in /usr/bin/arm script "python" to "python2" then working.

Reproducible: Always

Steps to Reproduce:
1.Just change python version.
2.
3.
Actual Results:  
see in description

Expected Results:  
working
Comment 1 Norman Rieß 2013-01-15 13:00:59 UTC
Confirmed.
Comment 2 Manuel Rüger (RETIRED) gentoo-dev 2014-07-22 22:52:27 UTC
Created attachment 381400 [details]
arm-1.4.5.0_p20140714.ebuild

WIP ebuild to migrate to distutils-r1. Tests currently fail.
Comment 3 Manuel Rüger (RETIRED) gentoo-dev 2014-07-23 00:16:27 UTC
Needs a more recent snapshot of stem, and it works. :)

*arm-1.4.5.0_p20140714 (23 Jul 2014)

  23 Jul 2014; Manuel Rüger <mrueg@gentoo.org> +arm-1.4.5.0_p20140714.ebuild:
  Add new snapshot. Depends on net-libs/stem now. Migrate to distutils-r1. Fixes
  bug #432206.
Comment 4 Jeroen Roovers gentoo-dev 2014-10-19 20:41:13 UTC
*** Bug 525900 has been marked as a duplicate of this bug. ***
Comment 5 Jeroen Roovers gentoo-dev 2014-10-19 20:41:51 UTC
Maybe something newer should be stabilised.