Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 431358 - dev-util/lttng-modules - lttng kernel modules
Summary: dev-util/lttng-modules - lttng kernel modules
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Yixun Lan
URL: http://lttng.org
Whiteboard: [sunrise-overlay]
Keywords:
Depends on:
Blocks: 431354
  Show dependency tree
 
Reported: 2012-08-14 09:34 UTC by Yixun Lan
Modified: 2014-03-04 07:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
bump to 2.1.1, also take advantage of linux-mod eclass to address this problem (lttng-modules-2.1.1.ebuild,1.35 KB, text/plain)
2013-03-20 02:58 UTC, Yixun Lan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yixun Lan gentoo-dev 2012-08-14 09:34:26 UTC
new ebuild will goes into sunrise

Reproducible: Always
Comment 1 Patrick Lauer gentoo-dev 2013-03-18 02:14:12 UTC
>>> Emerging (1 of 1) dev-util/lttng-modules-2.0.4 from sunrise
 * lttng-modules-2.0.4.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                   [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     3.8.2-gentoo
 * Checking for suitable kernel configuration options...                                                                                                                                                                              [ ok ]
>>> Unpacking source...
>>> Unpacking lttng-modules-2.0.4.tar.bz2 to /var/tmp/portage/dev-util/lttng-modules-2.0.4/work
>>> Source unpacked in /var/tmp/portage/dev-util/lttng-modules-2.0.4/work
>>> Preparing source in /var/tmp/portage/dev-util/lttng-modules-2.0.4/work/lttng-modules-2.0.4 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-util/lttng-modules-2.0.4/work/lttng-modules-2.0.4 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-util/lttng-modules-2.0.4/work/lttng-modules-2.0.4 ...
make -j4 default 
make -C /lib/modules/3.7.9-vs2.3.5.6/build M=/var/tmp/portage/dev-util/lttng-modules-2.0.4/work/lttng-modules-2.0.4 modules
make: *** /lib/modules/3.7.9-vs2.3.5.6/build: No such file or directory.  Stop.
make: *** [default] Error 2
 * ERROR: dev-util/lttng-modules-2.0.4 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=dev-util/lttng-modules-2.0.4'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/lttng-modules-2.0.4'`.
 * This ebuild is from an overlay named 'sunrise': '/sunrise/'
 * The complete build log is located at '/var/tmp/portage/dev-util/lttng-modules-2.0.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/lttng-modules-2.0.4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/lttng-modules-2.0.4/work/lttng-modules-2.0.4'
 * S: '/var/tmp/portage/dev-util/lttng-modules-2.0.4/work/lttng-modules-2.0.4'

>>> Failed to emerge dev-util/lttng-modules-2.0.4, Log file:

>>>  '/var/tmp/portage/dev-util/lttng-modules-2.0.4/temp/build.log'

 * Messages for package dev-util/lttng-modules-2.0.4:

 * ERROR: dev-util/lttng-modules-2.0.4 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=dev-util/lttng-modules-2.0.4'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/lttng-modules-2.0.4'`.
 * This ebuild is from an overlay named 'sunrise': '/sunrise/'
 * The complete build log is located at '/var/tmp/portage/dev-util/lttng-modules-2.0.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/lttng-modules-2.0.4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/lttng-modules-2.0.4/work/lttng-modules-2.0.4'
 * S: '/var/tmp/portage/dev-util/lttng-modules-2.0.4/work/lttng-modules-2.0.4'
localhost sunrise # eselect kernel list
Available kernel symlink targets:
  [1]   linux-3.8.2-gentoo *


Err. Please make it care about the selected kernel instead of the running kernel ... please? :)
Comment 2 Yixun Lan gentoo-dev 2013-03-20 02:58:09 UTC
Created attachment 342686 [details]
bump to 2.1.1, also take advantage of linux-mod eclass to address this problem
Comment 3 Yixun Lan gentoo-dev 2013-04-07 01:18:11 UTC
already in sunrise overlay
Comment 4 Michael Palimaka (kensington) gentoo-dev 2013-04-07 15:21:56 UTC
Reopening since we would usually only mark as "fixed" once the package is in portage.
Comment 5 Yixun Lan gentoo-dev 2014-03-04 07:02:24 UTC
2.4.0 in portage tree