Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 431304 - cross-i686-pc-linux-gnu/glibc-2.15-r2 - ld: cannot find -lgcc_eh
Summary: cross-i686-pc-linux-gnu/glibc-2.15-r2 - ld: cannot find -lgcc_eh
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
: 432602 (view as bug list)
Depends on:
Reported: 2012-08-14 02:06 UTC by David Flogeras
Modified: 2013-01-04 21:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

overall crossdev log (cross-i686-pc-linux-gnu-info.log,13.48 KB, text/plain)
2012-08-14 02:07 UTC, David Flogeras
glibc config log (glibc-config.logs.tar.xz,10.04 KB, application/x-xz)
2012-08-14 02:08 UTC, David Flogeras
complete glibc log (cross-i686-pc-linux-gnu-glibc.log.xz,116.85 KB, application/x-xz)
2012-08-14 02:08 UTC, David Flogeras

Note You need to log in before you can comment on or make changes to this bug.
Description David Flogeras 2012-08-14 02:06:48 UTC
Since the stabling of glibc-2.15-r2, I cannot build a toolchain. As alluded to in #431044, it fails when building glibc with a stage1 gcc (complains about missing libgcc_eh).

I've tried with both i686-pc-linux-gnu and armv6j-hardfloat-linux-gnueabi (both using stable, ie crossdev -S). This is from a fresh environment (ie cleaned old crossdev chains with crossdev -C first).

Attaching to relevant logs as requested.

Reproducible: Always
Comment 1 David Flogeras 2012-08-14 02:07:29 UTC
Created attachment 321254 [details]
overall crossdev log
Comment 2 David Flogeras 2012-08-14 02:08:07 UTC
Created attachment 321256 [details]
glibc config log
Comment 3 David Flogeras 2012-08-14 02:08:33 UTC
Created attachment 321258 [details]
complete glibc log
Comment 4 David Flogeras 2012-08-14 02:15:45 UTC
On closer inspection, the armv6j toolchain was trying to use the current stable glibc for that arch, which is still 2.14. May not have anything to do with 2.15 as my summary suggested.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2012-08-14 13:04:20 UTC
Comment on attachment 321256 [details]
glibc config log

Why a single file in a tar archive?
Comment 6 David Flogeras 2012-08-14 14:08:18 UTC
When crossdev fails, it says to include those three files, I just followed its instructions verbatim. I can uncompress next time...
Comment 7 SpanKY gentoo-dev 2012-08-14 16:05:21 UTC
(In reply to comment #6)

you did the right thing
Comment 8 SpanKY gentoo-dev 2012-08-14 16:06:17 UTC
should be all set now in the tree; thanks for the report!

Commit message: Fix inverted version logic with libgcc_eh
Comment 9 David Flogeras 2012-08-14 17:32:01 UTC
Cheers, works for me on both affected cross chains :)
Comment 10 SpanKY gentoo-dev 2012-08-24 17:30:58 UTC
*** Bug 432602 has been marked as a duplicate of this bug. ***
Comment 11 mike 2013-01-04 21:15:36 UTC
Same error here but different reason: the CFLAG "-march=native" set in make.conf wasn't recognized. Removing this option resolved the problem.