Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 431036 - dev-lisp/sbcl fails tests: SB-POSIX-TESTS::READDIR.1,
Summary: dev-lisp/sbcl fails tests: SB-POSIX-TESTS::READDIR.1,
Status: RESOLVED DUPLICATE of bug 427616
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Panagiotis Christopoulos (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-12 06:10 UTC by neko259
Modified: 2014-04-27 15:12 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
log.tar.bz2 (log.tar.bz2,290.42 KB, application/x-bzip-compressed-tar)
2012-08-12 06:12 UTC, neko259
Details
emerge --info (info.txt,17.34 KB, text/plain)
2012-08-12 06:12 UTC, neko259
Details

Note You need to log in before you can comment on or make changes to this bug.
Description neko259 2012-08-12 06:10:57 UTC
When trying to compile sbcl of any version (tried since 1.0.19 to 1.0.55-r1) fails on sb-posix tests for unknown reason.

Reproducible: Always

Steps to Reproduce:
1. emerge sbcl
Actual Results:  
Failing on sb-posix tests.

Expected Results:  
Compiling and installing.
Comment 1 neko259 2012-08-12 06:12:18 UTC
Created attachment 321064 [details]
log.tar.bz2
Comment 2 neko259 2012-08-12 06:12:34 UTC
Created attachment 321066 [details]
emerge --info
Comment 3 Samuli Suominen gentoo-dev 2012-08-12 07:32:48 UTC
Please don't change the "Importance: " field. This bug is certainly not 'critical'.

How is sbcl-1.0.57 from bug 422505 (if you are capable of testing) ?
Comment 4 Samuli Suominen gentoo-dev 2012-08-12 07:34:54 UTC
CCing neurogeek@ too despite not being in metadata.xml since he did the last bump to 1.0.55-r1.
Comment 5 neko259 2012-08-12 07:42:55 UTC
(In reply to comment #3)
> Please don't change the "Importance: " field. This bug is certainly not
> 'critical'.
> 
> How is sbcl-1.0.57 from bug 422505 (if you are capable of testing) ?

I don't see any ebuild in that bug.
Comment 6 RCV 2012-08-30 18:50:48 UTC
I confirm this bug. I can't build sbcl with LANG="ru_RU.UTF-8". I can build sbcl  with LC_ALL="C", but anyway it doesn't work in  my system with LANG="ru_RU.UTF-8".
Comment 7 Jeroen Roovers gentoo-dev 2014-04-27 15:12:58 UTC

*** This bug has been marked as a duplicate of bug 427616 ***