Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430968 - dev-libs/grantlee-0.2.0 fails to build on arm hardfp
Summary: dev-libs/grantlee-0.2.0 fails to build on arm hardfp
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: ARM Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-11 17:55 UTC by Meik Frischke
Modified: 2013-03-09 11:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (dev-libs:grantlee-0.2.0:20120811-155738.log,158.33 KB, text/plain)
2012-08-11 17:55 UTC, Meik Frischke
Details
libgrantlee_core.so.0.2.0 compiled without -Wl,--fatal-warnings (libgrantlee_core.so.0.2.0.xz,118.36 KB, application/octet-stream)
2012-08-24 23:27 UTC, Meik Frischke
Details
g++ -Wl,-M output (g++-out.txt.xz,32.93 KB, application/octet-stream)
2012-08-24 23:31 UTC, Meik Frischke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Meik Frischke 2012-08-11 17:55:03 UTC
Portage 2.1.10.65 (default/linux/arm/10.0/armv7a, gcc-4.5.3, glibc-2.14.1-r3, 3.2.24 armv7l)
=================================================================
System uname: Linux-3.2.24-armv7l-ARMv7_Processor_rev_2_-v7l-with-gentoo-2.1
Timestamp of tree: Mon, 06 Aug 2012 07:45:01 +0000
distcc 3.1 armv7a-hardfloat-linux-gnueabi [enabled]
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
ACCEPT_KEYWORDS="arm"
ACCEPT_LICENSE="* -@EULA"
CBUILD="armv7a-hardfloat-linux-gnueabi"
CFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
CHOST="armv7a-hardfloat-linux-gnueabi"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
DISTDIR="/mnt/net/Gentoo/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FCFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp"
FEATURES="assume-digests binpkg-logs buildpkg candy config-protect-if-modified distcc distlocks ebuild-locks fail-clean fixlafiles news parallel-fetch parallel-install parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://mirror.jamit.de/gentoo/"
LANG="de_DE.UTF-8"
LC_ALL="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/mnt/net/Gentoo/packages/embedded/pandaboard"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="-v --progress"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/ramdisk"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="acl arm berkdb bzip2 cli cracklib crypt cups cxx fortran gdbm gpm iconv ipv6 kdehiddenvisibility modules mudflap ncurses neon nls nptl nptlonly openmp pam pcre perl pppd python readline session ssl tcpd unicode xinerama zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="adc65 agfa_cl20 aox barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 jl2005a kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 stv0674 stv0680 sx330z template topfield toshiba_pdrm11" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="g15" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="exynos fbdev omap omapfb dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, USE_PYTHON

Reproducible: Always
Comment 1 Meik Frischke 2012-08-11 17:55:55 UTC
Created attachment 321034 [details]
build log
Comment 2 Andreas K. Hüttel gentoo-dev 2012-08-11 22:07:03 UTC
/usr/lib/gcc/armv7a-hardfloat-linux-gnueabi/4.5.3/../../../../armv7a-hardfloat-linux-gnueabi/bin/ld: warning: creating a DT_TEXTREL in a shared object.

No idea where that is coming from. Maybe some arm people know...
Comment 3 SpanKY gentoo-dev 2012-08-23 21:31:20 UTC
well, the build shouldn't be using -Wl,--fatal-warnings in the first place.  that's almost as bad as -Werror.  if that weren't there, scanelf would have kicked in and done some debugging and provided logs that we could look at.

Meik: please run:
  scanelf -qyRAF '%T %p' /tmp/portage/dev-libs/grantlee-0.2.0/work/grantlee-0.2.0_build >& log

and then post that log file as an attachment
Comment 4 Andreas K. Hüttel gentoo-dev 2012-08-24 08:06:32 UTC
(In reply to comment #3)
> well, the build shouldn't be using -Wl,--fatal-warnings in the first place. 
> that's almost as bad as -Werror.  if that weren't there, scanelf would have
> kicked in and done some debugging and provided logs that we could look at.

That was afaik a team decision at some point, it's hardwired into all kde ebuilds. Since I dont know what the reason for it was, this is a good agenda topic for the next monthly meeting...
Comment 5 SpanKY gentoo-dev 2012-08-24 17:20:55 UTC
(In reply to comment #4)

textrels, while generally something we should investigate & fix, are not something we should be blocking the install of packages for
Comment 6 Meik Frischke 2012-08-24 20:49:30 UTC
(In reply to comment #3)
> Meik: please run:
>   scanelf -qyRAF '%T %p'
> /tmp/portage/dev-libs/grantlee-0.2.0/work/grantlee-0.2.0_build >& log
> 

running scanelf in that directory gives no output in quiet mode
Comment 7 SpanKY gentoo-dev 2012-08-24 21:59:02 UTC
(In reply to comment #6)

right, because --fatal-warnings was used, the output was deleted

if you look at the build log, you'll want to run that last command by hand (minus the -Wl,--fatal-warnings flag), and then run scanelf
Comment 8 Meik Frischke 2012-08-24 23:27:28 UTC
Created attachment 322138 [details]
libgrantlee_core.so.0.2.0 compiled without -Wl,--fatal-warnings
Comment 9 Meik Frischke 2012-08-24 23:31:13 UTC
Created attachment 322140 [details]
g++ -Wl,-M output
Comment 10 Andreas K. Hüttel gentoo-dev 2013-03-09 11:30:49 UTC
fixed in grantlee-0.3.0 (linker warnings are now nonfatal)