Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430966 - net-p2p/amule fails to build with GCC 4.7
Summary: net-p2p/amule fails to build with GCC 4.7
Status: RESOLVED DUPLICATE of bug 403197
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo net-p2p team
Depends on:
Blocks: gcc-4.7
  Show dependency tree
Reported: 2012-08-11 17:53 UTC by jospezial
Modified: 2013-02-19 19:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,23.92 KB, text/plain)
2012-08-13 21:23 UTC, jospezial

Note You need to log in before you can comment on or make changes to this bug.
Description jospezial 2012-08-11 17:53:30 UTC
net-p2p/amule fails to build with gcc-4.7.1

Compiling ThreadScheduler.cpp
In file included from /usr/include/cryptopp/iterhash.h:5:0,
                 from /usr/include/cryptopp/md4.h:4,
                 from CryptoPP_Inc.h:51,
                 from RandomFunctions.cpp:29:
/usr/include/cryptopp/secblock.h: In Instanziierung von »CryptoPP::AllocatorWithCleanup<T, T_Align16>::pointer CryptoPP::AllocatorWithCleanup<T, T_Align16>::allocate(CryptoPP::AllocatorWithCleanup<T, T_Align
16>::size_type, const void*) [with T = long long unsigned int; bool T_Align16 = false; CryptoPP::AllocatorWithCleanup<T, T_Align16>::pointer = long long unsigned int*; CryptoPP::AllocatorWithCleanup<T, T_Ali
gn16>::size_type = long unsigned int]«:
/usr/include/cryptopp/secblock.h:249:23:   erfordert durch »CryptoPP::SecBlock<T, A>::SecBlock(const CryptoPP::SecBlock<T, A>&) [with T = long long unsigned int; A = CryptoPP::AllocatorWithCleanup<long long 
unsigned int>]«
/usr/include/cryptopp/modarith.h:122:7:   von hier erfordert
/usr/include/cryptopp/secblock.h:91:3: Fehler: »CheckSize« wurde in diesem Gültigkeitsbereich nicht deklariert, und bei argumentabhängiger Suche am Ort der Instanziierung wurden keine Deklarationen gefunden 
/usr/include/cryptopp/secblock.h:91:3: Anmerkung: Deklarationen in abhängiger Basis »CryptoPP::AllocatorBase<long long unsigned int>« wurden bei unqualifizierter Suche nicht gefunden
/usr/include/cryptopp/secblock.h:91:3: Anmerkung: stattdessen »this->CheckSize« verwenden
/usr/include/cryptopp/secblock.h: In Instanziierung von »CryptoPP::AllocatorWithCleanup<T, T_Align16>::pointer CryptoPP::AllocatorWithCleanup<T, T_Align16>::allocate(CryptoPP::AllocatorWithCleanup<T, T_Align16>::size_type, const void*) [with T = unsigned char; bool T_Align16 = false; CryptoPP::AllocatorWithCleanup<T, T_Align16>::pointer = unsigned char*; CryptoPP::AllocatorWithCleanup<T, T_Align16>::size_type = long unsigned int]«:
/usr/include/cryptopp/secblock.h:247:19:   erfordert durch »CryptoPP::SecBlock<T, A>::SecBlock(CryptoPP::SecBlock<T, A>::size_type) [with T = unsigned char; A = CryptoPP::AllocatorWithCleanup<unsigned char>; CryptoPP::SecBlock<T, A>::size_type = long unsigned int]«
/usr/include/cryptopp/algparam.h:17:2:   von hier erfordert
/usr/include/cryptopp/secblock.h:91:3: Fehler: »CheckSize« wurde in diesem Gültigkeitsbereich nicht deklariert, und bei argumentabhängiger Suche am Ort der Instanziierung wurden keine Deklarationen gefunden [-fpermissive]
/usr/include/cryptopp/secblock.h:91:3: Anmerkung: Deklarationen in abhängiger Basis »CryptoPP::AllocatorBase<unsigned char>« wurden bei unqualifizierter Suche nicht gefunden
/usr/include/cryptopp/secblock.h:91:3: Anmerkung: stattdessen »this->CheckSize« verwenden
make[3]: *** [libmuleappcore_a-RandomFunctions.o] Fehler 1

joerg@jlgentoo ~ $ equery b secblock.h
 * Searching for secblock.h ... 
dev-libs/crypto++-5.6.1-r3 (/usr/include/crypto++/secblock.h)

I found there some info:

" Changed 6 months ago by zooko

We fixed this in the embedded copy of Crypto++ which is included in pycryptopp, with this patch: "

Don't know where to use this because dev-python/pycryptopp is not installed on my system.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-08-12 15:16:34 UTC
1) Please post your `emerge --info' output in a comment.
2) Please attach the entire build log to this bug report.
Comment 2 jospezial 2012-08-13 21:23:37 UTC
Created attachment 321246 [details]
Comment 3 jospezial 2012-08-13 21:25:21 UTC
jlgentoo ~ # emerge --info
Portage 2.2.0_alpha121 (default/linux/amd64/10.0, gcc-4.7.1, glibc-2.15-r2, 3.6.0-rc1 x86_64)
System uname: Linux-3.6.0-rc1-x86_64-AMD_Athlon-tm-_64_Processor_3700+-with-gentoo-2.1
Timestamp of tree: Mon, 13 Aug 2012 19:15:01 +0000
ccache version 3.1.8 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.5, 1.12.2
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo overlay_jl
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
EMERGE_DEFAULT_OPTS="--autounmask-write=y --keep-going --quiet-build=y"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-march=native -O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext 64bit X Xaw3d a52 aac aacplus aacs aalib ace acl acpi activefilter aften alsa amd64 apm apng archive async audacious audiofile automount bash-completion bazaar berkdb binary-drivers binfilter blender-game bluray boost bzip2 bzr cairo ccache cdda cddb cdio cdparanoia cdr cdrdao cdrom cgi charconv chroot cjk cleartype cli colordiff colors compress consolekit corefonts cpio cracklib crypt css cue cups curl curlwrappers cvs cxx daemon dbus declarative device-mapper dga dhcp dri dts dv dvb dvd dvdnav eap eap-sim eap-tls emerald emoticon enca encode enscript equalizer exif extensions extras faac faad fat fax fbcon ffmpeg fftw firefox flac floppy fluidsynth fontconfig foomaticdb fortran ftp fts3 fuse g3dvl gallium gd gdbm gdu geoip gif gimp git glut gme gnutls gphoto2 gpm gsm gstreamer gtk gtk3 gudev gui gzip hddtemp hdf hdf5 highlight hwdb iconv icq icu id3 id3tag idn imagemagick introspection ios ipc ipod ipv6 java javascript jit jpeg jpeg2k kate kde keymap ladspa lame laptop lcms lensfun lha libass libcaca libcanberra libkms libnl libnotify libsamplerate libssh2 libtiger libv4l libv4l2 libwww lm_sensors logrotate lua lxde lzma lzo mad madwifi magic matroska md5sum metalink midi mikmod mime minizip mixer mjpeg mmap mms mmx mmxext mng mod modplug modules mouse mozilla mp3 mp4 mpeg mplayer mudflap multilib multislot musepack musicbrainz nano-syntax ncat ncurses ndiff network networkmanager nfs nfsidmap nfsv3 nfsv4 nfsv41 nls nmap nmap-update nokia normalize nowlistening nping nptl nsplugin nss ntfs ntfsprogs ntp nvidia nvram obex ocr ogg ogm openal opencl opengl openmp optimized-qmake oscar osdmenu otr pam pango panorama parport parse-clocks pcap pci pcre pdf pdfimport phonon pipes plasma pm-utils pmu png policykit portaudio postscript ppds pppd privacy projectm projectx pulseaudio pvr qalculate qt3support qt4 quicktime radio rar raw rdesktop readline recording redeyes reiser4 reiserfs remote-access remoteosd replaygain rpm rtc rtmp rtsp rubberband samba sbsms scanner schroedinger sdl secure-delete semantic-desktop sensord session sftp sha512 shorten shout skins slang smbclient smi sndfile sockets sound soundtouch speex spell sql sqlite sqlite3 sse sse2 sse3 ssh ssl startup-notification statistics stk stream subtitles subversion svg swat symlink syslog taglib tcpd texteffect tftp theora threads thumbnail tiff translator truetype twolame udev udisks unicode urlpicpreview usb v4l vamp vboxwebsrv vcd vcdx vdpau video videos vim-syntax virtualbox vlm vnc vorbis vroot vst wad wav wavpack webgl webkit webm webpresence wifi winpopup wireshark wmf wps wxwidgets x264 xattr xcb xcomposite xine xinerama xinetd xml xorg xosd xpm xrandr xscreensaver xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev nv nvidia nouveau vesa svga vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 4 jospezial 2012-10-02 06:22:23 UTC
With gcc-4.7.2 the bug is still present.
Comment 5 jospezial 2012-10-06 18:29:38 UTC
Tried the latest tarball from june at
and got the same result.

With gcc-4.6.3 there are no problems.

Perhaps somebody could report it upstream if the there is the need to?
I couldn't find a public bugtracker for amule.

Can someone confirm this bug?
Comment 6 Morse 2012-10-10 18:04:42 UTC
It's crypto++ which fails, not amule.

use crypto++-5.6.1-r3, it has gcc-4.7 patch
Comment 7 Ryan Hill (RETIRED) gentoo-dev 2013-02-19 19:24:53 UTC

*** This bug has been marked as a duplicate of bug 403197 ***