Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430854 - media-sound/pulseaudio-2.1: won't store volume level on gnome 3.
Summary: media-sound/pulseaudio-2.1: won't store volume level on gnome 3.
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal minor (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-11 00:06 UTC by Alexandre
Modified: 2013-12-23 16:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre 2012-08-11 00:06:53 UTC
Using media-sound/pulseaudio-2.1 with gnome 3, pulseaudio won't store the volume level after restart or logoff, but not every time. Sometimes it's keep others not.

Reproducible: Sometimes




Portage 2.1.11.9 (default/linux/amd64/10.0/desktop/gnome, gcc-4.6.3, glibc-2.15-r2, 3.5.0-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.5.0-gentoo-x86_64-Intel-R-_Pentium-R-_Dual_CPU_T3400_@_2.16GHz-with-gentoo-2.1
Timestamp of tree: Fri, 10 Aug 2012 22:45:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.2
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo sunrise
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy ccache config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" ftp://gentoo.c3sl.ufpr.br/gentoo/ http://gentoo.c3sl.ufpr.br/ ftp://ftp.las.ic.unicamp.br/pub/gentoo/ http://www.las.ic.unicamp.br/pub/gentoo/ http://gentoo.lcc.ufmg.br/ #ftp://mirrors.localhost.net.ar/pub/mirrors/gentoo #http://gentoo.localhost.net.ar/ #ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ #http://distro.ibiblio.org/pub/linux/distributions/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j3 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage/"
USE="7Zip X a52 aac acl acpi alsa amd64 audiofile bash-completion berkdb branding bzip2 cairo caps cdda cddb cdparanoia cdr cli colord consolekit cracklib crypt css cups custom-cflags cxx dbus dga dri dts dvd dvdr eds encode evo exif fam ffmpeg firefox flac foomaticdb ftp gdbm gif gnome gnome-keyring gnome-online-accounts gnutls gpm gstreamer gtk gtk3 iconv imagemagick imap jabber java jpeg lame latex lcms libcanberra libnotify llvm lm_sensors lzma lzo mad matroska minimal mmx mng modules mp3 mp4 mpd mpeg mudflap multilib musepack musicbrainz nautilus ncurses networkmanager nls nptl nsplugin nvidia offensive ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio quicktime readline samba schroedinger sdl session socialweb spell sse sse2 sse3 ssl ssse3 startup-notification svg syslog tcpd theora threads tiff truetype udev udisks unicode upower usb v4l vdpau vim-syntax vorbis wavpack wifi x264 xcb xml xv xvid zlib" ALSA_CARDS="hda-intel loopback" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-sound/pulseaudio-2.1 was built with the following:
USE="X alsa asyncns caps dbus gdbm glib gnome gtk (multilib) orc ssl tcpd udev webrtc-aec -avahi -bluetooth -doc -equalizer -ipv6 -jack -libsamplerate -lirc (-oss) -realtime (-system-wide) -systemd -test -xen"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--no-as-needed"
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-08-11 01:22:28 UTC
I believe that pulseaudio itself is responsible for saving its sound levels in config files under ~/.pulse/

Reassigning the bug to pulseaudio maintainers.
Comment 2 Alexandre 2012-08-11 02:51:51 UTC
Just updating: the volume level is also not stored on gdm, but if I change the level on gdm when I login that level is keeped for my user.
Comment 3 Alexandre 2012-08-26 20:26:51 UTC
Seems solved with media-sound/pulseaudio-2.1-r1. :)
Comment 4 Samuli Suominen gentoo-dev 2012-08-27 07:16:53 UTC
(In reply to comment #3)
> Seems solved with media-sound/pulseaudio-2.1-r1. :)

all -r1 does is moves udev rules where they belong while udev has patches to work on both locations, so -r1 changes absolutely nothing

since the statement of -r1 solving everything came from the reporter, we'll have to assume the problem was local to begin with since the problem disappeared due to no reason at all
Comment 5 Alexandre 2012-08-27 21:33:07 UTC
No, not solved!
I was mistaken. It worked for a day and now the issue is back. :/

Sorry for the wrong 'solved' report.
Comment 6 Pacho Ramos gentoo-dev 2013-07-27 10:56:45 UTC
I cannot reproduce with gnome 3.8 and pulseaudio 4
Comment 7 Pacho Ramos gentoo-dev 2013-12-23 16:16:13 UTC
(In reply to Pacho Ramos from comment #6)
> I cannot reproduce with gnome 3.8 and pulseaudio 4