Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 430706 - dev-util/mutrace-0.2: fails to build with recent binutils
Summary: dev-util/mutrace-0.2: fails to build with recent binutils
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: https://tinderboxlogs.s3.amazonaws.co...
Whiteboard:
Keywords: NeedPatch
: 462240 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-10 01:54 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2015-03-29 12:46 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log - JM (build.log,14.09 KB, text/plain)
2013-03-03 22:56 UTC, Jason Mours
Details
mutrace-0.2-binutils2.diff (mutrace-0.2-binutils2.diff,285 bytes, patch)
2013-10-20 17:05 UTC, Jaak Ristioja
Details | Diff
mutrace-0.2-r1.ebuild (mutrace-0.2-r1.ebuild,633 bytes, text/plain)
2013-10-20 17:06 UTC, Jaak Ristioja
Details
mutrace-0.2-r1.ebuild (mutrace-0.2-r1.ebuild,608 bytes, text/plain)
2013-10-20 17:11 UTC, Jaak Ristioja
Details
Newer build log with extended info (mutrace-0.2-build.log,13.70 KB, text/plain)
2015-01-18 05:20 UTC, Jason Mours
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2012-08-10 01:54:54 UTC
Portage 2.2.0_alpha120 (default/linux/amd64/10.0, gcc-4.7.1-asneeded, glibc-2.16.0, 3.4.4-hardened-r1 x86_64)
=================================================================
System uname: Linux-3.4.4-hardened-r1-x86_64-AMD_Opteron-TM-_Processor_6272-with-gentoo-2.1
Timestamp of tree: Mon, 23 Jul 2012 14:30:01 +0000
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.6.8, 2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.4_p6-r1, 1.9.6-r3, 1.10.3, 1.11.6, 1.12.2
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3, 4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo tbamd64
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -ggdb -march=native -ftracer -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/entropy /opt/openjms/config /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /usr/share/qpsmtpd/plugins /usr/share/themes/oxygen-gtk/gtk-2.0 /var/bind /var/lib/hsqldb /var/lib/redmine/config /var/spool/torque"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /var/lib/redmine/config/locales /var/lib/redmine/config/settings.yml"
CXXFLAGS="-O2 -pipe -ggdb -march=native -ftracer -frecord-gcc-switches"
DISTDIR="/var/cache/portage/distfiles"
FCFLAGS="-O2 -pipe -ggdb -march=native -frecord-gcc-switches"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict test test-fail-continue unknown-features-warn unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe -ggdb -march=native -frecord-gcc-switches"
GENTOO_MIRRORS="http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://gentoo.mirrors.hoobly.com/ http://gentoo.llarian.net/"
LANG="en_US.utf8"
LC_ALL="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j24"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/var/cache/tinderbox/tree"
PORTDIR_OVERLAY="/root/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowex acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri emacs ffmpeg fortran gdbm gnutls gphoto gphoto2 gpm iconv ipv6 mmx modules mudflap multilib ncurses nls nptl openmp pam pax_kernel pcre pdf plasma pppd qt3support readline semantic-desktop session sse sse2 sse3 sse4 ssl ssse3 tcmalloc tcpd udev unicode vhosts xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19 ree18" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jason Mours 2013-03-03 22:55:37 UTC
Compile issue with following output: 

CC     libmutrace_backtrace_symbols_la-backtrace-symbols.lo
chmod +x matrace
chmod +x mutrace
In file included from backtrace-symbols.c:52:0:
/usr/include/bfd.h:37:2: error: #error config.h must be included before this header
matrace.c: In function 'setup':
matrace.c:177:9: warning: '__malloc_hook' is deprecated (declared at /usr/include/malloc.h:175) [-Wdeprecated-declarations]
mutrace.c: In function 'setup':
mutrace.c:270:9: warning: '__malloc_hook' is deprecated (declared at /usr/include/malloc.h:175) [-Wdeprecated-declarations]
make[1]: *** [libmutrace_backtrace_symbols_la-backtrace-symbols.lo] Error 1

Ref. sys-kernel/ksymoops-2.4.11-r1 Bug 428728 : Having similar compile issue

&

While not having problem with binutils ref : http://sourceware.org/bugzilla/show_bug.cgi?id=14243... A NOTGONNAFIX, but I'm not sure I understand it correctly.

Attaching my build.log
Comment 2 Jason Mours 2013-03-03 22:56:43 UTC
Created attachment 340892 [details]
build.log - JM
Comment 3 Pacho Ramos gentoo-dev 2013-10-13 14:20:41 UTC
*** Bug 462240 has been marked as a duplicate of this bug. ***
Comment 4 Pacho Ramos gentoo-dev 2013-10-13 14:26:33 UTC
I cannot make it build :@

Will need to treeclean if no fix is provided
Comment 5 Jaak Ristioja 2013-10-20 17:05:46 UTC
Created attachment 361450 [details, diff]
mutrace-0.2-binutils2.diff

A simple
  #include "config.h"
before
  #include <bfd.h>
in backtrace-symbols.c was needed to fix the build.
Comment 6 Jaak Ristioja 2013-10-20 17:06:44 UTC
Created attachment 361452 [details]
mutrace-0.2-r1.ebuild

Revbumped ebuild using the proposed patch.
Comment 7 Jaak Ristioja 2013-10-20 17:11:15 UTC
Created attachment 361454 [details]
mutrace-0.2-r1.ebuild

Whoops! Since we're using EAPI >= 2 patching should be done in src_prepare(), not in src_unpack(). Fixed.
Comment 8 Toralf Förster gentoo-dev 2015-01-17 10:14:44 UTC
and I do get :

  CCLD   libmatrace.la
  CC     libmutrace_backtrace_symbols_la-backtrace-symbols.lo
<command-line>:0:0: warning: "_FORTIFY_SOURCE" redefined [enabled by default]
<built-in>:0:0: note: this is the location of the previous definition
In file included from backtrace-symbols.c:52:0:
/usr/include/bfd.h:35:2: error: #error config.h must be included before this header
 #error config.h must be included before this header
  ^
Makefile:542: recipe for target 'libmutrace_backtrace_symbols_la-backtrace-symbols.lo' failed
make[1]: *** [libmutrace_backtrace_symbols_la-backtrace-symbols.lo] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-util/mutrace-0.2/work/mutrace-0.2'
Makefile:372: recipe for target 'all' failed
make: *** [all] Error 2
emake failed
 * ERROR: dev-util/mutrace-0.2::gentoo failed (compile phase):
 *   died running emake, base_src_make
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 2001:  Called base_src_compile
 *   environment, line  326:  Called base_src_make
 *   environment, line  364:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "died running emake, $FUNCNAME";
 * 
 * If you need support, post the output of `emerge --info '=dev-util/mutrace-0.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/mutrace-0.2::gentoo'`.
 * The complete build log is located at '/var/log/portage/dev-util:mutrace-0.2:20150117-054136.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/dev-util/mutrace-0.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/mutrace-0.2/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/mutrace-0.2/work/mutrace-0.2'
 * S: '/var/tmp/portage/dev-util/mutrace-0.2/work/mutrace-0.2'


! ! !  This is a build bot chroot located at a hardened amd64 host ! ! !

Portage 2.2.15 (python 3.3.5-final-0, hardened/linux/amd64, gcc-4.8.4, glibc-2.20-r1, 3.17.7-hardened-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.17.7-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16166924 total,   1293324 free
KiB Swap:   16777212 total,  16722372 free
Timestamp of tree: Fri, 16 Jan 2015 19:45:01 +0000
sh bash 4.3_p33
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p33
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.3.5-r1
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.7
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r4, 1.10.3-r1, 1.11.6-r1, 1.15
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.4
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.4
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.18 (virtual/os-headers)
sys-libs/glibc:           2.20-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--nospinner --tree --quiet-build --deep --jobs 1"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://gd.tuwien.ac.at/opsys/linux/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X acl aes-ni alsa amd64 apache2 avx avx2 berkdb bzip2 cli corefonts cracklib crypt cups cxx dbus dnssec dri drmkms dvd ecc ffmpeg fontconfig fortran fpm gdbm git gtk gudev gui hardened iconv isag jpeg justify libvirtd logrotate macvtap mbox minizip mmx modules multilib mysql ncurses nls nptl ogg opengl openmp pam pax_kernel pcre plasma png policykit qemu qt3support qt4 readline session spice sse sse2 sse4 sse4_1 sse4_2 ssh-askpass ssl ssse3 tcpd theora thinkpad threads tk tls truetype uml unicode urandom usb usbredir uxa v4l v4l2 vaapi video vorbis xa xattr xmp xscreensaver xtpax xvfb xvmc zenmap zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19  ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


 build log is stored in /var/log/portage/_emerge_20150117-064202.log
Comment 9 Jason Mours 2015-01-18 05:20:03 UTC
Created attachment 394236 [details]
Newer build log with extended info

Pulled more out showing extended info:

  CC     libmutrace_backtrace_symbols_la-backtrace-symbols.lo
chmod +x mutrace
chmod +x matrace
<command-line>:0:0: warning: "_FORTIFY_SOURCE" redefined [enabled by default]
backtrace-symbols.c:1:0: note: this is the location of the previous definition
<command-line>:0:0: warning: "_FORTIFY_SOURCE" redefined [enabled by default]
matrace.c:1:0: note: this is the location of the previous definition
<command-line>:0:0: warning: "_FORTIFY_SOURCE" redefined [enabled by default]
mutrace.c:1:0: note: this is the location of the previous definition
In file included from backtrace-symbols.c:52:0:
/usr/include/bfd.h:35:2: error: #error config.h must be included before this header
mutrace.c: In function 'setup':
mutrace.c:270:9: warning: '__malloc_hook' is deprecated (declared at /usr/include/malloc.h:175) [-Wdeprecated-declarations]
matrace.c: In function 'setup':
matrace.c:177:9: warning: '__malloc_hook' is deprecated (declared at /usr/include/malloc.h:175) [-Wdeprecated-declarations]
Makefile:542: recipe for target 'libmutrace_backtrace_symbols_la-backtrace-symbols.lo' failed
Comment 10 Pacho Ramos gentoo-dev 2015-03-29 12:46:58 UTC
fixed, thanks